summaryrefslogtreecommitdiff
path: root/dev-perl/CGI-Application
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /dev-perl/CGI-Application
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'dev-perl/CGI-Application')
-rw-r--r--dev-perl/CGI-Application/CGI-Application-4.610.0.ebuild35
-rw-r--r--dev-perl/CGI-Application/Manifest3
-rw-r--r--dev-perl/CGI-Application/metadata.xml13
3 files changed, 51 insertions, 0 deletions
diff --git a/dev-perl/CGI-Application/CGI-Application-4.610.0.ebuild b/dev-perl/CGI-Application/CGI-Application-4.610.0.ebuild
new file mode 100644
index 000000000000..16233b13da96
--- /dev/null
+++ b/dev-perl/CGI-Application/CGI-Application-4.610.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=MARTO
+DIST_VERSION=4.61
+inherit perl-module
+
+DESCRIPTION="Framework for building reusable web-applications"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="minimal test"
+RESTRICT="!test? ( test )"
+RDEPEND="
+ !minimal? (
+ >=dev-perl/CGI-PSGI-0.90.0
+ )
+ >=dev-perl/CGI-4.210.0
+ virtual/perl-Carp
+ dev-perl/Class-ISA
+ dev-perl/HTML-Template
+ virtual/perl-Scalar-List-Utils
+ virtual/perl-libnet
+"
+DEPEND="
+ dev-perl/Module-Build
+"
+BDEPEND="${RDEPEND}
+ >=dev-perl/Module-Build-0.420.0
+ test? (
+ dev-perl/Test-Requires
+ >=virtual/perl-Test-Simple-0.470.0
+ )
+"
diff --git a/dev-perl/CGI-Application/Manifest b/dev-perl/CGI-Application/Manifest
new file mode 100644
index 000000000000..b0d47e83908b
--- /dev/null
+++ b/dev-perl/CGI-Application/Manifest
@@ -0,0 +1,3 @@
+DIST CGI-Application-4.61.tar.gz 77687 BLAKE2B 9cf29f2e691e5b296bd404708ac52961af3aa46cfab600d54e0fafbd4b17cb8e501f19636458e6088806a9ef46b532edb435d12929e41c5e1ff3ec5d8c93057b SHA512 8923323d1c78997f2990303b46177b6b4b725c8b512391e81709acb06c2f8d73417443fa85f441b9d28de5aa75e52b62e6eac1f638c6e629d3661a818f229e4a
+EBUILD CGI-Application-4.610.0.ebuild 667 BLAKE2B 78c5949dfff52213a2ba3487e31fd4ce21a1c158eb2069b3fa641c9e01b3bb3f2e847621b36c9b1e4c78d924fdd7acbe3be68afc9b3cda435379b99ac78d3244 SHA512 6cb7470fab30e4e31f544d0ccbd0887f523d3f8fa01da6cb2c30fb57867ed33291f8b3e07f8b2c0ce06dbe98d2f109f7f05ab518bc3325d0f9c49b96e5858ddb
+MISC metadata.xml 475 BLAKE2B 8254e4d3de413058e0607dc41608f6b5f36b31a277a0ee5bab9674a3315cb911163575d33f92351fcb60d786acb5856991b98bfd911d2a091f7bd19c19253ba4 SHA512 e316e2f72f3b8fe1e6ad4614372bf4d39c6486bf1457bdee45e5237e0d715da0aabd866c96e1b2e0378905092888e3119bc5af33620a77093434e0eca934fd98
diff --git a/dev-perl/CGI-Application/metadata.xml b/dev-perl/CGI-Application/metadata.xml
new file mode 100644
index 000000000000..43fb06cc1535
--- /dev/null
+++ b/dev-perl/CGI-Application/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>perl@gentoo.org</email>
+ <name>Gentoo Perl Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="cpan">CGI-Application</remote-id>
+ <remote-id type="cpan-module">CGI::Application</remote-id>
+ <remote-id type="cpan-module">CGI::Application::Mailform</remote-id>
+ </upstream>
+</pkgmetadata>