summaryrefslogtreecommitdiff
path: root/dev-perl/CGI-Compile
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-perl/CGI-Compile
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-perl/CGI-Compile')
-rw-r--r--dev-perl/CGI-Compile/CGI-Compile-0.220.0.ebuild26
-rw-r--r--dev-perl/CGI-Compile/Manifest4
-rw-r--r--dev-perl/CGI-Compile/files/CGI-Compile-0.210.0-perl-526.patch137
-rw-r--r--dev-perl/CGI-Compile/metadata.xml12
4 files changed, 179 insertions, 0 deletions
diff --git a/dev-perl/CGI-Compile/CGI-Compile-0.220.0.ebuild b/dev-perl/CGI-Compile/CGI-Compile-0.220.0.ebuild
new file mode 100644
index 000000000000..0e88d81b514b
--- /dev/null
+++ b/dev-perl/CGI-Compile/CGI-Compile-0.220.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=MIYAGAWA
+DIST_VERSION=0.22
+inherit perl-module
+
+DESCRIPTION="Compile .cgi scripts to a code reference like ModPerl::Registry"
+SLOT="0"
+KEYWORDS="alpha amd64 ia64 ppc ppc64 sparc x86"
+IUSE="test"
+
+RDEPEND="
+ dev-perl/File-pushd
+"
+DEPEND="${RDEPEND}
+ >=dev-perl/Module-Build-Tiny-0.34.0
+ test? (
+ dev-perl/Test-NoWarnings
+ dev-perl/Test-Requires
+ virtual/perl-Test-Simple
+ )
+"
+PATCHES=("${FILESDIR}/${PN}-0.210.0-perl-526.patch")
diff --git a/dev-perl/CGI-Compile/Manifest b/dev-perl/CGI-Compile/Manifest
new file mode 100644
index 000000000000..a51ea866ff6b
--- /dev/null
+++ b/dev-perl/CGI-Compile/Manifest
@@ -0,0 +1,4 @@
+AUX CGI-Compile-0.210.0-perl-526.patch 2937 BLAKE2B 0cfa79fda11f3e082feb7fa58bff5b3c131476d1076694f9bfee34af87b32b293f6b12f1ee53246589d49c84b9304b14368f4fcd554114b9c141a49ab1334706 SHA512 e9d4589ef1a0deeeb71127173953ce78382d8775e1d8da2f6761707f9eb28ca90e988bdbc4623def2991e94e9c958ee1257d3e8e94abff29ff7203d26dec6f5a
+DIST CGI-Compile-0.22.tar.gz 21160 BLAKE2B a2b8ba4c7f180ec5dc1d48dace853ac37a3c8cbaaa2e1a140b52eca2fe366f59c0229d47cd8738029781ee4cb137db7d646efb55e254dffdb4e0112a107dc2f3 SHA512 58be714bd25975fbb66e4c83c197fa3c17219327859d965011706fda96d5c2f208831e52368c0b4b8ef6b0f462b9c8ea216d94d7ef30e904e21b818b134cc5b7
+EBUILD CGI-Compile-0.220.0.ebuild 559 BLAKE2B 5023293344f2655b7181229de94f9f59bd4e6dee955d7362a0db34012d24ce15c517a7df0eba81d40414ac11d3274182eb500bad3720fe2a615cc9029d0d5682 SHA512 bf6371d0281883b14ead445ca31d9c2cf03cb300d5261f55e74340bd5f7ffb1528efd3a172867cf19fcece57eadce861e85dd9db1413ea835276bac94d897b70
+MISC metadata.xml 394 BLAKE2B 672aeee83d2a9f29dbc89bbd9c1a19bcd4c611f54d8608780cf9662b7e879cc58eae26cef6c8b19e12bf6c8debb6163ea607674fa08d2a40f4b0f7810fb8a6b2 SHA512 7d0c50b0b8c75c5ddce5b77400b88223a3481a1615071c6e32d9dd491b6c8d7a85abfc8309e16407c1886a12a5a4dc312cf8c2ec7c0c07e10c26707a2dd710f3
diff --git a/dev-perl/CGI-Compile/files/CGI-Compile-0.210.0-perl-526.patch b/dev-perl/CGI-Compile/files/CGI-Compile-0.210.0-perl-526.patch
new file mode 100644
index 000000000000..74945fb94886
--- /dev/null
+++ b/dev-perl/CGI-Compile/files/CGI-Compile-0.210.0-perl-526.patch
@@ -0,0 +1,137 @@
+From dc9437c949a4f44ca8b36bbf974d6a49337c67b4 Mon Sep 17 00:00:00 2001
+From: Kent Fredric <kentnl@gentoo.org>
+Date: Sun, 1 Oct 2017 04:10:33 +1300
+Subject: Fix tests failure on Perl 5.26+ with PERL_USE_UNSAFE_INC=0
+
+Bug: https://github.com/miyagawa/CGI-Compile/issues/21
+Bug: https://bugs.gentoo.org/614352
+---
+ t/Capture.pm | 3 ++-
+ t/coderef_args.t | 3 ++-
+ t/compile.t | 3 ++-
+ t/data_end.t | 4 +++-
+ t/exit.t | 2 +-
+ t/local-SIG.t | 3 ++-
+ t/source.t | 3 ++-
+ t/source_filter.t | 3 ++-
+ t/warnings.t | 3 ++-
+ 9 files changed, 18 insertions(+), 9 deletions(-)
+
+diff --git a/t/Capture.pm b/t/Capture.pm
+index 476f80d..2331b33 100644
+--- a/t/Capture.pm
++++ b/t/Capture.pm
+@@ -1,4 +1,5 @@
+-package t::Capture;
++package # Hide from PAUSE
++ Capture;
+ use base qw(Exporter);
+ our @EXPORT = qw(capture_out);
+
+diff --git a/t/coderef_args.t b/t/coderef_args.t
+index 8d9c1b4..89720dd 100644
+--- a/t/coderef_args.t
++++ b/t/coderef_args.t
+@@ -1,5 +1,6 @@
+ use Test::More;
+-use t::Capture;
++use lib 't';
++use Capture;
+ use CGI::Compile;
+
+ my $sub = CGI::Compile->compile("t/args.cgi");
+diff --git a/t/compile.t b/t/compile.t
+index db42283..f302f9b 100644
+--- a/t/compile.t
++++ b/t/compile.t
+@@ -1,6 +1,7 @@
+ use Test::More;
+ use Test::Requires qw(CGI);
+-use t::Capture;
++use lib 't';
++use Capture;
+ use CGI::Compile;
+ #no warnings 'signal'; # for MSWin32
+
+diff --git a/t/data_end.t b/t/data_end.t
+index af468f7..175641f 100644
+--- a/t/data_end.t
++++ b/t/data_end.t
+@@ -1,6 +1,8 @@
+ use Test::More;
+ use CGI::Compile;
+-use t::Capture;
++
++use lib 't';
++use Capture;
+
+ {
+ my $sub = CGI::Compile->compile("t/data.cgi");
+diff --git a/t/exit.t b/t/exit.t
+index b98b28a..2167b1c 100644
+--- a/t/exit.t
++++ b/t/exit.t
+@@ -1,8 +1,8 @@
+ use strict;
+ use Test::More tests => 2;
+ use CGI::Compile;
+-use t::Capture;
+ use lib "t";
++use Capture;
+ use Exit;
+
+ my $sub = CGI::Compile->compile("t/exit.cgi");
+diff --git a/t/local-SIG.t b/t/local-SIG.t
+index b781c05..68f733e 100644
+--- a/t/local-SIG.t
++++ b/t/local-SIG.t
+@@ -1,6 +1,7 @@
+ #!perl
+
+-use t::Capture;
++use lib 't';
++use Capture;
+ use CGI::Compile;
+ use POSIX qw(:signal_h);
+
+diff --git a/t/source.t b/t/source.t
+index e212244..b101632 100644
+--- a/t/source.t
++++ b/t/source.t
+@@ -1,6 +1,7 @@
+ use Test::More;
+ use CGI::Compile;
+-use t::Capture;
++use lib 't';
++use Capture;
+
+ {
+ my $str =<<EOL;
+diff --git a/t/source_filter.t b/t/source_filter.t
+index 8b84e0c..51b11b2 100644
+--- a/t/source_filter.t
++++ b/t/source_filter.t
+@@ -1,6 +1,7 @@
+ use Test::More;
+ use Test::Requires qw(Switch);
+-use t::Capture;
++use lib 't';
++use Capture;
+ use CGI::Compile;
+
+ my $sub = eval {
+diff --git a/t/warnings.t b/t/warnings.t
+index 5962aae..0d044cb 100644
+--- a/t/warnings.t
++++ b/t/warnings.t
+@@ -1,5 +1,6 @@
+ use Test::More;
+-use t::Capture;
++use lib 't';
++use Capture;
+ use CGI::Compile;
+
+ my $sub = CGI::Compile->compile("t/warnings.cgi");
+--
+2.14.1
+
diff --git a/dev-perl/CGI-Compile/metadata.xml b/dev-perl/CGI-Compile/metadata.xml
new file mode 100644
index 000000000000..c6f78b9fa272
--- /dev/null
+++ b/dev-perl/CGI-Compile/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>perl@gentoo.org</email>
+ <name>Gentoo Perl Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="cpan">CGI-Compile</remote-id>
+ <remote-id type="cpan-module">CGI::Compile</remote-id>
+ </upstream>
+</pkgmetadata>