summaryrefslogtreecommitdiff
path: root/dev-perl/CGI-Session
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-perl/CGI-Session
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-perl/CGI-Session')
-rw-r--r--dev-perl/CGI-Session/CGI-Session-4.480.0-r1.ebuild29
-rw-r--r--dev-perl/CGI-Session/CGI-Session-4.480.0-r2.ebuild27
-rw-r--r--dev-perl/CGI-Session/Manifest4
-rw-r--r--dev-perl/CGI-Session/metadata.xml29
4 files changed, 89 insertions, 0 deletions
diff --git a/dev-perl/CGI-Session/CGI-Session-4.480.0-r1.ebuild b/dev-perl/CGI-Session/CGI-Session-4.480.0-r1.ebuild
new file mode 100644
index 000000000000..e9ab02ce4e8f
--- /dev/null
+++ b/dev-perl/CGI-Session/CGI-Session-4.480.0-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+MODULE_AUTHOR=MARKSTOS
+MODULE_VERSION=4.48
+inherit perl-module
+
+DESCRIPTION="persistent session data in CGI applications"
+
+SLOT="0"
+KEYWORDS="amd64 ~hppa ~ppc x86"
+IUSE="test"
+
+RDEPEND="
+ virtual/perl-Digest-MD5
+ virtual/perl-Scalar-List-Utils
+ >=dev-perl/CGI-3.26
+"
+DEPEND="${RDEPEND}
+ >=dev-perl/Module-Build-0.380.0
+ test? (
+ virtual/perl-Test-Simple
+ dev-perl/CGI-Simple
+ )
+"
+
+SRC_TEST="do"
diff --git a/dev-perl/CGI-Session/CGI-Session-4.480.0-r2.ebuild b/dev-perl/CGI-Session/CGI-Session-4.480.0-r2.ebuild
new file mode 100644
index 000000000000..4614a2b2b0ad
--- /dev/null
+++ b/dev-perl/CGI-Session/CGI-Session-4.480.0-r2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=MARKSTOS
+DIST_VERSION=4.48
+inherit perl-module
+
+DESCRIPTION="persistent session data in CGI applications"
+
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~x86"
+IUSE="test"
+
+RDEPEND="
+ virtual/perl-Digest-MD5
+ virtual/perl-Scalar-List-Utils
+ >=dev-perl/CGI-3.26
+"
+DEPEND="${RDEPEND}
+ >=dev-perl/Module-Build-0.380.0
+ test? (
+ virtual/perl-Test-Simple
+ dev-perl/CGI-Simple
+ )
+"
diff --git a/dev-perl/CGI-Session/Manifest b/dev-perl/CGI-Session/Manifest
new file mode 100644
index 000000000000..5bd9f231ce9b
--- /dev/null
+++ b/dev-perl/CGI-Session/Manifest
@@ -0,0 +1,4 @@
+DIST CGI-Session-4.48.tar.gz 95291 BLAKE2B d1d915c85e230ec73575d56cc92589c45a5f6d35f52737b5cefa61704cfc42aeb6682e3e56e1b8cb015ff2d55b141dcfe01ad4fe376e70ff17014edd3951a531 SHA512 82d6a498035b91474df712fdae2c9ce7290157ddec36095757f16b5cbce593d3b5115077c722350d1c890c299230f7489a41328ed64b85a0f4c3cfff8aceef54
+EBUILD CGI-Session-4.480.0-r1.ebuild 513 BLAKE2B 1875700b7c9297f8aab0332e2de9f747740aac2ba60880fd4d4dc34dbf3890acbd16166c5ba41ccb9134deb8ef65a6aa472f8a7b86d00ca99eae818849ea27b7 SHA512 6f9f82f6e5703a87a9518abac9f020377d01be90c40051a63323451a00304f441b092a3635e5a39f06c3eedd20bdd60c2d5901784f002c1f7691edeb0ec009ec
+EBUILD CGI-Session-4.480.0-r2.ebuild 496 BLAKE2B 3b4b1597edd148ddbd2f66860dab5d465a12e622724d8720cdd7676516f8eff483cdad19897921402377e6f6801cd328aff65c0ada59d7723850cc13a45b5354 SHA512 cbbbdb4c490ca570591714506c3d74e2bb2778ad398c083511285b0efc6d1169cd2a2fedda309cc031d80315197c026afc661d6e32238c2369abea7c4e7a55d9
+MISC metadata.xml 1637 BLAKE2B 27d43c41f9acb206c4d50b34971d917c412aba3fde8cce4c1a08dd7250f154440f49d025533f67370f59206ccea949e2e8ca9a0092c3c58cfc422f11e4df9ffc SHA512 00f923a38d667b785fffd9543d724f0eb8d016562bdbba08b24b567128972461ee8816eeea66e9b14c77bdc8ba0317d36fa7217986088fbb642db9781524e2f1
diff --git a/dev-perl/CGI-Session/metadata.xml b/dev-perl/CGI-Session/metadata.xml
new file mode 100644
index 000000000000..648b4fdd2d86
--- /dev/null
+++ b/dev-perl/CGI-Session/metadata.xml
@@ -0,0 +1,29 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>perl@gentoo.org</email>
+ <name>Gentoo Perl Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="cpan">CGI-Session</remote-id>
+ <remote-id type="cpan-module">CGI::Session</remote-id>
+ <remote-id type="cpan-module">CGI::Session::Driver</remote-id>
+ <remote-id type="cpan-module">CGI::Session::Driver::DBI</remote-id>
+ <remote-id type="cpan-module">CGI::Session::Driver::db_file</remote-id>
+ <remote-id type="cpan-module">CGI::Session::Driver::file</remote-id>
+ <remote-id type="cpan-module">CGI::Session::Driver::mysql</remote-id>
+ <remote-id type="cpan-module">CGI::Session::Driver::postgresql</remote-id>
+ <remote-id type="cpan-module">CGI::Session::Driver::sqlite</remote-id>
+ <remote-id type="cpan-module">CGI::Session::ErrorHandler</remote-id>
+ <remote-id type="cpan-module">CGI::Session::ID::incr</remote-id>
+ <remote-id type="cpan-module">CGI::Session::ID::md5</remote-id>
+ <remote-id type="cpan-module">CGI::Session::ID::static</remote-id>
+ <remote-id type="cpan-module">CGI::Session::Serialize::default</remote-id>
+ <remote-id type="cpan-module">CGI::Session::Serialize::freezethaw</remote-id>
+ <remote-id type="cpan-module">CGI::Session::Serialize::storable</remote-id>
+ <remote-id type="cpan-module">CGI::Session::Test::Default</remote-id>
+ <remote-id type="cpan-module">CGI::Session::Tutorial</remote-id>
+ <remote-id type="cpan-module">OverloadedClass</remote-id>
+ </upstream>
+</pkgmetadata>