summaryrefslogtreecommitdiff
path: root/dev-perl/Const-Fast/Const-Fast-0.14.0-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-06-29 11:38:31 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-06-29 11:38:31 +0100
commit90c88731bd036e5698b281fbc0a5f3aa4c9983ac (patch)
tree83fc5facb6b12be510a37bc3d241cc63e965b13a /dev-perl/Const-Fast/Const-Fast-0.14.0-r2.ebuild
parentfeb0daf81d888e9160f9f94502de09b66f2a63fd (diff)
gentoo resync : 29.06.2020
Diffstat (limited to 'dev-perl/Const-Fast/Const-Fast-0.14.0-r2.ebuild')
-rw-r--r--dev-perl/Const-Fast/Const-Fast-0.14.0-r2.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-perl/Const-Fast/Const-Fast-0.14.0-r2.ebuild b/dev-perl/Const-Fast/Const-Fast-0.14.0-r2.ebuild
new file mode 100644
index 000000000000..27a9d59ba25f
--- /dev/null
+++ b/dev-perl/Const-Fast/Const-Fast-0.14.0-r2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=LEONT
+DIST_VERSION=0.014
+inherit perl-module
+
+DESCRIPTION="Facility for creating read-only scalars, arrays, and hashes"
+
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ virtual/perl-Scalar-List-Utils
+ virtual/perl-Storable
+ >=dev-perl/Sub-Exporter-Progressive-0.1.7
+"
+DEPEND="
+ dev-perl/Module-Build-Tiny
+"
+BDEPEND="${RDEPEND}
+ >=dev-perl/Module-Build-Tiny-0.21.0
+ test? (
+ virtual/perl-Data-Dumper
+ virtual/perl-File-Temp
+ dev-perl/Test-Fatal
+ >=virtual/perl-Test-Simple-0.880.0
+ )
+"