summaryrefslogtreecommitdiff
path: root/dev-perl/Convert-Binary-C
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-perl/Convert-Binary-C
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-perl/Convert-Binary-C')
-rw-r--r--dev-perl/Convert-Binary-C/Convert-Binary-C-0.780.0-r1.ebuild26
-rw-r--r--dev-perl/Convert-Binary-C/Manifest4
-rw-r--r--dev-perl/Convert-Binary-C/files/Convert-Binary-C-0.780.0-perl-526.patch181
-rw-r--r--dev-perl/Convert-Binary-C/metadata.xml13
4 files changed, 224 insertions, 0 deletions
diff --git a/dev-perl/Convert-Binary-C/Convert-Binary-C-0.780.0-r1.ebuild b/dev-perl/Convert-Binary-C/Convert-Binary-C-0.780.0-r1.ebuild
new file mode 100644
index 000000000000..13dd86b53695
--- /dev/null
+++ b/dev-perl/Convert-Binary-C/Convert-Binary-C-0.780.0-r1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=MHX
+DIST_VERSION=0.78
+# NB: Examples are generated
+DIST_EXAMPLES=("examples/*")
+inherit perl-module
+
+DESCRIPTION="Binary Data Conversion using C Types"
+
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+# bison >= 1.31?
+DEPEND="virtual/perl-ExtUtils-MakeMaker"
+
+MAKEOPTS+=" -j1"
+PATCHES=( "${FILESDIR}/${P}-perl-526.patch" )
+src_test() {
+ perl_rm_files tests/802_pod.t tests/803_pod_coverage.t
+ perl-module_src_test
+}
diff --git a/dev-perl/Convert-Binary-C/Manifest b/dev-perl/Convert-Binary-C/Manifest
new file mode 100644
index 000000000000..3ca12c0eda35
--- /dev/null
+++ b/dev-perl/Convert-Binary-C/Manifest
@@ -0,0 +1,4 @@
+AUX Convert-Binary-C-0.780.0-perl-526.patch 5389 BLAKE2B 458c7dedc257f04d79edc1fa49dadeb72393874c1956ea8d7c8f382e81f5131691a5f7120b340437efa8278928403469b5b1a76157822e5438b82888cbcc6f9c SHA512 c6bffca0fe3bdf47d32821f6fff033828f03c4a26e23c4097556f0134a40e01bc47cae5672707cd875f11b9f63a1877b096eec76349e35e99ba4a1c4284aad4a
+DIST Convert-Binary-C-0.78.tar.gz 1564698 BLAKE2B 220f6221769a9907d9dcadd6ba6ffcd04114cdc8d03d4a63a43f95a492b7fa45fa97451c4dbda64bb54e9053914f0ab75821f9d6b84ae6e8b266c9cf89c9be41 SHA512 d9b85ce2ae870c2de6c2fa0838a6b20000ec8d33f19a989f8ebe1b026f2796ae7e924391a0fe387310a3217c75dcd797ea819ff964a9c3e448d007c16d41040c
+EBUILD Convert-Binary-C-0.780.0-r1.ebuild 535 BLAKE2B 819983cb503898300ed93b7f366195fa40e1d7f515891396a907174f9f6bc45df74f979fddba49c5a69efb984c95e97bb38e3151ba258cb299db0b61bf33b476 SHA512 c2f4629fa0806565e48709859d236304f317ab1a3550de6e69cfdfcd621683d6877b1756d9d2d5a8d50754a6a035ead89b238b55f483016dbb6918fe576b13ee
+MISC metadata.xml 478 BLAKE2B 0dab96e21fa8a982057859969e3ff5be89591a8141365a55abab6b12165243c20f81ba724af8fb5f1d0364face2606724567aa4d03cb2975eac7e5a554889f23 SHA512 589fee143714f35bf258db7a23b2d7539dd311b891f1c5132a8018f911296aa38fa45237a72be8fcbe38b890fb401d60bcb380cd1793eccfbc4287c114c0cda5
diff --git a/dev-perl/Convert-Binary-C/files/Convert-Binary-C-0.780.0-perl-526.patch b/dev-perl/Convert-Binary-C/files/Convert-Binary-C-0.780.0-perl-526.patch
new file mode 100644
index 000000000000..2c61d6178bc5
--- /dev/null
+++ b/dev-perl/Convert-Binary-C/files/Convert-Binary-C-0.780.0-perl-526.patch
@@ -0,0 +1,181 @@
+From 26c2c60f11cf649f348a5af2c15f83525f02bf30 Mon Sep 17 00:00:00 2001
+From: Kent Fredric <kentfredric@gmail.com>
+Date: Wed, 20 Sep 2017 08:00:50 +1200
+Subject: Fix tests for Perl 5.26
+
+Bug: https://rt.cpan.org/Public/Bug/Display.html?id=121039
+Bug: https://bugs.gentoo.org/615106
+Bug: https://github.com/mhx/Convert-Binary-C/pull/6
+---
+ bin/perltypes.PL | 3 ++-
+ tests/206_parse.t | 4 ++--
+ tests/209_sourcify.t | 2 +-
+ tests/210_depend.t | 2 +-
+ tests/211_clone.t | 2 +-
+ tests/215_local.t | 2 +-
+ tests/218_member.t | 2 +-
+ tests/223_initializer.t | 2 +-
+ tests/230_compiler.t | 2 +-
+ tests/601_speed.t | 2 +-
+ tests/602_threads.t | 2 +-
+ 11 files changed, 13 insertions(+), 12 deletions(-)
+
+diff --git a/bin/perltypes.PL b/bin/perltypes.PL
+index 09ca5d2..be63ffd 100755
+--- a/bin/perltypes.PL
++++ b/bin/perltypes.PL
+@@ -21,10 +21,11 @@ print OUT <<'!NO!SUBS!';
+
+ use Convert::Binary::C;
+ use Data::Dumper;
++use File::Spec::Functions qw(rel2abs);
+ use strict;
+
+ my $base;
+--d "$_/include" and $base = "$_/include" and last for qw( tests ../tests );
++-d "$_/include" and $base = rel2abs("$_/include") and last for qw( tests ../tests );
+ defined $base or die <<MSG;
+ Please run this script from either the 'examples' directory
+ or the distribution base directory.
+diff --git a/tests/206_parse.t b/tests/206_parse.t
+index 6e34d63..a4c403f 100644
+--- a/tests/206_parse.t
++++ b/tests/206_parse.t
+@@ -13,7 +13,7 @@ $^W = 1;
+
+ BEGIN { plan tests => 116 }
+
+-my $CCCFG = require 'tests/include/config.pl';
++my $CCCFG = require './tests/include/config.pl';
+
+ #===================================================================
+ # create object (1 tests)
+@@ -140,7 +140,7 @@ ok($s1,329,"incorrect number of typedef identifiers");
+ # check if all sizes are correct (1 big test)
+ #===================================================================
+
+-do 'tests/include/sizeof.pl';
++do './tests/include/sizeof.pl';
+ $max_size = 0;
+ @fail = ();
+ @success = ();
+diff --git a/tests/209_sourcify.t b/tests/209_sourcify.t
+index 3fbdae6..0f34e83 100644
+--- a/tests/209_sourcify.t
++++ b/tests/209_sourcify.t
+@@ -13,7 +13,7 @@ $^W = 1;
+
+ BEGIN { plan tests => 98 }
+
+-my $CCCFG = require 'tests/include/config.pl';
++my $CCCFG = require './tests/include/config.pl';
+
+ eval {
+ $orig = new Convert::Binary::C %$CCCFG;
+diff --git a/tests/210_depend.t b/tests/210_depend.t
+index b46fdf7..e2705fd 100644
+--- a/tests/210_depend.t
++++ b/tests/210_depend.t
+@@ -13,7 +13,7 @@ $^W = 1;
+
+ BEGIN { plan tests => 483 }
+
+-my $CCCFG = require 'tests/include/config.pl';
++my $CCCFG = require './tests/include/config.pl';
+
+ eval {
+ $c1 = new Convert::Binary::C Include => ['tests/include/files'];
+diff --git a/tests/211_clone.t b/tests/211_clone.t
+index 252554f..144de70 100644
+--- a/tests/211_clone.t
++++ b/tests/211_clone.t
+@@ -13,7 +13,7 @@ $^W = 1;
+
+ BEGIN { plan tests => 35 }
+
+-my $CCCFG = require 'tests/include/config.pl';
++my $CCCFG = require './tests/include/config.pl';
+
+ eval {
+ $orig = new Convert::Binary::C %$CCCFG;
+diff --git a/tests/215_local.t b/tests/215_local.t
+index dabf7fc..2f2dffe 100644
+--- a/tests/215_local.t
++++ b/tests/215_local.t
+@@ -15,7 +15,7 @@ BEGIN {
+ plan tests => 10;
+ }
+
+-my $CCCFG = require 'tests/include/config.pl';
++my $CCCFG = require './tests/include/config.pl';
+
+ eval {
+ $c = new Convert::Binary::C;
+diff --git a/tests/218_member.t b/tests/218_member.t
+index e212160..7966e44 100644
+--- a/tests/218_member.t
++++ b/tests/218_member.t
+@@ -15,7 +15,7 @@ BEGIN {
+ plan tests => 1907;
+ }
+
+-my $CCCFG = require 'tests/include/config.pl';
++my $CCCFG = require './tests/include/config.pl';
+
+ %basic = ( char => 1, short => 1, int => 1,
+ long => 1, signed => 1, unsigned => 1,
+diff --git a/tests/223_initializer.t b/tests/223_initializer.t
+index a80d741..f1d6b26 100644
+--- a/tests/223_initializer.t
++++ b/tests/223_initializer.t
+@@ -13,7 +13,7 @@ $^W = 1;
+
+ BEGIN { plan tests => 27 }
+
+-my $CCCFG = require 'tests/include/config.pl';
++my $CCCFG = require './tests/include/config.pl';
+
+ $c = eval { new Convert::Binary::C %$CCCFG };
+ ok($@,'',"failed to create Convert::Binary::C objects");
+diff --git a/tests/230_compiler.t b/tests/230_compiler.t
+index 1cc67f1..276275a 100644
+--- a/tests/230_compiler.t
++++ b/tests/230_compiler.t
+@@ -37,7 +37,7 @@ for my $cur (sort keys %cc) {
+ $bin =~ s/\s+//gms;
+ $bin = pack "H*", $bin;
+
+- do $cc{$cur}{cfg};
++ do "./$cc{$cur}{cfg}";
+
+ my $c = new Convert::Binary::C %config;
+ $c->parse_file('tests/compiler/test.h');
+diff --git a/tests/601_speed.t b/tests/601_speed.t
+index 27f1fc9..d399e38 100644
+--- a/tests/601_speed.t
++++ b/tests/601_speed.t
+@@ -16,7 +16,7 @@ BEGIN {
+ plan tests => 11;
+ }
+
+-my $CCCFG = require 'tests/include/config.pl';
++my $CCCFG = require './tests/include/config.pl';
+
+ eval { require Data::Dumper }; $Data_Dumper = $@;
+ eval { require IO::File }; $IO_File = $@;
+diff --git a/tests/602_threads.t b/tests/602_threads.t
+index 8e45b0d..968939b 100644
+--- a/tests/602_threads.t
++++ b/tests/602_threads.t
+@@ -17,7 +17,7 @@ BEGIN {
+ plan tests => NUM_THREADS
+ }
+
+-my $CCCFG = require 'tests/include/config.pl';
++my $CCCFG = require './tests/include/config.pl';
+
+ #===================================================================
+ # load appropriate threads module and start a couple of threads
+--
+2.14.1
+
diff --git a/dev-perl/Convert-Binary-C/metadata.xml b/dev-perl/Convert-Binary-C/metadata.xml
new file mode 100644
index 000000000000..56b56d9d9eb5
--- /dev/null
+++ b/dev-perl/Convert-Binary-C/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>perl@gentoo.org</email>
+ <name>Gentoo Perl Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="cpan">Convert-Binary-C</remote-id>
+ <remote-id type="cpan-module">Convert::Binary::C</remote-id>
+ <remote-id type="cpan-module">Convert::Binary::C::Cached</remote-id>
+ </upstream>
+</pkgmetadata>