summaryrefslogtreecommitdiff
path: root/dev-perl/Devel-NYTProf
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-perl/Devel-NYTProf
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-perl/Devel-NYTProf')
-rw-r--r--dev-perl/Devel-NYTProf/Devel-NYTProf-6.40.0.ebuild37
-rw-r--r--dev-perl/Devel-NYTProf/Manifest6
-rw-r--r--dev-perl/Devel-NYTProf/files/Devel-NYTProf-6.40.0-perl526.patch41
-rw-r--r--dev-perl/Devel-NYTProf/metadata.xml24
4 files changed, 108 insertions, 0 deletions
diff --git a/dev-perl/Devel-NYTProf/Devel-NYTProf-6.40.0.ebuild b/dev-perl/Devel-NYTProf/Devel-NYTProf-6.40.0.ebuild
new file mode 100644
index 000000000000..ca15e9d531fa
--- /dev/null
+++ b/dev-perl/Devel-NYTProf/Devel-NYTProf-6.40.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=TIMB
+DIST_VERSION=6.04
+DIST_EXAMPLES=("demo/*")
+inherit perl-module
+
+DESCRIPTION="Powerful feature-rich perl source code profiler"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ >=dev-perl/File-Which-1.90.0
+ virtual/perl-Getopt-Long
+ dev-perl/JSON-MaybeXS
+ virtual/perl-Scalar-List-Utils
+ virtual/perl-XSLoader
+ sys-libs/zlib
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ >=virtual/perl-Test-Simple-0.840.0
+ >=dev-perl/Test-Differences-0.60.0
+ )
+"
+PATCHES=( "${FILESDIR}/${P}-perl526.patch" )
+src_test() {
+ perl_rm_files t/90-pod.t t/91-pod_coverage.t t/92-file_port.t \
+ t/71-moose.t t/72-autodie.t t/68-hashline.t
+ perl-module_src_test
+}
diff --git a/dev-perl/Devel-NYTProf/Manifest b/dev-perl/Devel-NYTProf/Manifest
new file mode 100644
index 000000000000..a80380949673
--- /dev/null
+++ b/dev-perl/Devel-NYTProf/Manifest
@@ -0,0 +1,6 @@
+AUX Devel-NYTProf-6.40.0-perl526.patch 1403 SHA256 edc401bd935f39ada77e5d418b81b7984b9c1aa2f6b106a7e0e353b44a590d8a SHA512 ceb987196321b7e08bd8d1b83cff802ae66fc7a82642e9e0a8b578ecc42af7a859da4cc2028112febfbc74b584e3b75f3307be864cc6eacf6fdf9568e574ce42 WHIRLPOOL b5bf6568e6a7e4978cbe2c8066830d9e7ad18535f809e8dde50e23314ae60ea47abcded1654cc02f5f1f5313c22f6d49c488ffb47aa495bcb2cc1ede710a0e0e
+DIST Devel-NYTProf-6.04.tar.gz 461716 SHA256 c04c9f03663b7e4e9cc159f30bcdc0bab5652889c88c425ec157e831318d4891 SHA512 67b5013f4b3e54db743964f91fd8113fbe672be81026aae3375e9bb5376205d735c91ddbde05784a7df235a8e43ef3db2713e396c13e45726ca594e1e76d051c WHIRLPOOL f5fce257b4a71b44943bdd5f0328743359c40cad4fa50b7e0d17ba7f16bc15b9cb4c2c2815f8cc4cec4671a84723ef60ee900df7ffe6f85c7bda7fb671abf26a
+EBUILD Devel-NYTProf-6.40.0.ebuild 799 SHA256 822cfaf7189ff8ba8131ea10bf4e905fcc7db6736b07ede4cb610fef94b4e96c SHA512 a20141f5069364c98a8c8ccf9de2001049a49210034aacd3065b01758732cef53b6b6605232cfc6b2c3663d01ab0116aff2c71fb91058626f36db872808df18f WHIRLPOOL 95a5b106d4a94c2c0e601abe13bf98fec1db8b27bafe82f2722be5ebb76c39aeaa7690a8b34e06c596142ba4613009752e8c22bab1657ad8fa2c109939bde098
+MISC ChangeLog 3875 SHA256 3c402fef93051230545bef1830afb46fb3660662c90c997a3b981e19ece064d6 SHA512 7f8ccf4db3128f401df7d28a366f950ee2446ecd0c5860107c765b573cc529c71dd711387ac9d75407831bdef760ae7f8923c7d45a7eef6893855e49be2ef5cc WHIRLPOOL 2c7286a91242e9224e7d5ee2d77230f0c198100de310257ee839f6ea0e68cd967dbe2f1b311024ecd0354f6ba0e4cd8467ae628a0e3e065e2a9e57cb75e74671
+MISC ChangeLog-2015 4840 SHA256 265594a704ffc99639a43c04d932dcf7c1048c75a31d9b5c93d7b61ad45cd543 SHA512 329ce833b16e68e5949e77f6e1c2e852ca687ae357b99a4433b654ed1ceb04bb38cc5a332ff78544a1ed362c0d1c705d86733d065f0780f654a2af5a27edfc50 WHIRLPOOL 4db27e6d451f0ee6cdc0efdbfb58a4cba57bc5e4fce1b229a3f4a32638e136cc542bde4091f30bc190b60677e94950e539e28bf5cc9fea8a766a6e3af72110d6
+MISC metadata.xml 1236 SHA256 8a09af280faab57ace7f85aaa06861bf96824dd75a458fb2d80cd30d24666e30 SHA512 c113998d635e62bd13406b2c8112485f6b3bb0bf7efcf2f60d50eb176ed82fe4ed85263545c7ad5d680b752c12523ee7e1cf30eb4c9d3e20a6c256f89be75361 WHIRLPOOL 40be6c412627a35a1c4fe359bb6040c08b384df4f1aa306a2aa9013698ee82672920e0ca3b7d3683f1ee8ee0c089439117ade58f6169233721c5bb7d20268d0b
diff --git a/dev-perl/Devel-NYTProf/files/Devel-NYTProf-6.40.0-perl526.patch b/dev-perl/Devel-NYTProf/files/Devel-NYTProf-6.40.0-perl526.patch
new file mode 100644
index 000000000000..cd81f120dddb
--- /dev/null
+++ b/dev-perl/Devel-NYTProf/files/Devel-NYTProf-6.40.0-perl526.patch
@@ -0,0 +1,41 @@
+From 461055d041e0e08f5fe851461db42ea7121fa39f Mon Sep 17 00:00:00 2001
+From: Kent Fredric <kentnl@gentoo.org>
+Date: Sun, 8 Oct 2017 07:44:14 +1300
+Subject: Fix test failures on Perl 5.26 w/ PERL_USE_UNSAFE_INC=0
+
+Perl 5.26+ removes '.' from the default @INC, and this breaks the
+mechanism internally where @INC-prefixes are stripped from fid_fileinfo
+names ( in ::FileInfo.pm ).
+
+This breaks tests due to the sample 'rdt' files expecting single-token
+comparators relative to 't/', instead getting a fully qualified path in
+the "got" side of the test.
+
+This remedies this by ensuring a fully-qualified path to "t/" is in
+@INC for the aforementioned prefix-stripper to pick-up on.
+
+Bug: https://github.com/timbunce/devel-nytprof/issues/108
+Bug: https://bugs.gentoo.org/615734
+Bug: https://github.com/timbunce/devel-nytprof/pull/112
+---
+ t/lib/NYTProfTest.pm | 4 ++++
+ 1 file changed, 4 insertions(+)
+
+diff --git a/t/lib/NYTProfTest.pm b/t/lib/NYTProfTest.pm
+index 9c29627..7fb5381 100644
+--- a/t/lib/NYTProfTest.pm
++++ b/t/lib/NYTProfTest.pm
+@@ -69,6 +69,10 @@ my $text_extn_info = {
+ pf => { order => 50, tests => 2, },
+ };
+
++# having t/* in @INC is necessary for prefix-stripping
++# to reduce test-file names down to the single tokens
++# that are used in the comparison-output files.
++unshift @INC, File::Spec->rel2abs('./t') if -d 't';
+ chdir('t') if -d 't';
+
+ if (-d '../blib') {
+--
+2.14.1
+
diff --git a/dev-perl/Devel-NYTProf/metadata.xml b/dev-perl/Devel-NYTProf/metadata.xml
new file mode 100644
index 000000000000..c4728df9c2ea
--- /dev/null
+++ b/dev-perl/Devel-NYTProf/metadata.xml
@@ -0,0 +1,24 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>perl@gentoo.org</email>
+ <name>Gentoo Perl Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="cpan">Devel-NYTProf</remote-id>
+ <remote-id type="cpan-module">Devel::NYTProf</remote-id>
+ <remote-id type="cpan-module">Devel::NYTProf::Apache</remote-id>
+ <remote-id type="cpan-module">Devel::NYTProf::Constants</remote-id>
+ <remote-id type="cpan-module">Devel::NYTProf::Core</remote-id>
+ <remote-id type="cpan-module">Devel::NYTProf::Data</remote-id>
+ <remote-id type="cpan-module">Devel::NYTProf::FileHandle</remote-id>
+ <remote-id type="cpan-module">Devel::NYTProf::FileInfo</remote-id>
+ <remote-id type="cpan-module">Devel::NYTProf::ReadStream</remote-id>
+ <remote-id type="cpan-module">Devel::NYTProf::Reader</remote-id>
+ <remote-id type="cpan-module">Devel::NYTProf::Run</remote-id>
+ <remote-id type="cpan-module">Devel::NYTProf::SubCallInfo</remote-id>
+ <remote-id type="cpan-module">Devel::NYTProf::SubInfo</remote-id>
+ <remote-id type="cpan-module">Devel::NYTProf::Util</remote-id>
+ </upstream>
+</pkgmetadata>