summaryrefslogtreecommitdiff
path: root/dev-perl/File-RsyncP
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-21 11:40:40 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-21 11:40:40 +0000
commitbae478b64a6bc9eca66b65bcfa318fc21e7f34bb (patch)
treef713006fd9c119e5dbb3bdafe7d695d2644da94c /dev-perl/File-RsyncP
parent374561aeaff53ce5a2836af934749923b4ea3763 (diff)
gentoo auto-resync : 21:01:2023 - 11:40:40
Diffstat (limited to 'dev-perl/File-RsyncP')
-rw-r--r--dev-perl/File-RsyncP/File-RsyncP-0.760.0-r1.ebuild38
-rw-r--r--dev-perl/File-RsyncP/Manifest3
-rw-r--r--dev-perl/File-RsyncP/files/File-RsyncP-0.760.0-clang16.patch188
-rw-r--r--dev-perl/File-RsyncP/files/File-RsyncP-0.760.0-lto.patch40
4 files changed, 269 insertions, 0 deletions
diff --git a/dev-perl/File-RsyncP/File-RsyncP-0.760.0-r1.ebuild b/dev-perl/File-RsyncP/File-RsyncP-0.760.0-r1.ebuild
new file mode 100644
index 000000000000..2c19a775d327
--- /dev/null
+++ b/dev-perl/File-RsyncP/File-RsyncP-0.760.0-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=CBARRATT
+DIST_VERSION=0.76
+inherit perl-module toolchain-funcs
+
+DESCRIPTION="An rsync perl module"
+HOMEPAGE="http://perlrsync.sourceforge.net/ https://metacpan.org/release/File-RsyncP"
+# Bundled files make for some weirdness
+LICENSE="GPL-3+ GPL-2+ RSA"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+RDEPEND="
+ >=virtual/perl-Getopt-Long-2.240.0
+ net-misc/rsync
+"
+BDEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-0.700.0-make.patch"
+ "${FILESDIR}/${PN}-0.760.0-lto.patch"
+ "${FILESDIR}/${PN}-0.760.0-clang16.patch"
+)
+
+src_prepare() {
+ perl-module_src_prepare
+ tc-export CC
+}
+src_compile() {
+ mymake=(
+ "OPTIMIZE=${CFLAGS}"
+ )
+ perl-module_src_compile
+}
diff --git a/dev-perl/File-RsyncP/Manifest b/dev-perl/File-RsyncP/Manifest
index 31bd8b1f3469..4de35a129bb1 100644
--- a/dev-perl/File-RsyncP/Manifest
+++ b/dev-perl/File-RsyncP/Manifest
@@ -1,4 +1,7 @@
AUX File-RsyncP-0.700.0-make.patch 980 BLAKE2B 997e84bdd3183c324e76df69279fa00ec09663d73906607b3a0d2518d73f8391aab2214221bb797dadd4031b6f1e195f465cc5153e004c1e415a5ce4da9c8eaa SHA512 dccabb516cb4036efd8372c36343b02916ec1576c64f5c449eff1e7f0aac450f732ac4b190578426c52cbfedd3e5df28b4851cf350621a381b605065f473df14
+AUX File-RsyncP-0.760.0-clang16.patch 6046 BLAKE2B 5d388247096dc604cdf0dac5f070b69826fa4bd106b791d5ea29cdc0d2cf66545926414c5cda37ce9afac64dda862aefe87edeadb39fc0d63c084b6d95890e9e SHA512 a64a38ef191361cb2429a9a7101333e4631f264452825359b0006baeb89517960c86a4bd01b3647c8c4b3f7962782961ff968341c1d1362a21fa6edf492c3e7b
+AUX File-RsyncP-0.760.0-lto.patch 1788 BLAKE2B e297938568837ee271e63aed2c520334317e11c08a3481ceae27e657586221f5a813b55e3f2e6a2a1e09cb9a364d80a0236117aeff88fb6a0caf02492d4640e0 SHA512 ab70725cd8503fb59b5df57e66a056f78ef9b6a699e92c76f121decfaf959b51b8804a122af8be66d11ec141f03b0c2eeb1e77eae10ed745d6c2b47622bda065
DIST File-RsyncP-0.76.tar.gz 167744 BLAKE2B e718a8cd18f3bf7c3d8b9ceb440c19b9544c232f2889532a15023ec1da6947085d4d07efb7edf7b1366830005f784e03b76bb9526d5ecb0072b3c0ab5fb88494 SHA512 b81d9ce63181605939e8aff87c9e56ab276899f019f44eb3f149e7ee0d44a94fcbee771381ebe6ca8281c2de0d57d9cbdbcb972ccb7406a0aefd920040603bb3
+EBUILD File-RsyncP-0.760.0-r1.ebuild 798 BLAKE2B de3c8d3aa3cb99a945c2f0985ebe3be9dc5dd5d57dc766fe9b704e02c98b0db595ce1a793d521ae2e6983db4159bfcc48e35cb9768bf9a7e041027a95e77261e SHA512 1ebc38d833d93565575dcfad980df74404e00967a3e32127115cd9dada3d5190c6b2a13d4bbf82691df65a79b26fae7b371abee69281a5fa0bfc1a76649e014f
EBUILD File-RsyncP-0.760.0.ebuild 712 BLAKE2B 3192b8f7eac3447540d27012d25b8aa322fe3092567d88db1582764f6baebdd43849803bb2189464ea052251f046ceec6ff65e79eee17711ce0e599fe6bd70d4 SHA512 6c4e7d15e2e178c57d353eb896a93342bd6f5b7909cfbc0808f372faa407683a135bf4c7ec9c1ba80b5c074d8aa20e3910f65ab07d465ea123f77fa724ce5937
MISC metadata.xml 654 BLAKE2B de95af5a50340b4b1235613c8874a6ab53824c8d4c2ef7253fc58a349d72a63afeef797944da7ce8195e0314247f3904aaf61a42bfd02940101fadd7edad7c92 SHA512 9e8b272c3d070616e3434e597e014a3ccfa77a1749790708453e03ed29dedb993ebab52e178fca3dfc064db335e28524ebd22adc879ead7b6e3a3473e8ed72aa
diff --git a/dev-perl/File-RsyncP/files/File-RsyncP-0.760.0-clang16.patch b/dev-perl/File-RsyncP/files/File-RsyncP-0.760.0-clang16.patch
new file mode 100644
index 000000000000..5408ac9c982e
--- /dev/null
+++ b/dev-perl/File-RsyncP/files/File-RsyncP-0.760.0-clang16.patch
@@ -0,0 +1,188 @@
+https://rt.cpan.org/Public/Bug/Display.html?id=145943
+
+Various fixes for the configure script. Most of them are specific to
+this package, and not related to autoconf limitations. The
+configure.in/configure.ac autoconf input is not included among
+upstream sources, so they are not patched here.
+
+--- a/FileList/configure
++++ b/FileList/configure
+@@ -2246,7 +2246,7 @@ if { (eval echo "$as_me:$LINENO: \"$ac_compile\"") >&5
+ echo "$as_me:$LINENO: \$? = $ac_status" >&5
+ (exit $ac_status); }; }; then
+ for ac_declaration in \
+- '' \
++ '#include <stdlib.h>' \
+ 'extern "C" void std::exit (int) throw (); using std::exit;' \
+ 'extern "C" void std::exit (int); using std::exit;' \
+ 'extern "C" void exit (int) throw ();' \
+@@ -2905,6 +2905,8 @@ cat >>conftest.$ac_ext <<_ACEOF
+ #include <fcntl.h>
+ #include <sys/types.h>
+ #include <sys/wait.h>
++#include <stdlib.h>
++#include <string.h>
+
+ int main(void)
+ {
+@@ -4492,8 +4494,8 @@ main ()
+ for (i = 0; i < 256; i++)
+ if (XOR (islower (i), ISLOWER (i))
+ || toupper (i) != TOUPPER (i))
+- exit(2);
+- exit (0);
++ return 2;
++ return 0;
+ }
+ _ACEOF
+ rm -f conftest$ac_exeext
+@@ -6841,6 +6843,8 @@ cat >>conftest.$ac_ext <<_ACEOF
+ #define NGID 256
+ #undef MAX
+ #define MAX(x, y) ((x) > (y) ? (x) : (y))
++#include <unistd.h>
++#include <stdlib.h>
+
+ int
+ main ()
+@@ -8828,6 +8832,7 @@ cat confdefs.h >>conftest.$ac_ext
+ cat >>conftest.$ac_ext <<_ACEOF
+ /* end confdefs.h. */
+ $ac_includes_default
++#include <utime.h>
+ int
+ main ()
+ {
+@@ -9397,9 +9402,9 @@ cat >>conftest.$ac_ext <<_ACEOF
+ #include <sys/types.h>
+ #include <sys/socket.h>
+
+-main() {
++int main(void) {
+ int fd[2];
+- exit((socketpair(AF_UNIX, SOCK_STREAM, 0, fd) != -1) ? 0 : 1);
++ return (socketpair(AF_UNIX, SOCK_STREAM, 0, fd) != -1) ? 0 : 1;
+ }
+ _ACEOF
+ rm -f conftest$ac_exeext
+@@ -9451,7 +9456,7 @@ cat confdefs.h >>conftest.$ac_ext
+ cat >>conftest.$ac_ext <<_ACEOF
+ /* end confdefs.h. */
+ #include <stdio.h>
+-main() { long long x = 1000000; x *= x; exit(((x/1000000) == 1000000)? 0: 1); }
++int main(void) { long long x = 1000000; x *= x; return ((x/1000000) == 1000000)? 0: 1; }
+ _ACEOF
+ rm -f conftest$ac_exeext
+ if { (eval echo "$as_me:$LINENO: \"$ac_link\"") >&5
+@@ -9503,7 +9508,7 @@ cat >>conftest.$ac_ext <<_ACEOF
+ /* end confdefs.h. */
+ #include <stdio.h>
+ #include <sys/stat.h>
+-main() { struct stat64 st; off64_t s; if (sizeof(off_t) == sizeof(off64_t)) exit(1); exit((lstat64("/dev/null", &st)==0)?0:1); }
++int main(void) { struct stat64 st; off64_t s; if (sizeof(off_t) == sizeof(off64_t)) return 1; return (lstat64("/dev/null", &st)==0)?0:1; }
+ _ACEOF
+ rm -f conftest$ac_exeext
+ if { (eval echo "$as_me:$LINENO: \"$ac_link\"") >&5
+@@ -9556,7 +9561,7 @@ cat >>conftest.$ac_ext <<_ACEOF
+ #include <stdio.h>
+ #include <sys/types.h>
+ #include <sys/stat.h>
+-main() { if (sizeof(ino_t) < sizeof(unsigned int)) return 0; return 1; }
++int main(void) { if (sizeof(ino_t) < sizeof(unsigned int)) return 0; return 1; }
+ _ACEOF
+ rm -f conftest$ac_exeext
+ if { (eval echo "$as_me:$LINENO: \"$ac_link\"") >&5
+@@ -9607,7 +9612,7 @@ cat confdefs.h >>conftest.$ac_ext
+ cat >>conftest.$ac_ext <<_ACEOF
+ /* end confdefs.h. */
+ #include <stdio.h>
+-main() { char c; c=250; exit((c > 0)?0:1); }
++int main(void) { char c; c=250; return (c > 0)?0:1; }
+ _ACEOF
+ rm -f conftest$ac_exeext
+ if { (eval echo "$as_me:$LINENO: \"$ac_link\"") >&5
+@@ -9659,9 +9664,9 @@ cat >>conftest.$ac_ext <<_ACEOF
+ /* end confdefs.h. */
+ #include <sys/types.h>
+ #include <dirent.h>
+-main() { struct dirent *di; DIR *d = opendir("."); di = readdir(d);
++int main(void) { struct dirent *di; DIR *d = opendir("."); di = readdir(d);
+ if (di && di->d_name[-2] == '.' && di->d_name[-1] == 0 &&
+-di->d_name[0] == 0) exit(0); exit(1);}
++di->d_name[0] == 0) return 0; return 1;}
+ _ACEOF
+ rm -f conftest$ac_exeext
+ if { (eval echo "$as_me:$LINENO: \"$ac_link\"") >&5
+@@ -9713,7 +9718,7 @@ cat >>conftest.$ac_ext <<_ACEOF
+ int
+ main ()
+ {
+-struct utimbuf tbuf; tbuf.actime = 0; tbuf.modtime = 1; exit(utime("foo.c",&tbuf));
++struct utimbuf tbuf; tbuf.actime = 0; tbuf.modtime = 1; return utime("foo.c",&tbuf);
+ ;
+ return 0;
+ }
+@@ -9777,7 +9782,7 @@ cat >>conftest.$ac_ext <<_ACEOF
+
+ #include <sys/time.h>
+ #include <unistd.h>
+-main() { struct timeval tv; exit(gettimeofday(&tv, NULL));}
++int main(void) { struct timeval tv; return gettimeofday(&tv, NULL);}
+ _ACEOF
+ rm -f conftest$ac_exeext
+ if { (eval echo "$as_me:$LINENO: \"$ac_link\"") >&5
+@@ -9830,6 +9835,9 @@ cat >>conftest.$ac_ext <<_ACEOF
+
+ #include <sys/types.h>
+ #include <stdarg.h>
++#include <stdio.h>
++#include <stdlib.h>
++#include <string.h>
+ void foo(const char *format, ...) {
+ va_list ap;
+ int len;
+@@ -9844,7 +9852,7 @@ void foo(const char *format, ...) {
+
+ exit(0);
+ }
+-main() { foo("hello"); }
++int main(void) { foo("hello"); }
+
+ _ACEOF
+ rm -f conftest$ac_exeext
+@@ -9900,7 +9908,7 @@ cat >>conftest.$ac_ext <<_ACEOF
+ #include <sys/types.h>
+ #include <sys/stat.h>
+ #include <unistd.h>
+-main() {
++int main(void) {
+ struct stat st;
+ char tpl[20]="/tmp/test.XXXXXX";
+ int fd = mkstemp(tpl);
+@@ -9965,10 +9973,11 @@ cat >>conftest.$ac_ext <<_ACEOF
+ #include <sys/types.h>
+ #include <netinet/in.h>
+ #include <arpa/inet.h>
+-main() { struct in_addr ip; ip.s_addr = 0x12345678;
++#include <string.h>
++int main(void) { struct in_addr ip; ip.s_addr = 0x12345678;
+ if (strcmp(inet_ntoa(ip),"18.52.86.120") &&
+- strcmp(inet_ntoa(ip),"120.86.52.18")) { exit(1); }
+-exit(0);}
++ strcmp(inet_ntoa(ip),"120.86.52.18")) { return 1; }
++return 0;}
+ _ACEOF
+ rm -f conftest$ac_exeext
+ if { (eval echo "$as_me:$LINENO: \"$ac_link\"") >&5
+@@ -10024,8 +10033,8 @@ cat >>conftest.$ac_ext <<_ACEOF
+ #include <sys/types.h>
+ #include <netinet/in.h>
+ #include <arpa/inet.h>
+-main() { struct in_addr ip;
+-if (inet_aton("example", &ip) == 0) exit(0); exit(1);}
++int main(void) { struct in_addr ip;
++if (inet_aton("example", &ip) == 0) return 0; return 1;}
+ _ACEOF
+ rm -f conftest$ac_exeext
+ if { (eval echo "$as_me:$LINENO: \"$ac_link\"") >&5
+
diff --git a/dev-perl/File-RsyncP/files/File-RsyncP-0.760.0-lto.patch b/dev-perl/File-RsyncP/files/File-RsyncP-0.760.0-lto.patch
new file mode 100644
index 000000000000..752d35dfbb02
--- /dev/null
+++ b/dev-perl/File-RsyncP/files/File-RsyncP-0.760.0-lto.patch
@@ -0,0 +1,40 @@
+https://bugs.gentoo.org/867832
+https://rt.cpan.org/Public/Bug/Display.html?id=141822
+
+From 5fb151e46ce03c960ae05405c6f6360ccb7efa6f Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Petr=20P=C3=ADsa=C5=99?= <ppisar@redhat.com>
+Date: Fri, 18 Mar 2022 12:28:26 +0100
+Subject: [PATCH] Fix configure check with optimizing and lto-enabled GCC 12
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+After upgrading GCC to version 12 on Linux (where strlcpy() does not exist)
+tests fail like this if CFLAGS="-O1 -flto=auto":
+
+ make[1]: Entering directory '/home/test/fedora/perl-File-RsyncP/File-RsyncP-0.76/FileList'
+ "/usr/bin/perl" -MExtUtils::Command::MM -e 'cp_nonempty' -- FileList.bs ../blib/arch/auto/File/RsyncP/FileList/FileList.bs 644
+ PERL_DL_NONLAZY=1 "/usr/bin/perl" "-MExtUtils::Command::MM" "-MTest::Harness" "-e" "undef *Test::Harness::Switches; test_harness(0, '../blib/lib', '../blib/arch')" t/*.t
+ t/exclude.t ... Can't load '/home/test/fedora/perl-File-RsyncP/File-RsyncP-0.76/FileList/../blib/arch/auto/File/RsyncP/FileList/FileList.so' for module File::RsyncP::FileList: /home/test/fedora/perl-File-RsyncP/File-RsyncP-0.76/FileList/../blib/arch/auto/File/RsyncP/FileList/FileList.so: undefined symbol: strlcpy at /usr/lib64/perl5/DynaLoader.pm line 193.
+
+The new compiler optimizes out a check for strlcpy() perform by
+FileList/configure script. This patch changes the check to actually depend on
+strlcpy() function address. That should prevent a compiler from optimizing it
+out.
+
+CPAN RT#141822
+
+Signed-off-by: Petr Písař <ppisar@redhat.com>
+--- a/FileList/configure
++++ b/FileList/configure
+@@ -9330,7 +9330,7 @@ char (*f) () = $ac_func;
+ int
+ main ()
+ {
+-return f != $ac_func;
++return (int)f;
+ ;
+ return 0;
+ }
+--
+2.34.1