summaryrefslogtreecommitdiff
path: root/dev-perl/File-Scan-ClamAV
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-perl/File-Scan-ClamAV
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-perl/File-Scan-ClamAV')
-rw-r--r--dev-perl/File-Scan-ClamAV/File-Scan-ClamAV-1.950.0.ebuild38
-rw-r--r--dev-perl/File-Scan-ClamAV/Manifest3
-rw-r--r--dev-perl/File-Scan-ClamAV/metadata.xml12
3 files changed, 53 insertions, 0 deletions
diff --git a/dev-perl/File-Scan-ClamAV/File-Scan-ClamAV-1.950.0.ebuild b/dev-perl/File-Scan-ClamAV/File-Scan-ClamAV-1.950.0.ebuild
new file mode 100644
index 000000000000..b44b7a3bb3d7
--- /dev/null
+++ b/dev-perl/File-Scan-ClamAV/File-Scan-ClamAV-1.950.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=ESAYM
+DIST_VERSION=1.95
+
+inherit perl-module
+
+DESCRIPTION="Connect to a local Clam Anti-Virus clamd service and send commands"
+
+SLOT="0"
+KEYWORDS="~amd64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND="app-antivirus/clamav"
+DEPEND="${DEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+"
+
+# Test's can't be run in parallel because they internally spawn a
+# clam server on the same shared socket
+DIST_TEST="do"
+
+src_test() {
+ if [[ "${TEST_SCAN_CLAMAV:-0}" == "1" || -n "${DIST_TEST_OVERRIDE}" ]]; then
+ perl_rm_files t/pod-coverage.t t/pod.t
+ perl-module_src_test
+ else
+ einfo "Skipping Tests."
+ einfo
+ einfo "Tests require a manually and correctly configured ClamAV."
+ einfo
+ einfo "Set TEST_SCAN_CLAMAV=1 if you wish to run this test and have"
+ einfo "configured ClamAV"
+ fi
+}
diff --git a/dev-perl/File-Scan-ClamAV/Manifest b/dev-perl/File-Scan-ClamAV/Manifest
new file mode 100644
index 000000000000..49c237dc4038
--- /dev/null
+++ b/dev-perl/File-Scan-ClamAV/Manifest
@@ -0,0 +1,3 @@
+DIST File-Scan-ClamAV-1.95.tar.gz 15010 BLAKE2B 34e9d6b923cc7c302f8ddb012d387a138ac378774d3e1a92fa409306a57a92a7a2d284b82de7f0fd9388cfadc722348438ddbc2cdb8dc6922ea5cac845a21880 SHA512 604b3e4f876be41e0963e4969b8b06d4b720092d2e5e7b4b2f6f39db502fb213b38025d3904c1528d1c3d1aaf81e43e09924618efd1b29db221ac4e8e6149b93
+EBUILD File-Scan-ClamAV-1.950.0.ebuild 887 BLAKE2B ceccaf746f97f7485b1ae306376a8d098800782f07f897aa8751979dab8dad61161f815a3847a795ec3fd079095796926e5c38c9a2fb0072c595c36b834a6500 SHA512 de421e8e07225cccd8d41454ba62ce6501587ab0436f0ceaa57568e765bdba94ebb52ab6aa7967606f1d616e67e62d27c7e719ee06c7313d90b1cec2be451db3
+MISC metadata.xml 398 BLAKE2B 5d8c0d193f51cf3f72e4084ce286f3ab2bb874b27d5b0d96bd58c89ee598081559cbaa68c715012fe89004292304b6e38f0110f2a6c57dc242279549912bd4d1 SHA512 32cbfae10c7c48ade993477f5b494883bbd55bcf148645154691d1f4d3d5a5e7e5396c4e6725199f01567b7186769738ef597988922547873de8c6e6e1091fa5
diff --git a/dev-perl/File-Scan-ClamAV/metadata.xml b/dev-perl/File-Scan-ClamAV/metadata.xml
new file mode 100644
index 000000000000..951bd48001a3
--- /dev/null
+++ b/dev-perl/File-Scan-ClamAV/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>net-mail@gentoo.org</email>
+ <name>Net-Mail</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="cpan">File-Scan-ClamAV</remote-id>
+ <remote-id type="cpan-module">File::Scan::ClamAV</remote-id>
+ </upstream>
+</pkgmetadata>