summaryrefslogtreecommitdiff
path: root/dev-perl/Font-AFM/Font-AFM-1.200.0-r3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-23 10:22:15 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-23 10:22:15 +0100
commit8b4ace9c50842c5b83401ea7b179dcab940387e1 (patch)
tree230f3135ceaace633cf93e9838b185c4a6664c2e /dev-perl/Font-AFM/Font-AFM-1.200.0-r3.ebuild
parent9ee6d97c2883d42f204a533a8bc1f4562df778fb (diff)
gentoo resync : 23.09.2020
Diffstat (limited to 'dev-perl/Font-AFM/Font-AFM-1.200.0-r3.ebuild')
-rw-r--r--dev-perl/Font-AFM/Font-AFM-1.200.0-r3.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-perl/Font-AFM/Font-AFM-1.200.0-r3.ebuild b/dev-perl/Font-AFM/Font-AFM-1.200.0-r3.ebuild
new file mode 100644
index 000000000000..b279f82659d6
--- /dev/null
+++ b/dev-perl/Font-AFM/Font-AFM-1.200.0-r3.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=GAAS
+DIST_VERSION=1.20
+inherit perl-module
+
+DESCRIPTION="Parse Adobe Font Metric files"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~sparc ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+BDEPEND="
+ test? (
+ media-fonts/urw-fonts
+ )
+"
+PATCHES=(
+ "${FILESDIR}/${PN}-1.20-custom-test-font.patch"
+)
+src_test() {
+ # nimbus sans l medium r normal iso8859-1
+ TEST_FONT="n019003l" \
+ TEST_FONT_WIDTH="4279" \
+ METRICS="${EPREFIX}/usr/share/fonts/urw-fonts" \
+ perl-module_src_test
+}