summaryrefslogtreecommitdiff
path: root/dev-perl/GnuPG-Interface
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-06-15 14:57:03 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-06-15 14:57:03 +0100
commitd18bf1e01b65ee4bf0c804e2843b282d3d4e5d7c (patch)
tree4a95cbc6ffdf13bad6ecbc7f8d5af99631984123 /dev-perl/GnuPG-Interface
parente748ba9741f6540f4675c23e3e37b73e822c13a4 (diff)
gentoo resync : 15.06.2021
Diffstat (limited to 'dev-perl/GnuPG-Interface')
-rw-r--r--dev-perl/GnuPG-Interface/GnuPG-Interface-0.520.0-r2.ebuild65
-rw-r--r--dev-perl/GnuPG-Interface/GnuPG-Interface-1.20.0.ebuild42
-rw-r--r--dev-perl/GnuPG-Interface/Manifest3
3 files changed, 44 insertions, 66 deletions
diff --git a/dev-perl/GnuPG-Interface/GnuPG-Interface-0.520.0-r2.ebuild b/dev-perl/GnuPG-Interface/GnuPG-Interface-0.520.0-r2.ebuild
deleted file mode 100644
index fd6f4ac222a3..000000000000
--- a/dev-perl/GnuPG-Interface/GnuPG-Interface-0.520.0-r2.ebuild
+++ /dev/null
@@ -1,65 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-DIST_AUTHOR=ALEXMV
-DIST_VERSION=0.52
-inherit perl-module
-
-DESCRIPTION="Perl module interface to interacting with GnuPG"
-
-SLOT="0"
-KEYWORDS="amd64 ~hppa ppc x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- >=app-crypt/gnupg-1.2.1-r1
- virtual/perl-autodie
- >=virtual/perl-Math-BigInt-1.780.0
- >=dev-perl/Moo-0.91.11
- >=dev-perl/MooX-HandlesVia-0.1.4
- >=dev-perl/MooX-late-0.14.0
-"
-DEPEND="${RDEPEND}
- >=virtual/perl-ExtUtils-MakeMaker-6.360.0
-"
-
-PATCHES=(
- "${FILESDIR}/${P}"-0001-fix-spelling-error-settting-should-be-setting.patch
- "${FILESDIR}/${P}"-0002-Generalize-the-test-suite.patch
- "${FILESDIR}/${P}"-0003-subkey-validity-of-an-key-when-we-have-established-n.patch
- "${FILESDIR}/${P}"-0004-ensure-that-test-covers-all-signatures.patch
- "${FILESDIR}/${P}"-0005-add-gpg_is_modern-to-test-suite.patch
- "${FILESDIR}/${P}"-0006-Modern-GnuPG-2.1-reports-more-detail-about-secret-ke.patch
- "${FILESDIR}/${P}"-0007-test-suite-match-plaintext-output-across-versions-of.patch
- "${FILESDIR}/${P}"-0008-fix-test_default_key_passphrase-when-passphrase-come.patch
- "${FILESDIR}/${P}"-0009-clean-up-trailing-whitespace.patch
- "${FILESDIR}/${P}"-0010-fix-capitalization-of-GnuPG.patch
- "${FILESDIR}/${P}"-0011-ommand_args-should-be-command_args.patch
- "${FILESDIR}/${P}"-0012-use-fingerprints-as-inputs-during-tests-to-demonstra.patch
- "${FILESDIR}/${P}"-0013-move-key-files-to-generic-names.patch
- "${FILESDIR}/${P}"-0014-fix-spelling-s-convience-convenience.patch
- "${FILESDIR}/${P}"-0015-added-new-secret-key-with-different-passphrase.patch
- "${FILESDIR}/${P}"-0016-Test-use-of-gpg-without-explicit-passphrase-agent-pi.patch
- "${FILESDIR}/${P}"-0017-Kill-any-GnuPG-agent-before-and-after-the-test-suite.patch
- "${FILESDIR}/${P}"-0018-Use-a-short-temporary-homedir-during-the-test-suite.patch
- "${FILESDIR}/${P}"-0019-Make-things-work-with-gpg1-assuming-plain-gpg-is-mod.patch
-)
-
-DIST_TEST=skip
-# Nearly all tests succeed with this patchset and GnuPG 2.1 when running outside the
-# emerge sandbox. However, the agent architecture is not really sandbox-friendly, so...
-#
-# Test Summary Report
-# -------------------
-# t/decrypt.t (Wstat: 0 Tests: 6 Failed: 2)
-# Failed tests: 5-6
-# Failed 1/22 test programs. 2/56 subtests failed.
-
-src_prepare() {
- sed -i -e 's/use inc::Module::Install;/use lib q[.];\nuse inc::Module::Install;/' Makefile.PL ||
- die "Can't patch Makefile.PL for 5.26 dot-in-inc"
- perl-module_src_prepare
-}
diff --git a/dev-perl/GnuPG-Interface/GnuPG-Interface-1.20.0.ebuild b/dev-perl/GnuPG-Interface/GnuPG-Interface-1.20.0.ebuild
new file mode 100644
index 000000000000..e7ab6efaf1ee
--- /dev/null
+++ b/dev-perl/GnuPG-Interface/GnuPG-Interface-1.20.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=BPS
+DIST_VERSION=1.02
+inherit perl-module
+
+DESCRIPTION="Perl interface to GnuPG"
+
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=app-crypt/gnupg-1.4
+ virtual/perl-autodie
+ >=virtual/perl-Math-BigInt-1.780.0
+ >=dev-perl/Moo-0.91.11
+ >=dev-perl/MooX-HandlesVia-0.1.4
+ >=dev-perl/MooX-late-0.14.0
+"
+BDEPEND="${RDEPEND}
+ >=virtual/perl-ExtUtils-MakeMaker-6.360.0
+"
+
+src_test() {
+# Nearly all tests succeed with this patchset and GnuPG 2.1 when running outside the
+# emerge sandbox. However, the agent architecture is not really sandbox-friendly, so...
+#
+# Test Summary Report
+# -------------------
+# t/decrypt.t (Wstat: 0 Tests: 6 Failed: 2)
+# Failed tests: 5-6
+# Failed 1/22 test programs. 2/56 subtests failed.
+ perl_rm_files t/decrypt.t
+# Needs to run a setup test that spawns a persistent daemon
+ DIST_TEST="do"
+ perl-module_src_test
+}
diff --git a/dev-perl/GnuPG-Interface/Manifest b/dev-perl/GnuPG-Interface/Manifest
index 54f303e34f24..1914df0517f8 100644
--- a/dev-perl/GnuPG-Interface/Manifest
+++ b/dev-perl/GnuPG-Interface/Manifest
@@ -20,6 +20,7 @@ AUX GnuPG-Interface-0.520.0-0019-Make-things-work-with-gpg1-assuming-plain-gpg-i
AUX GnuPG-Interface-0.520.0-0030-gpg-2.2.6.patch 1897 BLAKE2B eca30b9a8485f7cb960ff343d1b575f324fcf6895c0fd723d14ebcccba14c69dd775ae315130af94a3246e3f8ddedb4ea9ba9c4c894f5e63b05fa8197e82f584 SHA512 5826dbc85925ac810dce695ea747ab2a4d361811295ce4f83925416c8c5842f8486e4275a3e610069157fa37e377413a39f1684ce94f618a99c46e7f6884264c
AUX GnuPG-Interface-0.520.0-0031-gpg-2.2.8.patch 1511 BLAKE2B 3eee783efd64848bc0e86a0e0768c8dc77f8e28819fdc466913ac029cef7fcf42ff67edf89762b4b023d58df7c740b7d3d6a56ea2598699637edf5fb12840464 SHA512 7f8597d4a25e1492475810e47fb7988d74411cbe6ad537889c65bf37119572d1ae0c24e2f5c99d77d12edee3c46dd0e635125ee7a7dde99abeddd19d43fe7aa9
DIST GnuPG-Interface-0.52.tar.gz 63733 BLAKE2B ce068177b8467356b57aae95a61e4746e4f690272083e465c877533a5ab0eedaaf271586aaffe7e4f979034d04bd49fc483047654426f23cfb904a98326454c3 SHA512 911f47a3b52249e8b39133d4040b86147793d9dd6a78d2b279674d6bba0cd38de5c919bf12b241b0e977790575502531afab6b1d2c05739d050c16d05d52fc49
-EBUILD GnuPG-Interface-0.520.0-r2.ebuild 2551 BLAKE2B aa027817241c32443debfcfd5152d5405b8d49d532dd670b28c8f2914924e708ed42951fd70c540b4b927202d0e2de72bbabcd450df0a4cb3efc63c0242e2e8e SHA512 af359488b27f603aad2c051ce001036f2f2c9c3f52a8e36e9c2a53c6e0f7ef26fa0c9231f278b474de57fa1bb9b532e6f523ce5fbd1e056ef373cbfb30158af3
+DIST GnuPG-Interface-1.02.tar.gz 75523 BLAKE2B 4b1311bbd930ae6719db9d7d25e247804c1f71f29da52b1896086ff4905cfdf09792d85fa9e90da462e974279cc673bacdcd2b6a32171eca1be861df5f712a98 SHA512 ff4365aa75fbcd2dc77c915ec36c0b578219ae1a2148e936b4769221f91c78a3bc3d371159b5130e7bee36ecf0e169b6a16e3a160d2598811d6f70850119f6e4
EBUILD GnuPG-Interface-0.520.0-r3.ebuild 2758 BLAKE2B 760a4a62c7d5413bce55f5f48d4068d6744cdf4efc2db42a62c902cf6704204a95b7dbf13fef3626f6c5e7ca5a9ef8f7de8dd8c349d97d1ccccfe587adfac844 SHA512 e90a32bd241a390d2f6ac1f2aed15dbb8e1c7e0bd343af52aa70cfdf36df803490d9a19c16e2666b30c4757d2f1207ed47354fe50fd7df6d7f1f7ad8b0b0c9b9
+EBUILD GnuPG-Interface-1.20.0.ebuild 1025 BLAKE2B 52f953f3fed485f4a78212ef9a76d97fafbd65957273f895423572089f4098d8299dcf4c84efde9d8d076369b7246d7fdc2053c71f60b467bfe7f558502ab580 SHA512 3d73090c93b78e31820551d1dc1ebd5b19a67fde4d3705067bb3baee3df1c2d40d8ab1454e8a4bf4a657f13999a394d6e9fb4db3e6ab62fa9d3f0b1501d369d2
MISC metadata.xml 1209 BLAKE2B a29e49d03ea5216897ae8d8ca55472c4d41d75a2722133dd2782b504db464740f15b5c017e09efb9a76da76b482f3f33e5b8cd8279402d51e14c201c8840d9b3 SHA512 3589a6d227ccde1efd9a0842e98b7f4c3d4f5434a9e62feba4a6764d1fdc4c0dc7390bba15bb52053520931c4ed4ff05235ec98efbe0239a4a9da12b30092cfb