summaryrefslogtreecommitdiff
path: root/dev-perl/HTML-Quoted/HTML-Quoted-0.40.0-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-11-03 06:47:15 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-11-03 06:47:15 +0000
commitfc2f1018fc323ef2c6572734a9b130427cba76a6 (patch)
treef834bdc9a67923ce75297c09d00d1e7b90791d26 /dev-perl/HTML-Quoted/HTML-Quoted-0.40.0-r1.ebuild
parent162945d2a91899b637bbb9e163b406350de12906 (diff)
gentoo resync : 03.11.2021
Diffstat (limited to 'dev-perl/HTML-Quoted/HTML-Quoted-0.40.0-r1.ebuild')
-rw-r--r--dev-perl/HTML-Quoted/HTML-Quoted-0.40.0-r1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-perl/HTML-Quoted/HTML-Quoted-0.40.0-r1.ebuild b/dev-perl/HTML-Quoted/HTML-Quoted-0.40.0-r1.ebuild
new file mode 100644
index 000000000000..1dd693582739
--- /dev/null
+++ b/dev-perl/HTML-Quoted/HTML-Quoted-0.40.0-r1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DIST_AUTHOR=TSIBLEY
+DIST_VERSION=0.04
+inherit perl-module
+
+DESCRIPTION="Extract structure of quoted HTML mail message"
+
+SLOT="0"
+KEYWORDS="amd64 ~x86"
+
+RDEPEND="
+ >=dev-perl/HTML-Parser-3.0.0
+"
+BDEPEND="${RDEPEND}
+ >=virtual/perl-ExtUtils-MakeMaker-6.590.0
+"
+
+src_prepare() {
+ sed -i -e 's/use inc::Module::Install/use lib q[.]; use inc::Module::Install/' Makefile.PL ||
+ die "Can't patch Makefile.PL for 5.26 dot-in-inc"
+ perl-module_src_prepare
+}