summaryrefslogtreecommitdiff
path: root/dev-perl/JSON-XS/JSON-XS-4.30.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-06-24 14:47:38 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-06-24 14:47:38 +0100
commitb4d43e8c611df4a8061b6f88d9e9f6b1e3c83903 (patch)
tree911928b566777494d08ebe2c16cb64f15af71901 /dev-perl/JSON-XS/JSON-XS-4.30.0.ebuild
parent61f10f985e19dfe20a4d9552902625edd5b6eabb (diff)
gentoo resync : 24.06.2021
Diffstat (limited to 'dev-perl/JSON-XS/JSON-XS-4.30.0.ebuild')
-rw-r--r--dev-perl/JSON-XS/JSON-XS-4.30.0.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-perl/JSON-XS/JSON-XS-4.30.0.ebuild b/dev-perl/JSON-XS/JSON-XS-4.30.0.ebuild
new file mode 100644
index 000000000000..2da3b6d92f0d
--- /dev/null
+++ b/dev-perl/JSON-XS/JSON-XS-4.30.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DIST_AUTHOR=MLEHMANN
+DIST_VERSION=4.03
+DIST_EXAMPLES=("eg/bench")
+inherit perl-module
+
+DESCRIPTION="JSON::XS - JSON serialising/deserialising, done correctly and fast"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+RDEPEND="
+ dev-perl/Types-Serialiser
+ dev-perl/common-sense
+ !<dev-perl/JSON-2.900.0
+ !<dev-perl/JSON-Any-1.310.0
+"
+BDEPEND="${RDEPEND}
+ dev-perl/Canary-Stability
+ >=virtual/perl-ExtUtils-MakeMaker-6.520.0
+ test? ( virtual/perl-Test-Harness )
+"