summaryrefslogtreecommitdiff
path: root/dev-perl/LWP-Protocol-https/LWP-Protocol-https-6.70.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-perl/LWP-Protocol-https/LWP-Protocol-https-6.70.0.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-perl/LWP-Protocol-https/LWP-Protocol-https-6.70.0.ebuild')
-rw-r--r--dev-perl/LWP-Protocol-https/LWP-Protocol-https-6.70.0.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-perl/LWP-Protocol-https/LWP-Protocol-https-6.70.0.ebuild b/dev-perl/LWP-Protocol-https/LWP-Protocol-https-6.70.0.ebuild
new file mode 100644
index 000000000000..d7b641534748
--- /dev/null
+++ b/dev-perl/LWP-Protocol-https/LWP-Protocol-https-6.70.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=OALDERS
+DIST_VERSION=6.07
+inherit perl-module
+
+DESCRIPTION="Provide https support for LWP::UserAgent"
+
+SLOT="0"
+IUSE="test"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+RDEPEND="
+ app-misc/ca-certificates
+ >=dev-perl/IO-Socket-SSL-1.540.0
+ >=dev-perl/libwww-perl-6.60.0
+ >=dev-perl/Net-HTTP-6
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ virtual/perl-Test-Simple
+ dev-perl/Test-RequiresInternet
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-6.70.0-etcsslcerts.patch
+ "${FILESDIR}"/${PN}-6.70.0-CVE-2014-3230.patch # note: breaks a test, still needed?
+)
+PERL_RM_FILES=(
+ "t/https_proxy.t" # see above
+)