summaryrefslogtreecommitdiff
path: root/dev-perl/Lab-VXI11/Lab-VXI11-0.20.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-11-19 10:19:50 +0000
committerV3n3RiX <venerix@redcorelinux.org>2017-11-19 10:19:50 +0000
commit20d8e9cfb95a9f054d654ab6405e848807186aa0 (patch)
tree8a308cb480d00fd37d0189950e04f7d59004954f /dev-perl/Lab-VXI11/Lab-VXI11-0.20.0.ebuild
parenta5956e0a0daddcad648e0d8d8e5cb3e49e09bda7 (diff)
gentoo resync : 19.11.2017
Diffstat (limited to 'dev-perl/Lab-VXI11/Lab-VXI11-0.20.0.ebuild')
-rw-r--r--dev-perl/Lab-VXI11/Lab-VXI11-0.20.0.ebuild16
1 files changed, 15 insertions, 1 deletions
diff --git a/dev-perl/Lab-VXI11/Lab-VXI11-0.20.0.ebuild b/dev-perl/Lab-VXI11/Lab-VXI11-0.20.0.ebuild
index 6eca7c194229..9d18e77101a3 100644
--- a/dev-perl/Lab-VXI11/Lab-VXI11-0.20.0.ebuild
+++ b/dev-perl/Lab-VXI11/Lab-VXI11-0.20.0.ebuild
@@ -11,9 +11,23 @@ inherit perl-module
DESCRIPTION="Perl interface to the VXI-11 Test&Measurement backend"
SLOT="0"
+IUSE="+libtirpc"
-RDEPEND=""
+RDEPEND="
+ !libtirpc? ( sys-libs/glibc[rpc(-)] )
+ libtirpc? ( net-libs/libtirpc )
+"
DEPEND="
${RDEPEND}
virtual/perl-ExtUtils-MakeMaker
"
+
+src_configure() {
+ if use libtirpc ; then
+ myconf=(
+ OPTIMIZE="${CFLAGS} -I/usr/include/tirpc"
+ LIBS="-ltirpc"
+ )
+ fi
+ perl-module_src_configure
+}