summaryrefslogtreecommitdiff
path: root/dev-perl/MCE/MCE-1.874.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-07-08 15:03:58 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-07-08 15:03:58 +0100
commit814f4cf860e299a046b649eaee5463427984c09c (patch)
tree74c45f097899310e599dad6b8df5b63e0f085bc0 /dev-perl/MCE/MCE-1.874.0.ebuild
parent7f0ccc917c7abe6223784c703d86cd14755691fb (diff)
gentoo resync : 08.07.2021
Diffstat (limited to 'dev-perl/MCE/MCE-1.874.0.ebuild')
-rw-r--r--dev-perl/MCE/MCE-1.874.0.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-perl/MCE/MCE-1.874.0.ebuild b/dev-perl/MCE/MCE-1.874.0.ebuild
new file mode 100644
index 000000000000..493761a6efbc
--- /dev/null
+++ b/dev-perl/MCE/MCE-1.874.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DIST_AUTHOR=MARIOROY
+DIST_VERSION=1.874
+inherit perl-module
+
+DESCRIPTION="Many-Core Engine providing parallel processing capabilities"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="+sereal"
+
+RDEPEND="
+ virtual/perl-Carp
+ virtual/perl-File-Path
+ virtual/perl-Getopt-Long
+ virtual/perl-IO
+ virtual/perl-Scalar-List-Utils
+ virtual/perl-Socket
+ >=virtual/perl-Storable-2.40.0
+ virtual/perl-Time-HiRes
+ sereal? (
+ >=dev-perl/Sereal-Encoder-3.15.0
+ >=dev-perl/Sereal-Decoder-3.15.0
+ )
+"
+BDEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? ( >=virtual/perl-Test-Simple-0.880.0 )
+"