summaryrefslogtreecommitdiff
path: root/dev-perl/MCE
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-perl/MCE
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-perl/MCE')
-rw-r--r--dev-perl/MCE/MCE-1.831.0.ebuild32
-rw-r--r--dev-perl/MCE/Manifest3
-rw-r--r--dev-perl/MCE/metadata.xml38
3 files changed, 73 insertions, 0 deletions
diff --git a/dev-perl/MCE/MCE-1.831.0.ebuild b/dev-perl/MCE/MCE-1.831.0.ebuild
new file mode 100644
index 000000000000..0c8ce4f89fe9
--- /dev/null
+++ b/dev-perl/MCE/MCE-1.831.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=MARIOROY
+DIST_VERSION=1.831
+inherit perl-module
+
+DESCRIPTION="Many-Core Engine providing parallel processing capabilities"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="test +sereal"
+
+RDEPEND="
+ virtual/perl-Carp
+ virtual/perl-File-Path
+ virtual/perl-Getopt-Long
+ virtual/perl-IO
+ virtual/perl-Scalar-List-Utils
+ virtual/perl-Socket
+ >=virtual/perl-Storable-2.40.0
+ virtual/perl-Time-HiRes
+ sereal? (
+ >=dev-perl/Sereal-Encoder-3.15.0
+ >=dev-perl/Sereal-Decoder-3.15.0
+ )
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? ( virtual/perl-Test-Simple )
+"
diff --git a/dev-perl/MCE/Manifest b/dev-perl/MCE/Manifest
new file mode 100644
index 000000000000..36d4b9d946e6
--- /dev/null
+++ b/dev-perl/MCE/Manifest
@@ -0,0 +1,3 @@
+DIST MCE-1.831.tar.gz 181710 BLAKE2B 0002ae943d864d9242fa3cdf194d464b21f4a51e6fc335439a7869e6d0182d3684568cab0c3635aead697c1157a1da9a90c6e1a24343ca6a50faa3b6cd531c4c SHA512 cca01463bed30b2c028318d92269de59f7c48d86c64b7a2bb7e07a9a668217f10ae70d4e6ac05e873d7305b572840833bdce8585dfd3975a56c95b531ce4cc0e
+EBUILD MCE-1.831.0.ebuild 691 BLAKE2B ed0fbe6c922f256fcc4bbaf6c1ea21ade9166b5946687db13f9464891332a2cf520715e4f814b9634749d1d32e7762cd1db1893764bff310a40697643eb60cda SHA512 789a2a576baac5ab4153f7af3f90d10b8834c92aa048a5391d9c048b1aee885d06baf2f5c9d978d265793506f646e6ff0a523e32a7e4d322b2fbedef039f024b
+MISC metadata.xml 1927 BLAKE2B 229eecec589ab766072b8ddb4652da724ee4f7b9a9e9fbbfdb5c349cde949d11a0452364592d8f894561f550f421052ff3fb26a063225b16302baa432b95d6b1 SHA512 11bfac0b72aa9f75e0f8723201365da9c9ff45266794f97a2116e89e755cc9497aa7a54d1bb9236b57d5332b1b43982be38bd7613e9f83373f4cb5b8320b4956
diff --git a/dev-perl/MCE/metadata.xml b/dev-perl/MCE/metadata.xml
new file mode 100644
index 000000000000..15373d98698b
--- /dev/null
+++ b/dev-perl/MCE/metadata.xml
@@ -0,0 +1,38 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>perl@gentoo.org</email>
+ <name>Gentoo Perl Project</name>
+ </maintainer>
+ <use>
+ <flag name="sereal">Install <pkg>dev-perl/Sereal-Encoder</pkg> and decoder for faster worker IPC</flag>
+ </use>
+ <upstream>
+ <remote-id type="cpan">MCE</remote-id>
+ <remote-id type="cpan-module">MCE</remote-id>
+ <remote-id type="cpan-module">MCE::Candy</remote-id>
+ <remote-id type="cpan-module">MCE::Core::Input::Generator</remote-id>
+ <remote-id type="cpan-module">MCE::Core::Input::Handle</remote-id>
+ <remote-id type="cpan-module">MCE::Core::Input::Iterator</remote-id>
+ <remote-id type="cpan-module">MCE::Core::Input::Request</remote-id>
+ <remote-id type="cpan-module">MCE::Core::Input::Sequence</remote-id>
+ <remote-id type="cpan-module">MCE::Core::Manager</remote-id>
+ <remote-id type="cpan-module">MCE::Core::Validation</remote-id>
+ <remote-id type="cpan-module">MCE::Core::Worker</remote-id>
+ <remote-id type="cpan-module">MCE::Flow</remote-id>
+ <remote-id type="cpan-module">MCE::Grep</remote-id>
+ <remote-id type="cpan-module">MCE::Loop</remote-id>
+ <remote-id type="cpan-module">MCE::Map</remote-id>
+ <remote-id type="cpan-module">MCE::Mutex</remote-id>
+ <remote-id type="cpan-module">MCE::Mutex::Channel</remote-id>
+ <remote-id type="cpan-module">MCE::Mutex::Flock</remote-id>
+ <remote-id type="cpan-module">MCE::Queue</remote-id>
+ <remote-id type="cpan-module">MCE::Relay</remote-id>
+ <remote-id type="cpan-module">MCE::Signal</remote-id>
+ <remote-id type="cpan-module">MCE::Step</remote-id>
+ <remote-id type="cpan-module">MCE::Stream</remote-id>
+ <remote-id type="cpan-module">MCE::Subs</remote-id>
+ <remote-id type="cpan-module">MCE::Util</remote-id>
+ </upstream>
+</pkgmetadata>