summaryrefslogtreecommitdiff
path: root/dev-perl/Math-Pari/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-perl/Math-Pari/files
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-perl/Math-Pari/files')
-rw-r--r--dev-perl/Math-Pari/files/Math-Pari-2.10.809.0-no-dot-inc.patch31
-rw-r--r--dev-perl/Math-Pari/files/no-flto.patch74
-rw-r--r--dev-perl/Math-Pari/files/pari-2.3.5-no-dot-inc.patch61
3 files changed, 166 insertions, 0 deletions
diff --git a/dev-perl/Math-Pari/files/Math-Pari-2.10.809.0-no-dot-inc.patch b/dev-perl/Math-Pari/files/Math-Pari-2.10.809.0-no-dot-inc.patch
new file mode 100644
index 000000000000..95ebcf9d18f0
--- /dev/null
+++ b/dev-perl/Math-Pari/files/Math-Pari-2.10.809.0-no-dot-inc.patch
@@ -0,0 +1,31 @@
+From 712cff175abfbf95428ed09a875a15f4047ce105 Mon Sep 17 00:00:00 2001
+From: Kent Fredric <kentfredric@gmail.com>
+Date: Sun, 11 Jun 2017 13:22:46 +1200
+Subject: [PATCH] Fix "do" to forcibly use a relative path on Perl 5.26
+
+Reliance on "." in @INC was previously how this worked. But that
+becomes broken on Perl 5.26
+
+Resolves RT#120711 ( Well, at least the Math-Pari parts, the pari
+ parts themselves need additional fixing, and that's not viable
+ to really perform in Math::Pari )
+
+Bug: https://rt.cpan.org/Ticket/Display.html?id=120711
+---
+ test_eng/ex.t | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/test_eng/ex.t b/test_eng/ex.t
+index a1a2286..0ad57ee 100644
+--- a/test_eng/ex.t
++++ b/test_eng/ex.t
+@@ -10,5 +10,5 @@ $dir1 = "CHANGE_ME";
+ $dir1 = "$dir/../$dir1" unless $dir1 =~ m|^([a-z]:)?[\\/]|i;
+ @ARGV = "$dir1/src/test/$long_bits/$name";
+ @ARGV = "$dir1/src/test/32/$name" unless -r $ARGV[0];
+-do 'test_eng/Testout.pm';
++do './test_eng/Testout.pm';
+ die if $@;
+--
+2.13.1
+
diff --git a/dev-perl/Math-Pari/files/no-flto.patch b/dev-perl/Math-Pari/files/no-flto.patch
new file mode 100644
index 000000000000..d3902ac5d470
--- /dev/null
+++ b/dev-perl/Math-Pari/files/no-flto.patch
@@ -0,0 +1,74 @@
+From c169041dfa888ec3815aa5bacc97bcc0f21dc318 Mon Sep 17 00:00:00 2001
+From: Kent Fredric <kentfredric@gmail.com>
+Date: Sun, 11 Jun 2017 13:05:59 +1200
+Subject: [PATCH] Disable -flto as it breaks compile.
+
+LTO seems to be bad for static/shared libraries or something.
+
+Turning it off until somebody works out how to make it not cause
+a compile failure, on top of all the crap Pari does.
+---
+ Makefile.PL | 17 ++++++++++++-----
+ 1 file changed, 12 insertions(+), 5 deletions(-)
+
+diff --git a/Makefile.PL b/Makefile.PL
+index f3025bd..c32eb6a 100644
+--- a/Makefile.PL
++++ b/Makefile.PL
+@@ -42,18 +42,23 @@ Could not find GP/PARI build directory, please run Makefile.PL
+ with paridir=/directory option.
+ EOD
+
++my $optimize = $Config{optimize};
++my $ldflags = $Config{ldflags};
++
++s/(^|\s)-flto(\s|$)/$1$2/ for $optimize, $ldflags;
++
+ my $gcc_version
+ = defined($Config{gccversion}) ? ", gccversion=$Config{gccversion}" : "";
+ print <<EOP;
+ Setting up Math::Pari with Perl $] on $^O version $Config{osvers};
+ cc=$Config{cc}$gcc_version, cccdlflags='$Config{cccdlflags}',
+ ccflags='$Config{ccflags}',
+- optimize='$Config{optimize}',
+- ld=$Config{ld}, ldflags='$Config{ldflags}'.
++ optimize='$optimize',
++ ld=$Config{ld}, ldflags='$ldflags'.
+ EOP
+
+ if ($^O eq 'solaris' and $Config{cc} eq 'gcc'
+- and ( $Config{optimize} =~ s/(?<!\S)(-xarch=386|-xildoff)(?!\S)//g
++ and ( $optimize =~ s/(?<!\S)(-xarch=386|-xildoff)(?!\S)//g
+ or $Config{cccdlflags} =~ s/(?<!\S)-KPIC(?!\S)/-fPIC/ )) {
+ # Vendor's Perl has major problems with building extensions; try to fix this
+ # One way is to use perlgcc; but it does not work with 5.8.4
+@@ -61,7 +66,7 @@ if ($^O eq 'solaris' and $Config{cc} eq 'gcc'
+ print <<EOP;
+
+ ... Broken config of gcc-on-Solaris detected! I would try to work around this.
+-... Reset: cccdlflags --> '$Config{cccdlflags}', optimize -> '$Config{optimize}'.
++... Reset: cccdlflags --> '$Config{cccdlflags}', optimize -> '$optimize'.
+
+ EOP
+ }
+@@ -181,7 +186,7 @@ $define .= ' -DLONG_SHORTER_THAN_IV' if $perl_int_size > $longsize;
+
+ $define .= ' -Derr=pari_err'; # On linux it can get a wrong dynamic loading
+ $define .= ' -DHAVE_LADD' if $opts{have_ladd};
+-$define .= ' -DGCC_INLINE' if $Config{gccversion} and not $Config{optimize} =~ /-g\b/;
++$define .= ' -DGCC_INLINE' if $Config{gccversion} and not $optimize =~ /-g\b/;
+ $define .= ' -DHAVE_PARIPRIV' if -f "$paridir/src/headers/paripriv.h";
+ #$define .= ' -DNO_GRAPHICS_PARI' unless -f "$paridir/src/graph/plotgnuplot.c";
+
+@@ -200,6 +205,8 @@ my $extra_inc = extra_includes($paridir);
+ &WriteMakefile(
+ LIBS => $libs,
+ INC => $extra_inc . ' -I $(PARI_DIR)/src/headers -I $(PARI_DIR)/src -I ./libPARI',
++ OPTIMIZE => $optimize,
++ LDFLAGS => $ldflags,
+ NAME => 'Math::Pari',
+ ($common::parilib ? () :
+ (MYEXTLIB => 'libPARI/libPARI$(LIB_EXT)')),
+--
+2.13.1
+
diff --git a/dev-perl/Math-Pari/files/pari-2.3.5-no-dot-inc.patch b/dev-perl/Math-Pari/files/pari-2.3.5-no-dot-inc.patch
new file mode 100644
index 000000000000..cd34851a30fb
--- /dev/null
+++ b/dev-perl/Math-Pari/files/pari-2.3.5-no-dot-inc.patch
@@ -0,0 +1,61 @@
+From 4f1e00df5ea1e51042146f6277bb1af02f249cc3 Mon Sep 17 00:00:00 2001
+From: Kent Fredric <kentfredric@gmail.com>
+Date: Sun, 11 Jun 2017 10:31:03 +1200
+Subject: [PATCH] Fix for 5.26 removal of '.' in @INC
+
+Previous scripts assumed CWD was in @INC and that "PARI::822" was in
+wherever CWD was.
+
+This fixes both of those, and the latter, because its not obvious
+from the build system where one should assume CWD to be.
+
+Instead, the absolute path of the directory of these scripts is
+inserted into @INC
+---
+ src/desc/gen_member | 4 ++++
+ src/desc/gen_proto | 4 ++++
+ src/desc/merge_822 | 4 ++++
+ 3 files changed, 12 insertions(+)
+
+diff --git a/src/desc/gen_member b/src/desc/gen_member
+index 2f3cf52..66dea2b 100755
+--- a/src/desc/gen_member
++++ b/src/desc/gen_member
+@@ -1,4 +1,8 @@
+ #!/usr/bin/perl -w
++use File::Spec;
++use File::Basename qw( dirname );
++use lib dirname(File::Spec->rel2abs(__FILE__));
++
+ use PARI::822;
+
+ $class='member_functions';
+diff --git a/src/desc/gen_proto b/src/desc/gen_proto
+index 1b507fa..2fb4d3f 100755
+--- a/src/desc/gen_proto
++++ b/src/desc/gen_proto
+@@ -1,4 +1,8 @@
+ #!/usr/bin/perl -w
++use File::Spec;
++use File::Basename qw( dirname );
++use lib dirname(File::Spec->rel2abs(__FILE__));
++
+ use PARI::822;
+
+ $class=$ARGV[0];
+diff --git a/src/desc/merge_822 b/src/desc/merge_822
+index a02d612..9ca8252 100755
+--- a/src/desc/merge_822
++++ b/src/desc/merge_822
+@@ -1,4 +1,8 @@
+ #!/usr/bin/perl -w
++use File::Spec;
++use File::Basename qw( dirname );
++use lib dirname(File::Spec->rel2abs(__FILE__));
++
+ use PARI::822;
+
+ PARI::822::read(\%funcs,$_,1)
+--
+2.13.1
+