summaryrefslogtreecommitdiff
path: root/dev-perl/Math-Random-ISAAC-XS/Math-Random-ISAAC-XS-1.4.0-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-07-03 22:39:47 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-07-03 22:39:47 +0100
commit7f0ccc917c7abe6223784c703d86cd14755691fb (patch)
tree8c6793f68896b341e22f33d7e6cef88e481f4a8b /dev-perl/Math-Random-ISAAC-XS/Math-Random-ISAAC-XS-1.4.0-r2.ebuild
parent9aa80713372911cec499b3adb2cd746790920916 (diff)
gentoo resync : 03.07.2021
Diffstat (limited to 'dev-perl/Math-Random-ISAAC-XS/Math-Random-ISAAC-XS-1.4.0-r2.ebuild')
-rw-r--r--dev-perl/Math-Random-ISAAC-XS/Math-Random-ISAAC-XS-1.4.0-r2.ebuild6
1 files changed, 4 insertions, 2 deletions
diff --git a/dev-perl/Math-Random-ISAAC-XS/Math-Random-ISAAC-XS-1.4.0-r2.ebuild b/dev-perl/Math-Random-ISAAC-XS/Math-Random-ISAAC-XS-1.4.0-r2.ebuild
index 078626b748d4..df555c82a4b6 100644
--- a/dev-perl/Math-Random-ISAAC-XS/Math-Random-ISAAC-XS-1.4.0-r2.ebuild
+++ b/dev-perl/Math-Random-ISAAC-XS/Math-Random-ISAAC-XS-1.4.0-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -12,7 +12,7 @@ DESCRIPTION="C implementation of the ISAAC PRNG algorithm"
LICENSE="public-domain || ( Artistic GPL-1+ )"
SLOT="0"
-KEYWORDS="~amd64 ~x86"
+KEYWORDS="amd64 x86"
IUSE="minimal test"
RESTRICT="!test? ( test )"
@@ -43,11 +43,13 @@ PERL_RM_FILES=(
t/release-pod-syntax.t
t/release-portability.t
)
+
src_configure() {
unset LD
[[ -n "${CCLD}" ]] && export LD="${CCLD}"
perl-module_src_configure
}
+
src_compile() {
./Build --config "optimize=${CFLAGS}" build || die
}