summaryrefslogtreecommitdiff
path: root/dev-perl/Module-Runtime/Module-Runtime-0.16.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-31 15:47:53 +0000
committerV3n3RiX <venerix@redcorelinux.org>2017-10-31 15:47:53 +0000
commitd950fa39dbe16d164ed0cb8e3036fd5d0d896a4c (patch)
tree04f92d5d1070a7aedb970ce4539dc6d60253c4df /dev-perl/Module-Runtime/Module-Runtime-0.16.0.ebuild
parentbd7908c6630f38067350d396ac5d18c3cc2434a0 (diff)
gentoo resync : 31.10.2017
Diffstat (limited to 'dev-perl/Module-Runtime/Module-Runtime-0.16.0.ebuild')
-rw-r--r--dev-perl/Module-Runtime/Module-Runtime-0.16.0.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-perl/Module-Runtime/Module-Runtime-0.16.0.ebuild b/dev-perl/Module-Runtime/Module-Runtime-0.16.0.ebuild
new file mode 100644
index 000000000000..ca4242298ab3
--- /dev/null
+++ b/dev-perl/Module-Runtime/Module-Runtime-0.16.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=ZEFRAM
+DIST_VERSION=0.016
+inherit perl-module
+
+DESCRIPTION="Runtime module handling"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
+IUSE="test"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-perl/Module-Build
+ test? (
+ virtual/perl-Test-Simple
+ )
+"
+
+SRC_TEST="do"
+
+src_test() {
+ perl_rm_files t/pod_cvg.t t/pod_syn.t
+ perl-module_src_test
+}