summaryrefslogtreecommitdiff
path: root/dev-perl/MogileFS-Server
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-perl/MogileFS-Server
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-perl/MogileFS-Server')
-rw-r--r--dev-perl/MogileFS-Server/Manifest4
-rw-r--r--dev-perl/MogileFS-Server/MogileFS-Server-2.720.0-r1.ebuild77
-rw-r--r--dev-perl/MogileFS-Server/files/MogileFS-Server-2.720.0-gentoo-init-conf.patch184
-rw-r--r--dev-perl/MogileFS-Server/metadata.xml74
4 files changed, 339 insertions, 0 deletions
diff --git a/dev-perl/MogileFS-Server/Manifest b/dev-perl/MogileFS-Server/Manifest
new file mode 100644
index 000000000000..4d9c5448998a
--- /dev/null
+++ b/dev-perl/MogileFS-Server/Manifest
@@ -0,0 +1,4 @@
+AUX MogileFS-Server-2.720.0-gentoo-init-conf.patch 3945 BLAKE2B 590164b44c6f166950a7625b669a5ad94891b70d078b9c3780ed4385536cd124c6aefdca3aa29c2127cda61987f8b19e1ba5c59f48ee01d50d46060a1b2fd5f9 SHA512 e8a294dcea44a25f2128d199b3e202a799ed4fc8716ae1e99606ccee900a8d1ecb4a5dff7a5369038bf936bc40fcb2e0dae104a1a0d4415eb49dfbd47aa69a09
+DIST MogileFS-Server-2.72.tar.gz 200057 BLAKE2B 835a7799389e536b42ed000b8ce07225609501ee6a4c002253a0018d0b17c815e8825a56f78ee0c0604d57cafea45ac044fda4e6e6bc33e0b60b8ed5b51a7e10 SHA512 4076ba33123c984f9d7c56db7d308b4d857e852caa8d811d86ed551b9ab74a6dfc93b034d034ec2802376035799860c613aef2bdd3898c1225e37727fda34ade
+EBUILD MogileFS-Server-2.720.0-r1.ebuild 1983 BLAKE2B 10713fd1c36cf707c657b88d2592bcc07503ab6178006c9594233a7f9f9887c746d84702d3f9c7984c7d03dadc0e44347b30f7cf235725d99c7ee2cb4ad8444f SHA512 4fd691e7bc7d2fc49aa95471badefdd973ba7f4f53e7a1f1a4505e46b1c8f42e2b9a4b29560a50ac7020d59d2e065072f79d65ffc2b154fbc19b18b1783ef154
+MISC metadata.xml 4549 BLAKE2B eb81910b09295bbf72b0afc491e873184f7d6c247cc439c3df52dcdbab00af94b336491c218ef31e232fecdc5f3b89f44a233f6911c818b1c96e651c817f6336 SHA512 406e5860c1e43a71c2e101891b83986bdb9b604d5a92e021abdb1b28900b05bc51a81551ee8d535e31fc78b29e0de34fd956f4ccd3743ccf5d749600e0594bce
diff --git a/dev-perl/MogileFS-Server/MogileFS-Server-2.720.0-r1.ebuild b/dev-perl/MogileFS-Server/MogileFS-Server-2.720.0-r1.ebuild
new file mode 100644
index 000000000000..691d30b4fd8f
--- /dev/null
+++ b/dev-perl/MogileFS-Server/MogileFS-Server-2.720.0-r1.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=DORMANDO
+DIST_VERSION=${PV%0.0}
+inherit user perl-module
+
+DESCRIPTION="Server for the MogileFS distributed file system"
+HOMEPAGE="http://www.danga.com/mogilefs/ ${HOMEPAGE}"
+
+IUSE="mysql sqlite postgres"
+
+SLOT="0"
+LICENSE="|| ( Artistic GPL-2 )"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+# Upstream site recommends this,
+# but it breaks Perlbal
+# dev-perl/Perlbal-XS-HTTPHeaders
+RDEPEND="dev-perl/Net-Netmask
+ >=dev-perl/Danga-Socket-1.610.0
+ >=dev-perl/Sys-Syscall-0.220.0
+ >=dev-perl/Perlbal-1.790
+ >=dev-perl/IO-AIO-4
+ dev-perl/libwww-perl
+ >=dev-perl/MogileFS-Client-1.170.0
+ >=dev-perl/MogileFS-Utils-2.280.0
+ dev-perl/Cache-Memcached
+ dev-perl/DBI
+ mysql? ( dev-perl/DBD-mysql )
+ postgres? ( dev-perl/DBD-Pg )
+ sqlite? ( dev-perl/DBD-SQLite )"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/${P}-gentoo-init-conf.patch"
+)
+DIST_TEST="do"
+
+MOGILE_USER="mogile"
+
+pkg_setup() {
+ # Warning! It is important that the uid is constant over Gentoo machines
+ # As mogilefs may be used with non-local block devices that move!
+ enewuser ${MOGILE_USER} 460 -1 -1
+}
+
+src_install() {
+ perl-module_src_install || die "perl-module_src_install failed"
+ cd "${S}"
+
+ newconfd "${S}"/gentoo/conf.d/mogilefsd mogilefsd
+ newinitd "${S}"/gentoo/init.d/mogilefsd mogilefsd
+
+ newconfd "${S}"/gentoo/conf.d/mogstored mogstored
+ newinitd "${S}"/gentoo/init.d/mogstored mogstored
+
+ newinitd "${S}"/gentoo/init.d/mogautomount mogautomount
+
+ diropts -m 700 -o ${MOGILE_USER}
+ keepdir /var/mogdata
+
+ diropts -m 755 -o root
+ dodir /etc/mogilefs
+
+ insinto /etc/mogilefs
+ insopts -m 600 -o root -g ${MOGILE_USER}
+ newins "${S}"/gentoo/conf/mogilefsd.conf mogilefsd.conf
+ newins "${S}"/gentoo/conf/mogstored.conf mogstored.conf
+}
+
+pkg_postinst() {
+ chmod 640 "${ROOT}"/etc/mogilefs/{mogilefsd,mogstored}.conf
+ chown root:${MOGILE_USER} "${ROOT}"/etc/mogilefs/{mogilefsd,mogstored}.conf
+}
diff --git a/dev-perl/MogileFS-Server/files/MogileFS-Server-2.720.0-gentoo-init-conf.patch b/dev-perl/MogileFS-Server/files/MogileFS-Server-2.720.0-gentoo-init-conf.patch
new file mode 100644
index 000000000000..7a90e5c5d793
--- /dev/null
+++ b/dev-perl/MogileFS-Server/files/MogileFS-Server-2.720.0-gentoo-init-conf.patch
@@ -0,0 +1,184 @@
+diff --git a/gentoo/conf.d/mogilefsd b/gentoo/conf.d/mogilefsd
+new file mode 100644
+index 0000000..b6968d1
+--- /dev/null
++++ b/gentoo/conf.d/mogilefsd
+@@ -0,0 +1,3 @@
++PIDFILE="/var/run/mogile/mogilefsd.pid"
++MOGILEFSD_OPTS="--daemonize --pidfile=${PIDFILE}"
++# vim: ft=gentoo-conf-d:
+diff --git a/gentoo/conf.d/mogstored b/gentoo/conf.d/mogstored
+new file mode 100644
+index 0000000..aa3cb63
+--- /dev/null
++++ b/gentoo/conf.d/mogstored
+@@ -0,0 +1,3 @@
++PIDFILE="/var/run/mogile/mogstored.pid"
++MOGSTORED_OPTS=""
++# vim: ft=gentoo-conf-d:
+diff --git a/gentoo/conf/mogilefsd.conf b/gentoo/conf/mogilefsd.conf
+new file mode 100644
+index 0000000..df50e23
+--- /dev/null
++++ b/gentoo/conf/mogilefsd.conf
+@@ -0,0 +1,34 @@
++# System user
++user = mogile
++# These are set inside the Gentoo conf.d/mogilefsd
++#pidfile = /var/run/mogile/mogilefsd.pid
++#daemonize = 1
++
++# Database settings
++db_dsn = DBI:mysql:mogilefs
++db_user = mogile
++# You must insert your password here!
++db_pass = __PASSWORD__
++
++# Network settings
++#conf_port = 7001
++#listen = 10.0.0.1:7001,
++
++# Storage
++#mog_root = /mnt/mogilefs
++
++# Plugins
++#plugins = ...
++
++# Tuning knobs
++#query_jobs = 20
++#delete_jobs = 1
++#replicate_jobs = 1
++#monitor_jobs = 1
++#reaper_jobs = 1
++#min_free_space = 100
++#max_disk_age = 5
++#node_timeout = 2
++#old_repl_compat = 1
++#default_mindevcount = 2
++#no_unreachable_tracking = 1
+diff --git a/gentoo/conf/mogstored.conf b/gentoo/conf/mogstored.conf
+new file mode 100644
+index 0000000..100a8c3
+--- /dev/null
++++ b/gentoo/conf/mogstored.conf
+@@ -0,0 +1,21 @@
++# These are set inside the Gentoo conf.d/mogilefsd
++#pidfile = /var/run/mogile/mogstored.pid
++#daemonize = 1
++
++# Network settings
++#httplisten = 0.0.0.0:7500
++#mgmtlisten = 0.0.0.0:7501
++
++# Storage
++#docroot = /var/mogdata
++
++# Server type
++# Perlbal is the default
++#server = perlbal
++# But lighttpd is supported too
++#server = lighttpd
++#serverbin = /usr/sbin/lighttpd
++
++# Tuning knobs
++#max_conns = 10000
++#opt_iostat 1
+diff --git a/gentoo/init.d/mogautomount b/gentoo/init.d/mogautomount
+new file mode 100644
+index 0000000..f287366
+--- /dev/null
++++ b/gentoo/init.d/mogautomount
+@@ -0,0 +1,21 @@
++#!/sbin/openrc-run
++
++NAME="mogautomount"
++BINARY="/usr/bin/mogautomount"
++
++depend() {
++ use net
++ before mogstored
++}
++
++start() {
++ ebegin "Mounting MogileFS disks"
++ ${BINARY} --chmod-mountpoints
++ eend $?
++}
++
++stop() {
++ :
++}
++
++# vim: ft=gentoo-init-d:
+diff --git a/gentoo/init.d/mogilefsd b/gentoo/init.d/mogilefsd
+new file mode 100644
+index 0000000..062568e
+--- /dev/null
++++ b/gentoo/init.d/mogilefsd
+@@ -0,0 +1,31 @@
++#!/sbin/openrc-run
++
++NAME="mogilefsd"
++BINARY="/usr/bin/mogilefsd"
++MOGILE_UID="mogile"
++MOGILE_GID="mogile"
++
++depend() {
++ use net mysql postgresql
++ after mysql postgresql
++}
++
++start() {
++ checkpath --directory \
++ --owner "${MOGILE_UID}:${MOGILE_GID}" \
++ --mode 700 \
++ "$(dirname $PIDFILE)"
++ ebegin "Starting $NAME"
++ start-stop-daemon --chuid ${MOGILE_UID}:${MOGILE_GID} --start \
++ --pidfile ${PIDFILE} --exec ${BINARY} \
++ -- ${MOGILEFSD_OPTS}
++ eend $?
++}
++
++stop() {
++ ebegin "Stopping $NAME"
++ start-stop-daemon --stop --quiet --pidfile="${PIDFILE}"
++ eend $?
++}
++
++# vim: ft=gentoo-init-d noet:
+diff --git a/gentoo/init.d/mogstored b/gentoo/init.d/mogstored
+new file mode 100644
+index 0000000..d28a853
+--- /dev/null
++++ b/gentoo/init.d/mogstored
+@@ -0,0 +1,29 @@
++#!/sbin/openrc-run
++
++NAME="mogstored"
++BINARY="/usr/bin/mogstored"
++MOGILE_UID="mogile"
++MOGILE_GID="mogile"
++
++depend() {
++ use net logger
++ before mogilefsd
++ need mogautomount
++}
++
++start() {
++ install -o $MOGILE_UID -g $MOGILE_GID -d $(dirname $PIDFILE)
++ ebegin "Starting $NAME"
++ start-stop-daemon --start --quiet \
++ --pidfile=${PIDFILE} --exec ${BINARY} \
++ -- --daemonize --pidfile=${PIDFILE} ${MOGSTORED_OPTS}
++ eend $?
++}
++
++stop() {
++ ebegin "Stopping $NAME"
++ start-stop-daemon --stop --quiet --pidfile="${PIDFILE}"
++ eend $?
++}
++
++# vim: ft=gentoo-init-d:
diff --git a/dev-perl/MogileFS-Server/metadata.xml b/dev-perl/MogileFS-Server/metadata.xml
new file mode 100644
index 000000000000..fae2fa3f85f4
--- /dev/null
+++ b/dev-perl/MogileFS-Server/metadata.xml
@@ -0,0 +1,74 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>robbat2@gentoo.org</email>
+ </maintainer>
+ <maintainer type="project">
+ <email>perl@gentoo.org</email>
+ <name>Gentoo Perl Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="cpan">MogileFS-Server</remote-id>
+ <remote-id type="cpan-module">Mgd</remote-id>
+ <remote-id type="cpan-module">MogPath</remote-id>
+ <remote-id type="cpan-module">MogileFS</remote-id>
+ <remote-id type="cpan-module">MogileFS::Checksum</remote-id>
+ <remote-id type="cpan-module">MogileFS::Class</remote-id>
+ <remote-id type="cpan-module">MogileFS::Config</remote-id>
+ <remote-id type="cpan-module">MogileFS::Connection::Client</remote-id>
+ <remote-id type="cpan-module">MogileFS::Connection::Mogstored</remote-id>
+ <remote-id type="cpan-module">MogileFS::Connection::Worker</remote-id>
+ <remote-id type="cpan-module">MogileFS::DevFID</remote-id>
+ <remote-id type="cpan-module">MogileFS::Device</remote-id>
+ <remote-id type="cpan-module">MogileFS::DeviceState</remote-id>
+ <remote-id type="cpan-module">MogileFS::Domain</remote-id>
+ <remote-id type="cpan-module">MogileFS::Exception</remote-id>
+ <remote-id type="cpan-module">MogileFS::FID</remote-id>
+ <remote-id type="cpan-module">MogileFS::Factory</remote-id>
+ <remote-id type="cpan-module">MogileFS::Factory::Class</remote-id>
+ <remote-id type="cpan-module">MogileFS::Factory::Device</remote-id>
+ <remote-id type="cpan-module">MogileFS::Factory::Domain</remote-id>
+ <remote-id type="cpan-module">MogileFS::Factory::Host</remote-id>
+ <remote-id type="cpan-module">MogileFS::HTTPFile</remote-id>
+ <remote-id type="cpan-module">MogileFS::Host</remote-id>
+ <remote-id type="cpan-module">MogileFS::IOStatWatch::Client</remote-id>
+ <remote-id type="cpan-module">MogileFS::IOStatWatcher</remote-id>
+ <remote-id type="cpan-module">MogileFS::ProcManager</remote-id>
+ <remote-id type="cpan-module">MogileFS::Rebalance</remote-id>
+ <remote-id type="cpan-module">MogileFS::ReplicationPolicy</remote-id>
+ <remote-id type="cpan-module">MogileFS::ReplicationPolicy::MultipleHosts</remote-id>
+ <remote-id type="cpan-module">MogileFS::ReplicationPolicy::Union</remote-id>
+ <remote-id type="cpan-module">MogileFS::ReplicationRequest</remote-id>
+ <remote-id type="cpan-module">MogileFS::Server</remote-id>
+ <remote-id type="cpan-module">MogileFS::Store</remote-id>
+ <remote-id type="cpan-module">MogileFS::Store::MySQL</remote-id>
+ <remote-id type="cpan-module">MogileFS::Store::Postgres</remote-id>
+ <remote-id type="cpan-module">MogileFS::Store::SQLite</remote-id>
+ <remote-id type="cpan-module">MogileFS::Test</remote-id>
+ <remote-id type="cpan-module">MogileFS::Util</remote-id>
+ <remote-id type="cpan-module">MogileFS::Worker</remote-id>
+ <remote-id type="cpan-module">MogileFS::Worker::Delete</remote-id>
+ <remote-id type="cpan-module">MogileFS::Worker::Fsck</remote-id>
+ <remote-id type="cpan-module">MogileFS::Worker::JobMaster</remote-id>
+ <remote-id type="cpan-module">MogileFS::Worker::Monitor</remote-id>
+ <remote-id type="cpan-module">MogileFS::Worker::Query</remote-id>
+ <remote-id type="cpan-module">MogileFS::Worker::Reaper</remote-id>
+ <remote-id type="cpan-module">MogileFS::Worker::Replicate</remote-id>
+ <remote-id type="cpan-module">Mogstored::ChildProcess</remote-id>
+ <remote-id type="cpan-module">Mogstored::ChildProcess::DiskUsage</remote-id>
+ <remote-id type="cpan-module">Mogstored::ChildProcess::IOStat</remote-id>
+ <remote-id type="cpan-module">Mogstored::FIDStatter</remote-id>
+ <remote-id type="cpan-module">Mogstored::HTTPServer</remote-id>
+ <remote-id type="cpan-module">Mogstored::HTTPServer::Apache</remote-id>
+ <remote-id type="cpan-module">Mogstored::HTTPServer::Lighttpd</remote-id>
+ <remote-id type="cpan-module">Mogstored::HTTPServer::None</remote-id>
+ <remote-id type="cpan-module">Mogstored::HTTPServer::Perlbal</remote-id>
+ <remote-id type="cpan-module">Mogstored::SideChannelClient</remote-id>
+ <remote-id type="cpan-module">Mogstored::SideChannelListener</remote-id>
+ <remote-id type="cpan-module">Mogstored::TaskQueue</remote-id>
+ <remote-id type="cpan-module">MogstoredHandle</remote-id>
+ <remote-id type="cpan-module">ProcessHandle</remote-id>
+ <remote-id type="cpan-module">TrackerHandle</remote-id>
+ </upstream>
+</pkgmetadata>