summaryrefslogtreecommitdiff
path: root/dev-perl/MongoDB
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-perl/MongoDB
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-perl/MongoDB')
-rw-r--r--dev-perl/MongoDB/Manifest5
-rw-r--r--dev-perl/MongoDB/MongoDB-1.8.0.ebuild79
-rw-r--r--dev-perl/MongoDB/metadata.xml68
3 files changed, 152 insertions, 0 deletions
diff --git a/dev-perl/MongoDB/Manifest b/dev-perl/MongoDB/Manifest
new file mode 100644
index 000000000000..1ebce42ed4d4
--- /dev/null
+++ b/dev-perl/MongoDB/Manifest
@@ -0,0 +1,5 @@
+DIST MongoDB-v1.8.0.tar.gz 521237 SHA256 6772215b863baa685e23cda10492f536738d45281f7ae136d426d221b743b5fc SHA512 1346a1c82528f409f467e77cb713af856d8dcd90ff57d07ce9312d60a16c7b7922dc99fb23a5374447ba61a082de43eccd495c779cd8a32463a039a6a13fa427 WHIRLPOOL c3d2a42ce0b486b2abcf0d33e77f638fe041d96dc3c0c3a6f810d32dbf9a5b516c154963c66857d4896f9ca71ad450b17c357875d5592d241f90bb3ed2d22f60
+EBUILD MongoDB-1.8.0.ebuild 1770 SHA256 86c521e2c51ddc151406106cff951066293349bbdf3e23e9984337cabd346bc2 SHA512 c83f1bc99c2c5aae23d3a6bec9dc4cce7b5ca03eca8e5757ee00e149a095b3d288faf7fa08e479cfb6e7b2bc30148cc6b85a8b9df2e543aac64f4eefb4fb36db WHIRLPOOL 6c3e630e4bffdb3996f0ed6ac5100cfe240072dc89fec430ead971e2b75d0dc268799377d8f7e11cbf75e58148240283237a3ab69564c5c04262b3d6be76240c
+MISC ChangeLog 3975 SHA256 9b4c11a938f43f09c8d45f1a22cc120aa44b69defd2100f71c5eee815644c739 SHA512 ead7caa0f969193853d97893da444a027ad020adc2e98ba83dcfe0b3c22f60aea89e507aef0616709530781b9760b013246cfc09069841131df49400fbc76a70 WHIRLPOOL 594097fb5d403445adf5439b92826d294b589a39dd3215589e3c040513352df155c72737ede12ccaade972d2861c5f09522d844b6eb9ca74e484051d0b0a4432
+MISC ChangeLog-2015 1201 SHA256 91d52bc78b539b40c53d2e22d182a8228b17d7e445229adaf57eb04ca7c7c7bf SHA512 788e0cc31a5204e52167d092a532c61af747f85a90234e8c01f28b26525f135f02ff9dd8cdbfe3d667a8bda680974bade09db481700b2793f651cba1eda7a877 WHIRLPOOL d76a62ec1969d33e627366081ced4ad4f72cc59669716086b32b162b0e63a88cbd06be5f5490e313a0ac00f7dca0244d1a5e18b6ac54893c74fbc554cefec356
+MISC metadata.xml 4054 SHA256 86e06e55fd0a8d91333597ff8ab53c05831a16e4a8d091f3eca51346d9a3ba07 SHA512 30e0c287025fe86f05445614f4d2ce496e364e1642b89f3d2f3ffb0a1871ffc12769808c8af84ebca141e555fe96ab14f760a3b934e29da0ba878121525f367f WHIRLPOOL 13aea60916b580e0e68b1b20f88a388c9b4009d3cd042ab3b1542d89f249cacfc551be9bac95a13fa643f1c48bb491fea7f312250b2d3364b060714da6f2ea50
diff --git a/dev-perl/MongoDB/MongoDB-1.8.0.ebuild b/dev-perl/MongoDB/MongoDB-1.8.0.ebuild
new file mode 100644
index 000000000000..566c6bb8cd99
--- /dev/null
+++ b/dev-perl/MongoDB/MongoDB-1.8.0.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+DIST_AUTHOR=MONGODB
+DIST_VERSION="v${PV}"
+
+inherit perl-module
+
+DESCRIPTION="Official MongoDB Driver for Perl"
+SLOT="0"
+
+KEYWORDS="~amd64"
+
+LICENSE="Apache-2.0"
+IUSE="test minimal"
+
+# IO::Socket::SSL was escallated from suggested to recommended
+RDEPEND="
+ !minimal? (
+ >=virtual/perl-IO-Socket-IP-0.250.0
+ >=dev-perl/IO-Socket-SSL-1.560.0
+ >=dev-perl/Mozilla-CA-20130114
+ >=dev-perl/Net-SSLeay-1.490.0
+ )
+ >=dev-perl/Authen-SCRAM-0.3.0
+ dev-perl/BSON
+ virtual/perl-Carp
+ dev-perl/Class-XSAccessor
+ >=dev-perl/DateTime-0.780.0
+ virtual/perl-Digest-MD5
+ virtual/perl-Encode
+ >=virtual/perl-Exporter-5.570.0
+ virtual/perl-IO
+ virtual/perl-MIME-Base64
+ >=dev-perl/Moo-2
+ dev-perl/Safe-Isa
+ virtual/perl-Scalar-List-Utils
+ virtual/perl-Socket
+ dev-perl/Tie-IxHash
+ virtual/perl-Time-HiRes
+ dev-perl/Try-Tiny
+ dev-perl/Type-Tiny
+ dev-perl/Type-Tiny-XS
+ virtual/perl-XSLoader
+ >=dev-perl/boolean-0.250.0
+ virtual/perl-if
+ dev-perl/namespace-clean
+ virtual/perl-version
+"
+DEPEND="${RDEPEND}
+ >=dev-perl/Config-AutoConf-0.220.0
+ virtual/perl-ExtUtils-MakeMaker
+ >=dev-perl/Path-Tiny-0.52.0
+ test? (
+ !minimal? (
+ >=virtual/perl-CPAN-Meta-2.120.900
+ >=dev-perl/DateTime-Tiny-1.0.0
+ >=virtual/perl-Test-Harness-3.310.0
+ >=dev-perl/Time-Moment-0.220.0
+ )
+ virtual/perl-Data-Dumper
+ virtual/perl-File-Spec
+ virtual/perl-File-Temp
+ dev-perl/JSON-MaybeXS
+ virtual/perl-Math-BigInt
+ >=dev-perl/Path-Tiny-0.54.0
+ >=dev-perl/Test-Deep-0.111.0
+ dev-perl/Test-Fatal
+ >=virtual/perl-Test-Simple-0.960.0
+ virtual/perl-bignum
+ virtual/perl-threads-shared
+ )
+"
+
+pkg_setup() {
+ # https://jira.mongodb.org/browse/PERL-766
+ LDFLAGS="${LDFLAGS} -lpthread"
+}
diff --git a/dev-perl/MongoDB/metadata.xml b/dev-perl/MongoDB/metadata.xml
new file mode 100644
index 000000000000..778f1221b220
--- /dev/null
+++ b/dev-perl/MongoDB/metadata.xml
@@ -0,0 +1,68 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>chainsaw@gentoo.org</email>
+ <name>Tony Vroon</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>perl@gentoo.org</email>
+ <name>Gentoo Perl Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="cpan">MongoDB</remote-id>
+ <remote-id type="cpan-module">MongoDB</remote-id>
+ <remote-id type="cpan-module">MongoDB::AuthError</remote-id>
+ <remote-id type="cpan-module">MongoDB::BSON</remote-id>
+ <remote-id type="cpan-module">MongoDB::BSON::Binary</remote-id>
+ <remote-id type="cpan-module">MongoDB::BSON::Regexp</remote-id>
+ <remote-id type="cpan-module">MongoDB::BulkWrite</remote-id>
+ <remote-id type="cpan-module">MongoDB::BulkWriteResult</remote-id>
+ <remote-id type="cpan-module">MongoDB::BulkWriteView</remote-id>
+ <remote-id type="cpan-module">MongoDB::Code</remote-id>
+ <remote-id type="cpan-module">MongoDB::Collection</remote-id>
+ <remote-id type="cpan-module">MongoDB::CommandResult</remote-id>
+ <remote-id type="cpan-module">MongoDB::ConnectionError</remote-id>
+ <remote-id type="cpan-module">MongoDB::Cursor</remote-id>
+ <remote-id type="cpan-module">MongoDB::CursorNotFoundError</remote-id>
+ <remote-id type="cpan-module">MongoDB::DBRef</remote-id>
+ <remote-id type="cpan-module">MongoDB::Database</remote-id>
+ <remote-id type="cpan-module">MongoDB::DatabaseError</remote-id>
+ <remote-id type="cpan-module">MongoDB::DecodingError</remote-id>
+ <remote-id type="cpan-module">MongoDB::DeleteResult</remote-id>
+ <remote-id type="cpan-module">MongoDB::DocumentError</remote-id>
+ <remote-id type="cpan-module">MongoDB::DuplicateKeyError</remote-id>
+ <remote-id type="cpan-module">MongoDB::Error</remote-id>
+ <remote-id type="cpan-module">MongoDB::ExecutionTimeout</remote-id>
+ <remote-id type="cpan-module">MongoDB::GridFS</remote-id>
+ <remote-id type="cpan-module">MongoDB::GridFS::File</remote-id>
+ <remote-id type="cpan-module">MongoDB::GridFSBucket</remote-id>
+ <remote-id type="cpan-module">MongoDB::GridFSBucket::DownloadStream</remote-id>
+ <remote-id type="cpan-module">MongoDB::GridFSBucket::UploadStream</remote-id>
+ <remote-id type="cpan-module">MongoDB::GridFSError</remote-id>
+ <remote-id type="cpan-module">MongoDB::HandshakeError</remote-id>
+ <remote-id type="cpan-module">MongoDB::IndexView</remote-id>
+ <remote-id type="cpan-module">MongoDB::InsertManyResult</remote-id>
+ <remote-id type="cpan-module">MongoDB::InsertOneResult</remote-id>
+ <remote-id type="cpan-module">MongoDB::InternalError</remote-id>
+ <remote-id type="cpan-module">MongoDB::MongoClient</remote-id>
+ <remote-id type="cpan-module">MongoDB::NetworkError</remote-id>
+ <remote-id type="cpan-module">MongoDB::NetworkTimeout</remote-id>
+ <remote-id type="cpan-module">MongoDB::NotMasterError</remote-id>
+ <remote-id type="cpan-module">MongoDB::OID</remote-id>
+ <remote-id type="cpan-module">MongoDB::ProtocolError</remote-id>
+ <remote-id type="cpan-module">MongoDB::QueryResult</remote-id>
+ <remote-id type="cpan-module">MongoDB::QueryResult::Filtered</remote-id>
+ <remote-id type="cpan-module">MongoDB::ReadConcern</remote-id>
+ <remote-id type="cpan-module">MongoDB::ReadPreference</remote-id>
+ <remote-id type="cpan-module">MongoDB::SelectionError</remote-id>
+ <remote-id type="cpan-module">MongoDB::TimeoutError</remote-id>
+ <remote-id type="cpan-module">MongoDB::Timestamp</remote-id>
+ <remote-id type="cpan-module">MongoDB::UnacknowledgedResult</remote-id>
+ <remote-id type="cpan-module">MongoDB::UpdateResult</remote-id>
+ <remote-id type="cpan-module">MongoDB::UsageError</remote-id>
+ <remote-id type="cpan-module">MongoDB::WriteConcern</remote-id>
+ <remote-id type="cpan-module">MongoDB::WriteConcernError</remote-id>
+ <remote-id type="cpan-module">MongoDB::WriteError</remote-id>
+ </upstream>
+</pkgmetadata>