summaryrefslogtreecommitdiff
path: root/dev-perl/MongoDB
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-perl/MongoDB
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-perl/MongoDB')
-rw-r--r--dev-perl/MongoDB/Manifest3
-rw-r--r--dev-perl/MongoDB/MongoDB-1.8.0.ebuild79
-rw-r--r--dev-perl/MongoDB/metadata.xml68
3 files changed, 150 insertions, 0 deletions
diff --git a/dev-perl/MongoDB/Manifest b/dev-perl/MongoDB/Manifest
new file mode 100644
index 000000000000..af6772ed4f14
--- /dev/null
+++ b/dev-perl/MongoDB/Manifest
@@ -0,0 +1,3 @@
+DIST MongoDB-v1.8.0.tar.gz 521237 BLAKE2B 95e6da1c4bb19dd778c3b02d4b58a27f2b4e492da7dbdd14ec2fd9aa4af690166a5aa0884785dd169292c4787b13eb96f906ca7f8c1d51fd0fe3f91b7a42118f SHA512 1346a1c82528f409f467e77cb713af856d8dcd90ff57d07ce9312d60a16c7b7922dc99fb23a5374447ba61a082de43eccd495c779cd8a32463a039a6a13fa427
+EBUILD MongoDB-1.8.0.ebuild 1770 BLAKE2B feb1b46fba80f0f32ce7057eb292b0b96b00b0de70ab741d9503f843cab7e19f3b04d0ae5db3b7984ba393658891006d59b5ff4d64e3f9122989da913a3fb15e SHA512 c83f1bc99c2c5aae23d3a6bec9dc4cce7b5ca03eca8e5757ee00e149a095b3d288faf7fa08e479cfb6e7b2bc30148cc6b85a8b9df2e543aac64f4eefb4fb36db
+MISC metadata.xml 4054 BLAKE2B 79af21c932c70775e153174080fae05e7c3dce0633c4ddd0742a72129d699cd74386d7a45216ca4363d7297a45805d715e7ab146b2f36931841a6d07bee16594 SHA512 30e0c287025fe86f05445614f4d2ce496e364e1642b89f3d2f3ffb0a1871ffc12769808c8af84ebca141e555fe96ab14f760a3b934e29da0ba878121525f367f
diff --git a/dev-perl/MongoDB/MongoDB-1.8.0.ebuild b/dev-perl/MongoDB/MongoDB-1.8.0.ebuild
new file mode 100644
index 000000000000..566c6bb8cd99
--- /dev/null
+++ b/dev-perl/MongoDB/MongoDB-1.8.0.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+DIST_AUTHOR=MONGODB
+DIST_VERSION="v${PV}"
+
+inherit perl-module
+
+DESCRIPTION="Official MongoDB Driver for Perl"
+SLOT="0"
+
+KEYWORDS="~amd64"
+
+LICENSE="Apache-2.0"
+IUSE="test minimal"
+
+# IO::Socket::SSL was escallated from suggested to recommended
+RDEPEND="
+ !minimal? (
+ >=virtual/perl-IO-Socket-IP-0.250.0
+ >=dev-perl/IO-Socket-SSL-1.560.0
+ >=dev-perl/Mozilla-CA-20130114
+ >=dev-perl/Net-SSLeay-1.490.0
+ )
+ >=dev-perl/Authen-SCRAM-0.3.0
+ dev-perl/BSON
+ virtual/perl-Carp
+ dev-perl/Class-XSAccessor
+ >=dev-perl/DateTime-0.780.0
+ virtual/perl-Digest-MD5
+ virtual/perl-Encode
+ >=virtual/perl-Exporter-5.570.0
+ virtual/perl-IO
+ virtual/perl-MIME-Base64
+ >=dev-perl/Moo-2
+ dev-perl/Safe-Isa
+ virtual/perl-Scalar-List-Utils
+ virtual/perl-Socket
+ dev-perl/Tie-IxHash
+ virtual/perl-Time-HiRes
+ dev-perl/Try-Tiny
+ dev-perl/Type-Tiny
+ dev-perl/Type-Tiny-XS
+ virtual/perl-XSLoader
+ >=dev-perl/boolean-0.250.0
+ virtual/perl-if
+ dev-perl/namespace-clean
+ virtual/perl-version
+"
+DEPEND="${RDEPEND}
+ >=dev-perl/Config-AutoConf-0.220.0
+ virtual/perl-ExtUtils-MakeMaker
+ >=dev-perl/Path-Tiny-0.52.0
+ test? (
+ !minimal? (
+ >=virtual/perl-CPAN-Meta-2.120.900
+ >=dev-perl/DateTime-Tiny-1.0.0
+ >=virtual/perl-Test-Harness-3.310.0
+ >=dev-perl/Time-Moment-0.220.0
+ )
+ virtual/perl-Data-Dumper
+ virtual/perl-File-Spec
+ virtual/perl-File-Temp
+ dev-perl/JSON-MaybeXS
+ virtual/perl-Math-BigInt
+ >=dev-perl/Path-Tiny-0.54.0
+ >=dev-perl/Test-Deep-0.111.0
+ dev-perl/Test-Fatal
+ >=virtual/perl-Test-Simple-0.960.0
+ virtual/perl-bignum
+ virtual/perl-threads-shared
+ )
+"
+
+pkg_setup() {
+ # https://jira.mongodb.org/browse/PERL-766
+ LDFLAGS="${LDFLAGS} -lpthread"
+}
diff --git a/dev-perl/MongoDB/metadata.xml b/dev-perl/MongoDB/metadata.xml
new file mode 100644
index 000000000000..778f1221b220
--- /dev/null
+++ b/dev-perl/MongoDB/metadata.xml
@@ -0,0 +1,68 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>chainsaw@gentoo.org</email>
+ <name>Tony Vroon</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>perl@gentoo.org</email>
+ <name>Gentoo Perl Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="cpan">MongoDB</remote-id>
+ <remote-id type="cpan-module">MongoDB</remote-id>
+ <remote-id type="cpan-module">MongoDB::AuthError</remote-id>
+ <remote-id type="cpan-module">MongoDB::BSON</remote-id>
+ <remote-id type="cpan-module">MongoDB::BSON::Binary</remote-id>
+ <remote-id type="cpan-module">MongoDB::BSON::Regexp</remote-id>
+ <remote-id type="cpan-module">MongoDB::BulkWrite</remote-id>
+ <remote-id type="cpan-module">MongoDB::BulkWriteResult</remote-id>
+ <remote-id type="cpan-module">MongoDB::BulkWriteView</remote-id>
+ <remote-id type="cpan-module">MongoDB::Code</remote-id>
+ <remote-id type="cpan-module">MongoDB::Collection</remote-id>
+ <remote-id type="cpan-module">MongoDB::CommandResult</remote-id>
+ <remote-id type="cpan-module">MongoDB::ConnectionError</remote-id>
+ <remote-id type="cpan-module">MongoDB::Cursor</remote-id>
+ <remote-id type="cpan-module">MongoDB::CursorNotFoundError</remote-id>
+ <remote-id type="cpan-module">MongoDB::DBRef</remote-id>
+ <remote-id type="cpan-module">MongoDB::Database</remote-id>
+ <remote-id type="cpan-module">MongoDB::DatabaseError</remote-id>
+ <remote-id type="cpan-module">MongoDB::DecodingError</remote-id>
+ <remote-id type="cpan-module">MongoDB::DeleteResult</remote-id>
+ <remote-id type="cpan-module">MongoDB::DocumentError</remote-id>
+ <remote-id type="cpan-module">MongoDB::DuplicateKeyError</remote-id>
+ <remote-id type="cpan-module">MongoDB::Error</remote-id>
+ <remote-id type="cpan-module">MongoDB::ExecutionTimeout</remote-id>
+ <remote-id type="cpan-module">MongoDB::GridFS</remote-id>
+ <remote-id type="cpan-module">MongoDB::GridFS::File</remote-id>
+ <remote-id type="cpan-module">MongoDB::GridFSBucket</remote-id>
+ <remote-id type="cpan-module">MongoDB::GridFSBucket::DownloadStream</remote-id>
+ <remote-id type="cpan-module">MongoDB::GridFSBucket::UploadStream</remote-id>
+ <remote-id type="cpan-module">MongoDB::GridFSError</remote-id>
+ <remote-id type="cpan-module">MongoDB::HandshakeError</remote-id>
+ <remote-id type="cpan-module">MongoDB::IndexView</remote-id>
+ <remote-id type="cpan-module">MongoDB::InsertManyResult</remote-id>
+ <remote-id type="cpan-module">MongoDB::InsertOneResult</remote-id>
+ <remote-id type="cpan-module">MongoDB::InternalError</remote-id>
+ <remote-id type="cpan-module">MongoDB::MongoClient</remote-id>
+ <remote-id type="cpan-module">MongoDB::NetworkError</remote-id>
+ <remote-id type="cpan-module">MongoDB::NetworkTimeout</remote-id>
+ <remote-id type="cpan-module">MongoDB::NotMasterError</remote-id>
+ <remote-id type="cpan-module">MongoDB::OID</remote-id>
+ <remote-id type="cpan-module">MongoDB::ProtocolError</remote-id>
+ <remote-id type="cpan-module">MongoDB::QueryResult</remote-id>
+ <remote-id type="cpan-module">MongoDB::QueryResult::Filtered</remote-id>
+ <remote-id type="cpan-module">MongoDB::ReadConcern</remote-id>
+ <remote-id type="cpan-module">MongoDB::ReadPreference</remote-id>
+ <remote-id type="cpan-module">MongoDB::SelectionError</remote-id>
+ <remote-id type="cpan-module">MongoDB::TimeoutError</remote-id>
+ <remote-id type="cpan-module">MongoDB::Timestamp</remote-id>
+ <remote-id type="cpan-module">MongoDB::UnacknowledgedResult</remote-id>
+ <remote-id type="cpan-module">MongoDB::UpdateResult</remote-id>
+ <remote-id type="cpan-module">MongoDB::UsageError</remote-id>
+ <remote-id type="cpan-module">MongoDB::WriteConcern</remote-id>
+ <remote-id type="cpan-module">MongoDB::WriteConcernError</remote-id>
+ <remote-id type="cpan-module">MongoDB::WriteError</remote-id>
+ </upstream>
+</pkgmetadata>