summaryrefslogtreecommitdiff
path: root/dev-perl/Moo/Moo-2.3.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-perl/Moo/Moo-2.3.2.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-perl/Moo/Moo-2.3.2.ebuild')
-rw-r--r--dev-perl/Moo/Moo-2.3.2.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-perl/Moo/Moo-2.3.2.ebuild b/dev-perl/Moo/Moo-2.3.2.ebuild
new file mode 100644
index 000000000000..614b5da4dd63
--- /dev/null
+++ b/dev-perl/Moo/Moo-2.3.2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=HAARG
+DIST_VERSION=2.003002
+inherit perl-module
+
+DESCRIPTION="Minimalist Object Orientation (with Moose compatiblity)"
+
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~x86 ~ppc-aix ~ppc-macos ~x86-solaris"
+IUSE="test"
+
+# needs Scalar::Util
+RDEPEND="
+ >=dev-perl/Class-Method-Modifiers-1.100.0
+ >=dev-perl/Devel-GlobalDestruction-0.110.0
+ >=virtual/perl-Exporter-5.570.0
+ >=dev-perl/Module-Runtime-0.14.0
+ >=dev-perl/Role-Tiny-2.0.4
+ >=dev-perl/Sub-Quote-2.3.1
+ virtual/perl-Scalar-List-Utils
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ >=dev-perl/Test-Fatal-0.3.0
+ >=virtual/perl-Test-Simple-0.940.0
+ )
+"