summaryrefslogtreecommitdiff
path: root/dev-perl/Mozilla-PublicSuffix
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-perl/Mozilla-PublicSuffix
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-perl/Mozilla-PublicSuffix')
-rw-r--r--dev-perl/Mozilla-PublicSuffix/Manifest4
-rw-r--r--dev-perl/Mozilla-PublicSuffix/Mozilla-PublicSuffix-1.0.0.ebuild33
-rw-r--r--dev-perl/Mozilla-PublicSuffix/files/1.0.0-no-dynamic-update.patch90
-rw-r--r--dev-perl/Mozilla-PublicSuffix/metadata.xml12
4 files changed, 139 insertions, 0 deletions
diff --git a/dev-perl/Mozilla-PublicSuffix/Manifest b/dev-perl/Mozilla-PublicSuffix/Manifest
new file mode 100644
index 000000000000..c566e8f5ea30
--- /dev/null
+++ b/dev-perl/Mozilla-PublicSuffix/Manifest
@@ -0,0 +1,4 @@
+AUX 1.0.0-no-dynamic-update.patch 2472 SHA256 37a63fc0db458dcfe2852fc1607f20239afd47491da5fcc72e15a57280de36cf SHA512 3c264b0cdddbbab0845a8baee1cb669ef5e706cd85fd118de6a5f8bd34d15686e97e617519389664a0ca11386e06300259cafd4fca1c6087699826a1df391e1b WHIRLPOOL 177500f6058c9017abc29cefd076c797ec4377d49ab9c389411593e4a35b4f10395a2df66964d66fa34c96ae06c306c25a2e5dd01dc9392c815a1a835f071c1d
+DIST Mozilla-PublicSuffix-v1.0.0.tar.gz 71669 SHA256 8185ca687ad1c51e18cb472831f80160d6432376a06a19f864d617147b003dee SHA512 79ed7256bccb33f1f428657bd60cccaf7be5d4793424337b94a812a41f46e90507b8c32b3aa8b381bf16d77f4a3f911301f757332e9144718efd2341996d9cc6 WHIRLPOOL 1cab25d4505601bcaab570873225b78f1996e0fbc95325c6cc1799efc956255f361c2e35669384f121d112e2ea88e4359167b0edd5930d81d0cb03d206972195
+EBUILD Mozilla-PublicSuffix-1.0.0.ebuild 623 SHA256 15d8f3bc3c373737bae9af63e5238282d23db1e14f610b937db421a4d3234735 SHA512 b59677c538e4f2eebb11be427f5d3456472f3b73d136a2479a2f4488fa50b8c66ddc5cc096d187b0d720c4048a253474d99fb6bada4ce0f2ae2d7081041f5115 WHIRLPOOL a9bf779bfb679d00c8e29447938923d966592be9e68b2534c60c8a61854baf47ed91506ac9a4386631168a21abfc3d4b6a695af4f4701e68a02616caac78df59
+MISC metadata.xml 412 SHA256 02fe2a602445aa396eb8a9a7998d24c0b33440b2387cb1dcd54058529a93a414 SHA512 80903f8d4a6deca1a52e6cd413ccc9aa6bbc9e1cae0c5130c128f5b0c1fcfe837ec318ce2f436f7a584ce1140ebbf57a961b4164886c4c06c2a1acd12726400b WHIRLPOOL 15ac419f4664fea7d5dac149964a83eb95276faf3a2405504a2fbcc689d73f92c69300e93e58f151dd9bb7a1c80040185cfeeccbeb93f16fdc75ba5cbd44b198
diff --git a/dev-perl/Mozilla-PublicSuffix/Mozilla-PublicSuffix-1.0.0.ebuild b/dev-perl/Mozilla-PublicSuffix/Mozilla-PublicSuffix-1.0.0.ebuild
new file mode 100644
index 000000000000..789e8fa1b05b
--- /dev/null
+++ b/dev-perl/Mozilla-PublicSuffix/Mozilla-PublicSuffix-1.0.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=RSIMOES
+DIST_VERSION="v${PV}"
+inherit perl-module
+
+DESCRIPTION="Get a domain name's public suffix via the Mozilla Public Suffix List"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+PATCHES=(
+ "${FILESDIR}/${PV}-no-dynamic-update.patch"
+)
+RDEPEND="
+ virtual/perl-Exporter
+ dev-perl/URI
+"
+DEPEND="${RDEPEND}
+ virtual/perl-IO
+ >=dev-perl/Module-Build-0.280.0
+ test? (
+ virtual/perl-Test-Simple
+ virtual/perl-File-Spec
+ )
+"
+src_test() {
+ perl_rm_files t/author-* t/release-*
+ perl-module_src_test
+}
diff --git a/dev-perl/Mozilla-PublicSuffix/files/1.0.0-no-dynamic-update.patch b/dev-perl/Mozilla-PublicSuffix/files/1.0.0-no-dynamic-update.patch
new file mode 100644
index 000000000000..99c76a4dc754
--- /dev/null
+++ b/dev-perl/Mozilla-PublicSuffix/files/1.0.0-no-dynamic-update.patch
@@ -0,0 +1,90 @@
+From 7dcc6afa75d5318325856fdef0456f4ddf1672b1 Mon Sep 17 00:00:00 2001
+From: Kent Fredric <kentfredric@gmail.com>
+Date: Fri, 6 Jan 2017 12:32:50 +1300
+Subject: [PATCH] Remove dynamic update code
+
+As this basically makes builds unreproducale anyway, and the download
+URI is invariant meaning we can't even approximate the same logic via
+SRC_URI without having frequently changing Manifests, but no change in
+URI.
+---
+ Build.PL | 26 --------------------------
+ META.yml | 2 --
+ 2 files changed, 28 deletions(-)
+
+diff --git a/Build.PL b/Build.PL
+index 7ef1ca0..1e7834d 100755
+--- a/Build.PL
++++ b/Build.PL
+@@ -5,11 +5,9 @@ use warnings FATAL => "all";
+ use utf8;
+ use open ":encoding(UTF-8)";
+ use Carp qw(croak);
+-use HTTP::Tiny;
+ use Module::Build;
+ use IO::File;
+ use Tie::File;
+-use URI;
+
+ my $builder = Module::Build->new(
+ dist_name => "Mozilla-PublicSuffix",
+@@ -28,11 +26,9 @@ my $builder = Module::Build->new(
+ 'perl' => '5.008'
+ },
+ 'configure_requires' => {
+- 'HTTP::Tiny' => '0',
+ 'IO::File' => '0',
+ 'Module::Build' => '0.28',
+ 'Tie::File' => '0',
+- 'URI' => '0',
+ 'perl' => '5.008'
+ },
+ 'requires' => {
+@@ -43,28 +39,6 @@ my $builder = Module::Build->new(
+ );
+
+ my $dat_file = "effective_tld_names.dat";
+-my $get_new_list = $builder->y_n(
+- "Check for a new version of the Public Suffix List?", "N"
+-);
+-if ($get_new_list) {
+- my $http = HTTP::Tiny->new( timeout => 6 );
+- my $list_uri = URI->new(
+- "http://mxr.mozilla.org/mozilla-central/source/netwerk/dns/$dat_file"
+- );
+- $list_uri->query_form({ raw => 1 });
+- my %options = (
+- headers => {
+- "If-Modified-Since" => "Fri, 17 May 2013 00:00:00 UTC"
+- }
+- );
+- my $response = $http->get($list_uri, \%options);
+- if ( $response->{status} == 200 ) {
+- IO::File->new($dat_file, "w")->print($response->{content});
+- }
+- elsif ( $response->{status} != 304 ) {
+- croak "Unable to download public suffix list.";
+- }
+-}
+
+ # Divide rules from list into sets:
+ my $rules = join " ", map {
+diff --git a/META.yml b/META.yml
+index b25bc9c..2697608 100644
+--- a/META.yml
++++ b/META.yml
+@@ -11,11 +11,9 @@ build_requires:
+ blib: '1.01'
+ perl: '5.008'
+ configure_requires:
+- HTTP::Tiny: '0'
+ IO::File: '0'
+ Module::Build: '0.28'
+ Tie::File: '0'
+- URI: '0'
+ perl: '5.008'
+ dynamic_config: 0
+ generated_by: 'Dist::Zilla version 6.006, CPAN::Meta::Converter version 2.150001'
+--
+2.11.0
+
diff --git a/dev-perl/Mozilla-PublicSuffix/metadata.xml b/dev-perl/Mozilla-PublicSuffix/metadata.xml
new file mode 100644
index 000000000000..ef5b9e9b4db5
--- /dev/null
+++ b/dev-perl/Mozilla-PublicSuffix/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>perl@gentoo.org</email>
+ <name>Gentoo Perl Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="cpan">Mozilla-PublicSuffix</remote-id>
+ <remote-id type="cpan-module">Mozilla::PublicSuffix</remote-id>
+ </upstream>
+</pkgmetadata>