summaryrefslogtreecommitdiff
path: root/dev-perl/Mozilla-PublicSuffix
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-perl/Mozilla-PublicSuffix
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-perl/Mozilla-PublicSuffix')
-rw-r--r--dev-perl/Mozilla-PublicSuffix/Manifest4
-rw-r--r--dev-perl/Mozilla-PublicSuffix/Mozilla-PublicSuffix-1.0.0.ebuild33
-rw-r--r--dev-perl/Mozilla-PublicSuffix/files/1.0.0-no-dynamic-update.patch90
-rw-r--r--dev-perl/Mozilla-PublicSuffix/metadata.xml12
4 files changed, 139 insertions, 0 deletions
diff --git a/dev-perl/Mozilla-PublicSuffix/Manifest b/dev-perl/Mozilla-PublicSuffix/Manifest
new file mode 100644
index 000000000000..3e63dc44b06c
--- /dev/null
+++ b/dev-perl/Mozilla-PublicSuffix/Manifest
@@ -0,0 +1,4 @@
+AUX 1.0.0-no-dynamic-update.patch 2472 BLAKE2B 964aa47c1c54f0fdb9db529d662971dc41fe5ee65bee634d8160d8c13e133bcf7f6eb88b874555b5c5dcc54f729aec54804579a34697610c5d889800024cccde SHA512 3c264b0cdddbbab0845a8baee1cb669ef5e706cd85fd118de6a5f8bd34d15686e97e617519389664a0ca11386e06300259cafd4fca1c6087699826a1df391e1b
+DIST Mozilla-PublicSuffix-v1.0.0.tar.gz 71669 BLAKE2B 5a5866b6446cf56df24d5113e2ce663dec3ace6025ff9888b40914b577215dcb65f3f57bae1ac31bc82ff5dc3a0ae4d79f1d63dbe6fa717358ebf92d0779b579 SHA512 79ed7256bccb33f1f428657bd60cccaf7be5d4793424337b94a812a41f46e90507b8c32b3aa8b381bf16d77f4a3f911301f757332e9144718efd2341996d9cc6
+EBUILD Mozilla-PublicSuffix-1.0.0.ebuild 623 BLAKE2B d9ef0c4a3732ca712d884c22cb070965ae41e2804bbd0c8ab2b36876754a0f444604e0ddc900c9cdd318483e22d0b0d63a06758724e99ce3e7735a94af53646a SHA512 b59677c538e4f2eebb11be427f5d3456472f3b73d136a2479a2f4488fa50b8c66ddc5cc096d187b0d720c4048a253474d99fb6bada4ce0f2ae2d7081041f5115
+MISC metadata.xml 412 BLAKE2B 5a4ee675972149c12c64ab549c7267677bd0779c3e62483e9b9cbf4ae8f77da1c17fda121031782e6a3e682b5d9a29a82aaee8bb0ba8a10d212c5dd59b037be2 SHA512 80903f8d4a6deca1a52e6cd413ccc9aa6bbc9e1cae0c5130c128f5b0c1fcfe837ec318ce2f436f7a584ce1140ebbf57a961b4164886c4c06c2a1acd12726400b
diff --git a/dev-perl/Mozilla-PublicSuffix/Mozilla-PublicSuffix-1.0.0.ebuild b/dev-perl/Mozilla-PublicSuffix/Mozilla-PublicSuffix-1.0.0.ebuild
new file mode 100644
index 000000000000..789e8fa1b05b
--- /dev/null
+++ b/dev-perl/Mozilla-PublicSuffix/Mozilla-PublicSuffix-1.0.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=RSIMOES
+DIST_VERSION="v${PV}"
+inherit perl-module
+
+DESCRIPTION="Get a domain name's public suffix via the Mozilla Public Suffix List"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+PATCHES=(
+ "${FILESDIR}/${PV}-no-dynamic-update.patch"
+)
+RDEPEND="
+ virtual/perl-Exporter
+ dev-perl/URI
+"
+DEPEND="${RDEPEND}
+ virtual/perl-IO
+ >=dev-perl/Module-Build-0.280.0
+ test? (
+ virtual/perl-Test-Simple
+ virtual/perl-File-Spec
+ )
+"
+src_test() {
+ perl_rm_files t/author-* t/release-*
+ perl-module_src_test
+}
diff --git a/dev-perl/Mozilla-PublicSuffix/files/1.0.0-no-dynamic-update.patch b/dev-perl/Mozilla-PublicSuffix/files/1.0.0-no-dynamic-update.patch
new file mode 100644
index 000000000000..99c76a4dc754
--- /dev/null
+++ b/dev-perl/Mozilla-PublicSuffix/files/1.0.0-no-dynamic-update.patch
@@ -0,0 +1,90 @@
+From 7dcc6afa75d5318325856fdef0456f4ddf1672b1 Mon Sep 17 00:00:00 2001
+From: Kent Fredric <kentfredric@gmail.com>
+Date: Fri, 6 Jan 2017 12:32:50 +1300
+Subject: [PATCH] Remove dynamic update code
+
+As this basically makes builds unreproducale anyway, and the download
+URI is invariant meaning we can't even approximate the same logic via
+SRC_URI without having frequently changing Manifests, but no change in
+URI.
+---
+ Build.PL | 26 --------------------------
+ META.yml | 2 --
+ 2 files changed, 28 deletions(-)
+
+diff --git a/Build.PL b/Build.PL
+index 7ef1ca0..1e7834d 100755
+--- a/Build.PL
++++ b/Build.PL
+@@ -5,11 +5,9 @@ use warnings FATAL => "all";
+ use utf8;
+ use open ":encoding(UTF-8)";
+ use Carp qw(croak);
+-use HTTP::Tiny;
+ use Module::Build;
+ use IO::File;
+ use Tie::File;
+-use URI;
+
+ my $builder = Module::Build->new(
+ dist_name => "Mozilla-PublicSuffix",
+@@ -28,11 +26,9 @@ my $builder = Module::Build->new(
+ 'perl' => '5.008'
+ },
+ 'configure_requires' => {
+- 'HTTP::Tiny' => '0',
+ 'IO::File' => '0',
+ 'Module::Build' => '0.28',
+ 'Tie::File' => '0',
+- 'URI' => '0',
+ 'perl' => '5.008'
+ },
+ 'requires' => {
+@@ -43,28 +39,6 @@ my $builder = Module::Build->new(
+ );
+
+ my $dat_file = "effective_tld_names.dat";
+-my $get_new_list = $builder->y_n(
+- "Check for a new version of the Public Suffix List?", "N"
+-);
+-if ($get_new_list) {
+- my $http = HTTP::Tiny->new( timeout => 6 );
+- my $list_uri = URI->new(
+- "http://mxr.mozilla.org/mozilla-central/source/netwerk/dns/$dat_file"
+- );
+- $list_uri->query_form({ raw => 1 });
+- my %options = (
+- headers => {
+- "If-Modified-Since" => "Fri, 17 May 2013 00:00:00 UTC"
+- }
+- );
+- my $response = $http->get($list_uri, \%options);
+- if ( $response->{status} == 200 ) {
+- IO::File->new($dat_file, "w")->print($response->{content});
+- }
+- elsif ( $response->{status} != 304 ) {
+- croak "Unable to download public suffix list.";
+- }
+-}
+
+ # Divide rules from list into sets:
+ my $rules = join " ", map {
+diff --git a/META.yml b/META.yml
+index b25bc9c..2697608 100644
+--- a/META.yml
++++ b/META.yml
+@@ -11,11 +11,9 @@ build_requires:
+ blib: '1.01'
+ perl: '5.008'
+ configure_requires:
+- HTTP::Tiny: '0'
+ IO::File: '0'
+ Module::Build: '0.28'
+ Tie::File: '0'
+- URI: '0'
+ perl: '5.008'
+ dynamic_config: 0
+ generated_by: 'Dist::Zilla version 6.006, CPAN::Meta::Converter version 2.150001'
+--
+2.11.0
+
diff --git a/dev-perl/Mozilla-PublicSuffix/metadata.xml b/dev-perl/Mozilla-PublicSuffix/metadata.xml
new file mode 100644
index 000000000000..ef5b9e9b4db5
--- /dev/null
+++ b/dev-perl/Mozilla-PublicSuffix/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>perl@gentoo.org</email>
+ <name>Gentoo Perl Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="cpan">Mozilla-PublicSuffix</remote-id>
+ <remote-id type="cpan-module">Mozilla::PublicSuffix</remote-id>
+ </upstream>
+</pkgmetadata>