summaryrefslogtreecommitdiff
path: root/dev-perl/Net-Patricia
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-12-15 17:25:28 +0000
committerV3n3RiX <venerix@redcorelinux.org>2017-12-15 17:25:28 +0000
commit6b933047f46efec1aa747570f945344254227457 (patch)
treea12a4b87b38f954c4de435272cf4b90d721df5e8 /dev-perl/Net-Patricia
parentf45955e60d4da9b7f4a1088c98042f9c06669039 (diff)
gentoo resync : 15.12.2017
Diffstat (limited to 'dev-perl/Net-Patricia')
-rw-r--r--dev-perl/Net-Patricia/Manifest2
-rw-r--r--dev-perl/Net-Patricia/Net-Patricia-1.220.0-r1.ebuild27
-rw-r--r--dev-perl/Net-Patricia/files/Net-Patricia-1.22-no-lnsl.patch29
3 files changed, 58 insertions, 0 deletions
diff --git a/dev-perl/Net-Patricia/Manifest b/dev-perl/Net-Patricia/Manifest
index ffd2708e2f0b..9331d47d2058 100644
--- a/dev-perl/Net-Patricia/Manifest
+++ b/dev-perl/Net-Patricia/Manifest
@@ -1,5 +1,7 @@
+AUX Net-Patricia-1.22-no-lnsl.patch 947 BLAKE2B a0535920826937aa83fd1d9a64256a131a717131cd14338e2b7c067007e5e4c8d106745ad4dce9fbc8a6ba336e1c336f8f9bcd51fb2a31b5c63e620f12705bc8 SHA512 43f9907393952efb253cd8e8a9bdd1e6ed179750700855f46dbbf21b4e6e3838349dedda98c24896d177a4cfcf99289beb0053ab62327e161743f581954bbe58
DIST Net-Patricia-1.21.tar.gz 27911 BLAKE2B 5751753a290b45cb12b16eeed1d9b8e24c7dd86af7271db20f3f8cd909d7b97d48129aceb6e861697c50c1bddea60442cae43269dd5c9fd1d745ccdf469daa01 SHA512 d25d6e4894df365ddd549db748131f1df00b5d9e880b1deb520461ff00fa1035a7beeaeb3bc9c9df4a193cd5e39ab888884fc1ff468b2faa5c8faf1d59b25ed4
DIST Net-Patricia-1.22.tar.gz 27780 BLAKE2B 9f81e9551b4110bcc6e16f8393d39f5a5ef4521e1cb6c1ea58a35f37a7b4a4882eaa9a3418b0695fa17e295dbb325ee9583f129be1dfb476ffbad7150d08691c SHA512 d76702d30784f8448dcf3a5269e052bc7bd6f5fe5a16824b6e3ede1d0182deb139522e45e1fb78749a7527ddbc950c213d843e43f45b5b0ed63b5b985b329861
EBUILD Net-Patricia-1.210.0-r1.ebuild 539 BLAKE2B 462781f5d14e128b1f5f40d7ff7d8fc91ccc4eb09f308a6d10d7f0949688bd72ab23e07cc30cdb3e3f3ab3b144d51ebdabfcc696cda12e72255ec557970016d3 SHA512 27cb3d80cb6331f100fcd621325adc607a42b958d25749b6e5417678a1b632bb72bcdacddb2ca5a41c4857c9000462f3a4b12257f463261f6b1e116bdbf1c6f9
+EBUILD Net-Patricia-1.220.0-r1.ebuild 577 BLAKE2B 5c733cf0a844c6c18385e5b18bc26b3e52d59fd4325c5604ef78ce46730ccea910f2e174a9f9354c476428bd9759416bd53d7b5d7f4c592b0b1ac21e226f9406 SHA512 28f975cc1d9c711776c4dbe2982e67fb95713b1441438460134d6d433326a7a65f256db90749e78dc6c16a49e6a83dc62ec542be78129b078eecd0796b798786
EBUILD Net-Patricia-1.220.0.ebuild 539 BLAKE2B 3cec4a7a5514c292422b40b3b020db9ee2c6f41b6a9ab0d887ea172f626b02e0a723ed6f3cee8fb5ba10255430334a958c66c4b0e29876aea68e713a48379e4d SHA512 8fad3737caaeb1b0e43ea3be5449fb7532ede5c19bb2604ba64d8118e803e3e03ad6e8f2795abb6b7ed6e386fd869fa476617cd159bd90a36aeef9dc57a153fc
MISC metadata.xml 535 BLAKE2B 85679f1ddf9ae459d8b64634e9f2512ae5d7e71cbc8808a9c7f8f89f22cc417cd9228c32d7064d0d5bfffb8d47f91b7c20f3ab947bf72fab2e17b958b7387943 SHA512 cac83e7065b4ea8cb0f54ebde75a1e6e31cbcab5462d1e48e773425bf5ab5a413859dbce470b0692884ca827911a5ca9ff85a02d9cececa5e1602ab6d2495577
diff --git a/dev-perl/Net-Patricia/Net-Patricia-1.220.0-r1.ebuild b/dev-perl/Net-Patricia/Net-Patricia-1.220.0-r1.ebuild
new file mode 100644
index 000000000000..b29fdbe2b9e7
--- /dev/null
+++ b/dev-perl/Net-Patricia/Net-Patricia-1.220.0-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=GRUBER
+DIST_VERSION=1.22
+inherit perl-module toolchain-funcs
+
+DESCRIPTION="Patricia Trie perl module for fast IP address lookups"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="ipv6"
+
+RDEPEND="dev-perl/Net-CIDR-Lite
+ ipv6? (
+ dev-perl/Socket6
+ )
+"
+DEPEND="${RDEPEND}"
+
+PATCHES=("${FILESDIR}/${PN}-1.22-no-lnsl.patch")
+src_compile() {
+ emake AR="$(tc-getAR)" OTHERLDFLAGS="${LDFLAGS}"
+}
diff --git a/dev-perl/Net-Patricia/files/Net-Patricia-1.22-no-lnsl.patch b/dev-perl/Net-Patricia/files/Net-Patricia-1.22-no-lnsl.patch
new file mode 100644
index 000000000000..6ec76eec4cb3
--- /dev/null
+++ b/dev-perl/Net-Patricia/files/Net-Patricia-1.22-no-lnsl.patch
@@ -0,0 +1,29 @@
+From d23c3d9ef60260ecfddf25111d28abd3296940cd Mon Sep 17 00:00:00 2001
+From: Kent Fredric <kentnl@gentoo.org>
+Date: Thu, 14 Dec 2017 18:11:17 +1300
+Subject: Don't link against libnsl
+
+No evidence this is actually used can be found, nothing uses RPC
+headers, and the compiled .so doesn't use any of its symbols or retain
+links in thier NEEDED sections.
+
+Bug: https://bugs.gentoo.org/638518
+---
+ Makefile.PL | 1 -
+ 1 file changed, 1 deletion(-)
+
+diff --git a/Makefile.PL b/Makefile.PL
+index acd0918..c023e43 100644
+--- a/Makefile.PL
++++ b/Makefile.PL
+@@ -5,7 +5,6 @@ use ExtUtils::MakeMaker;
+ WriteMakefile(
+ 'NAME' => 'Net::Patricia',
+ 'VERSION_FROM' => 'Patricia.pm', # finds $VERSION
+- 'LIBS' => ['-lnsl'], # e.g., '-lm'
+ 'DEFINE' => '', # e.g., '-DHAVE_SOMETHING'
+ 'INC' => '', # e.g., '-I/usr/include/other'
+ 'MYEXTLIB' => 'libpatricia/libpatricia$(LIB_EXT)', # e.g., '-I/usr/include/other'
+--
+2.14.3
+