summaryrefslogtreecommitdiff
path: root/dev-perl/Net-RBLClient/Net-RBLClient-0.500.0-r3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-07-17 19:04:28 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-07-17 19:04:28 +0100
commit514d1bbe260df2521fe60f1a3ec87cfcfde1a829 (patch)
tree555c194dbeb0fb2ac4ad3cde7c0f6a80fd330ce2 /dev-perl/Net-RBLClient/Net-RBLClient-0.500.0-r3.ebuild
parent4df3bf9762850b34cd1ead5c80374d1a0fc3362e (diff)
gentoo resync : 17.07.2021
Diffstat (limited to 'dev-perl/Net-RBLClient/Net-RBLClient-0.500.0-r3.ebuild')
-rw-r--r--dev-perl/Net-RBLClient/Net-RBLClient-0.500.0-r3.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-perl/Net-RBLClient/Net-RBLClient-0.500.0-r3.ebuild b/dev-perl/Net-RBLClient/Net-RBLClient-0.500.0-r3.ebuild
new file mode 100644
index 000000000000..7c43e9bda6bf
--- /dev/null
+++ b/dev-perl/Net-RBLClient/Net-RBLClient-0.500.0-r3.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DIST_AUTHOR=ABLUM
+DIST_VERSION=0.5
+inherit perl-module
+
+DESCRIPTION="Queries multiple Realtime Blackhole Lists in parallel"
+
+SLOT="0"
+KEYWORDS="~alpha amd64 ~arm ~arm64 ~hppa ~ppc ppc64 sparc x86"
+
+RDEPEND="virtual/perl-Time-HiRes
+ dev-perl/Net-DNS"
+BDEPEND="${RDEPEND}
+"
+
+S=${WORKDIR}/RBLCLient-${DIST_VERSION} # second capitialized 'l' is deliberate
+
+src_test() {
+ local MODULES=(
+ "Net::RBLClient 0.4"
+ )
+ local failed=()
+ for dep in "${MODULES[@]}"; do
+ ebegin "Compile testing ${dep}"
+ perl -Mblib="${S}" -M"${dep} ()" -e1
+ eend $? || failed+=( "$dep" )
+ done
+ if [[ ${failed[@]} ]]; then
+ echo
+ eerror "One or more modules failed compile:";
+ for dep in "${failed[@]}"; do
+ eerror " ${dep}"
+ done
+ die "Failing due to module compilation errors";
+ fi
+ perl-module_src_test
+}