summaryrefslogtreecommitdiff
path: root/dev-perl/Parallel-Iterator
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-perl/Parallel-Iterator
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-perl/Parallel-Iterator')
-rw-r--r--dev-perl/Parallel-Iterator/Manifest4
-rw-r--r--dev-perl/Parallel-Iterator/Parallel-Iterator-1.0.0-r1.ebuild27
-rw-r--r--dev-perl/Parallel-Iterator/files/Parallel-Iterator-1.00-perl-5.26.patch57
-rw-r--r--dev-perl/Parallel-Iterator/metadata.xml12
4 files changed, 100 insertions, 0 deletions
diff --git a/dev-perl/Parallel-Iterator/Manifest b/dev-perl/Parallel-Iterator/Manifest
new file mode 100644
index 000000000000..44da066ab1ed
--- /dev/null
+++ b/dev-perl/Parallel-Iterator/Manifest
@@ -0,0 +1,4 @@
+AUX Parallel-Iterator-1.00-perl-5.26.patch 1490 BLAKE2B 628556289b1bde90149890e7ffa6bf45d3e8e33fdfae3d28d35a81b3ee03a592fc093d2214c9b88c29fc9bffe1c4e558b8d4aa835d636f1b819e9f4f6940020d SHA512 c0230fc0e94158782b6434757cd1e8ceb11c3523aee8875225bbf3f9278b888565e85042c8facc44bf8ce071f0ae125dd967e0fc81f9d9785dd0c2db6d24857f
+DIST Parallel-Iterator-1.00.tar.gz 15227 BLAKE2B 9ebfea3c67627d7f85d688f4adbe6bdca497f656789704c4567c306dd3530f2306bba4a38cd506da65e941483cbc68cf3b1d262daeb9cbf8f1e6141db64e6c9b SHA512 3027434d08da0750f33ad2cc10b1c00b18ac0f626af5aa1f9d5d94711e433c7e313e04106e5307d5a498ae65ebf577dfd83c669ecf5414bbe04d87c862b2a511
+EBUILD Parallel-Iterator-1.0.0-r1.ebuild 476 BLAKE2B 87299657dffbcf4291199911c7dabab152dab147ca0fb792c20690232839b118d0e8d0734d5cf4c205ce5a6eac869bbe6a471d523ba60281682bbd10b1a09e35 SHA512 4be8bff6c7932b12f6d737013f35090340f8b3f3429b7db3c398b50a7bd46e541fa706ffed232f79135c92310d8e3398fa43a5ea05a832eccc7d520786f7e30d
+MISC metadata.xml 394 BLAKE2B 98b66a7dbe3f1e8e72d16a002627ff6e87e493bafbdc871e8a707c3e67969ddd1cb3cdf28af37fd33e192f35728cb08a119304af3d85af7c2e28b4185972df01 SHA512 cec047e4438fc273dd3b3cdbce193dd26e92be54b035f81fe48c972fc14a68c0b8a0fce82155b5697c040d0c2f6f55bb6e30066a378caa525d6223e4178df66b
diff --git a/dev-perl/Parallel-Iterator/Parallel-Iterator-1.0.0-r1.ebuild b/dev-perl/Parallel-Iterator/Parallel-Iterator-1.0.0-r1.ebuild
new file mode 100644
index 000000000000..1bbc40ad174c
--- /dev/null
+++ b/dev-perl/Parallel-Iterator/Parallel-Iterator-1.0.0-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=ANDYA
+DIST_VERSION=1.00
+DIST_EXAMPLES=( "examples/*" )
+inherit perl-module
+
+DESCRIPTION="Simple parallel execution"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ virtual/perl-IO
+ virtual/perl-Storable
+"
+DEPEND="${RDEPEND}
+ dev-perl/Module-Build
+ test? (
+ virtual/perl-Test-Simple
+ )
+"
+PATCHES=("${FILESDIR}/${PN}-1.00-perl-5.26.patch")
diff --git a/dev-perl/Parallel-Iterator/files/Parallel-Iterator-1.00-perl-5.26.patch b/dev-perl/Parallel-Iterator/files/Parallel-Iterator-1.00-perl-5.26.patch
new file mode 100644
index 000000000000..66053713e220
--- /dev/null
+++ b/dev-perl/Parallel-Iterator/files/Parallel-Iterator-1.00-perl-5.26.patch
@@ -0,0 +1,57 @@
+From 3cf3250d8d62b93b83a34df309d1181f36a5e2ab Mon Sep 17 00:00:00 2001
+From: Kent Fredric <kentnl@gentoo.org>
+Date: Sat, 23 Dec 2017 12:40:14 +1300
+Subject: Fix test failures without '.' in @INC
+
+Bug: https://rt.cpan.org/Public/Bug/Display.html?id=120543
+Bug: https://bugs.gentoo.org/615726
+---
+ t/050-nofork-basic.t | 2 +-
+ t/060-nofork-data.t | 2 +-
+ t/070-nofork-block.t | 2 +-
+ t/080-nofork-batch.t | 2 +-
+ 4 files changed, 4 insertions(+), 4 deletions(-)
+
+diff --git a/t/050-nofork-basic.t b/t/050-nofork-basic.t
+index 1409174..2d2e454 100644
+--- a/t/050-nofork-basic.t
++++ b/t/050-nofork-basic.t
+@@ -3,4 +3,4 @@ use strict;
+ use lib 't/lib';
+
+ use NoFork;
+-require 't/020-data.t';
++require './t/020-data.t';
+diff --git a/t/060-nofork-data.t b/t/060-nofork-data.t
+index 281cd07..1654671 100644
+--- a/t/060-nofork-data.t
++++ b/t/060-nofork-data.t
+@@ -3,4 +3,4 @@ use strict;
+ use lib 't/lib';
+
+ use NoFork;
+-require 't/020-data.t';
++require './t/020-data.t';
+diff --git a/t/070-nofork-block.t b/t/070-nofork-block.t
+index a3dfb52..40b7342 100644
+--- a/t/070-nofork-block.t
++++ b/t/070-nofork-block.t
+@@ -3,4 +3,4 @@ use strict;
+ use lib 't/lib';
+
+ use NoFork;
+-require 't/030-block.t';
++require './t/030-block.t';
+diff --git a/t/080-nofork-batch.t b/t/080-nofork-batch.t
+index 5d66b5c..d7c7165 100644
+--- a/t/080-nofork-batch.t
++++ b/t/080-nofork-batch.t
+@@ -3,4 +3,4 @@ use strict;
+ use lib 't/lib';
+
+ use NoFork;
+-require 't/040-batch.t';
++require './t/040-batch.t';
+--
+2.15.1
+
diff --git a/dev-perl/Parallel-Iterator/metadata.xml b/dev-perl/Parallel-Iterator/metadata.xml
new file mode 100644
index 000000000000..6641df0dba9b
--- /dev/null
+++ b/dev-perl/Parallel-Iterator/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>perl@gentoo.org</email>
+ <name>Gentoo Perl Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="cpan">Parallel-Iterator</remote-id>
+ <remote-id type="cpan-module">Parallel::Iterator</remote-id>
+ </upstream>
+</pkgmetadata>