summaryrefslogtreecommitdiff
path: root/dev-perl/Path-Dispatcher
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-04-09 17:34:58 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-04-09 17:34:58 +0100
commitbac9556f73da9ac333933778ce81c053bd989a26 (patch)
treeda4df6abc6ad52afd906c19c1e489d4b1331f6b1 /dev-perl/Path-Dispatcher
parentc83738e70baeab2df370c1c73b13bb8feb99eb11 (diff)
gentoo auto-resync : 09:04:2023 - 17:34:58
Diffstat (limited to 'dev-perl/Path-Dispatcher')
-rw-r--r--dev-perl/Path-Dispatcher/Manifest3
-rw-r--r--dev-perl/Path-Dispatcher/Path-Dispatcher-1.08.ebuild26
-rw-r--r--dev-perl/Path-Dispatcher/metadata.xml31
3 files changed, 60 insertions, 0 deletions
diff --git a/dev-perl/Path-Dispatcher/Manifest b/dev-perl/Path-Dispatcher/Manifest
new file mode 100644
index 000000000000..0afb03676697
--- /dev/null
+++ b/dev-perl/Path-Dispatcher/Manifest
@@ -0,0 +1,3 @@
+DIST Path-Dispatcher-1.08.tar.gz 50388 BLAKE2B cea31a6e2f846f60dd28682e50c50cc7cc5dc1ee957329073a952d1ed17d28deb967de50a438d2c53432949010a8e2f39b953d0f836339e19a310afc097e4330 SHA512 3cda047a70dafc0ce54dad949b567d872b9c911c670a66d5f022cf21706ced2b6ff40b615458c2b7b06693141f9504beceb93c7c6b532eba53f32290b93b27c2
+EBUILD Path-Dispatcher-1.08.ebuild 474 BLAKE2B a56c64fda9db431f313a64218b58bf25a808f9c1c751a3359c83fb95184a5f770a6483b0b0260e215dfa3d5555ee8a6f3f125ded2194f5722a5bc8dd9571e9b3 SHA512 575b52d4a7ffc615e0dfa74e30981e9f5c2ebe381e31d29b4695fecc34d0eacb88487485149180630670cad691bec4689acf48643e8cc41aec38af46eb1f79df
+MISC metadata.xml 1826 BLAKE2B b83b4a737cd6bf6567845a74323967fcc6c68bac43993a394ee3a3093b930a4a7dbecbffb2f98a05c00c0e0116be45ddd23bf97d7c713cc5ef08eb22acf12acf SHA512 6322da1425b3c04fc58deb656ef86c484e9b0144ae3225a663b768d6d9552c91356a0189a862ab4222085617369af225b8c7c8c8568f4fcb45435d2daab4cefb
diff --git a/dev-perl/Path-Dispatcher/Path-Dispatcher-1.08.ebuild b/dev-perl/Path-Dispatcher/Path-Dispatcher-1.08.ebuild
new file mode 100644
index 000000000000..814ac1ab7c78
--- /dev/null
+++ b/dev-perl/Path-Dispatcher/Path-Dispatcher-1.08.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DIST_AUTHOR=ETHER
+DIST_VERSION=1.08
+inherit perl-module
+
+DESCRIPTION="Flexible and extensible dispatch"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ virtual/perl-Carp
+ dev-perl/Moo
+ dev-perl/MooX-TypeTiny
+ virtual/perl-Scalar-List-Utils
+ dev-perl/Try-Tiny
+ dev-perl/Type-Tiny
+"
+BDEPEND="${RDEPEND}
+ dev-perl/Module-Build-Tiny
+ virtual/perl-ExtUtils-MakeMaker
+"
diff --git a/dev-perl/Path-Dispatcher/metadata.xml b/dev-perl/Path-Dispatcher/metadata.xml
new file mode 100644
index 000000000000..b575f67909f3
--- /dev/null
+++ b/dev-perl/Path-Dispatcher/metadata.xml
@@ -0,0 +1,31 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>perl@gentoo.org</email>
+ <name>Gentoo Perl Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="cpan">Path-Dispatcher</remote-id>
+ <remote-id type="cpan-module">Path-Dispatcher</remote-id>
+ <remote-id type="cpan-module">Path-Dispatcher::Dispatch</remote-id>
+ <remote-id type="cpan-module">Path-Dispatcher::Match</remote-id>
+ <remote-id type="cpan-module">Path-Dispatcher::Path</remote-id>
+ <remote-id type="cpan-module">Path-Dispatcher::Role::Rules</remote-id>
+ <remote-id type="cpan-module">Path-Dispatcher::Rule</remote-id>
+ <remote-id type="cpan-module">Path-Dispatcher::Rule::Alternation</remote-id>
+ <remote-id type="cpan-module">Path-Dispatcher::Rule::Always</remote-id>
+ <remote-id type="cpan-module">Path-Dispatcher::Rule::Chain</remote-id>
+ <remote-id type="cpan-module">Path-Dispatcher::Rule::CodeRef</remote-id>
+ <remote-id type="cpan-module">Path-Dispatcher::Rule::Dispatch</remote-id>
+ <remote-id type="cpan-module">Path-Dispatcher::Rule::Empty</remote-id>
+ <remote-id type="cpan-module">Path-Dispatcher::Rule::Enum</remote-id>
+ <remote-id type="cpan-module">Path-Dispatcher::Rule::Eq</remote-id>
+ <remote-id type="cpan-module">Path-Dispatcher::Rule::Intersection</remote-id>
+ <remote-id type="cpan-module">Path-Dispatcher::Rule::Metadata</remote-id>
+ <remote-id type="cpan-module">Path-Dispatcher::Rule::Regex</remote-id>
+ <remote-id type="cpan-module">Path-Dispatcher::Rule::Sequence</remote-id>
+ <remote-id type="cpan-module">Path-Dispatcher::Rule::Tokens</remote-id>
+ <remote-id type="cpan-module">Path-Dispatcher::Rule::Under</remote-id>
+ </upstream>
+</pkgmetadata>