summaryrefslogtreecommitdiff
path: root/dev-perl/Perl-Tags/Perl-Tags-0.320.0-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-perl/Perl-Tags/Perl-Tags-0.320.0-r1.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-perl/Perl-Tags/Perl-Tags-0.320.0-r1.ebuild')
-rw-r--r--dev-perl/Perl-Tags/Perl-Tags-0.320.0-r1.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/dev-perl/Perl-Tags/Perl-Tags-0.320.0-r1.ebuild b/dev-perl/Perl-Tags/Perl-Tags-0.320.0-r1.ebuild
new file mode 100644
index 000000000000..a79a4037ff1f
--- /dev/null
+++ b/dev-perl/Perl-Tags/Perl-Tags-0.320.0-r1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=OSFAMERON
+DIST_VERSION=0.32
+inherit perl-module
+
+DESCRIPTION="Generate (possibly exuberant) Ctags style tags for Perl sourcecode"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="test minimal"
+
+PATCHES=(
+ "${FILESDIR}/vim_noplugin.patch" # https://rt.cpan.org/Ticket/Display.html?id=105899
+ "${FILESDIR}/${PN}-0.32-no-dot-inc.patch"
+ "${FILESDIR}/${PN}-0.32-no-vim-tests.patch"
+)
+PERL_RM_FILES=(
+ "README.pod" # https://rt.cpan.org/Ticket/Display.html?id=113166
+)
+RDEPEND="
+ dev-perl/File-Find-Rule
+ virtual/perl-Data-Dumper
+ virtual/perl-File-Spec
+ virtual/perl-File-Temp
+ dev-perl/Module-Locate
+ dev-perl/Path-Tiny
+ virtual/perl-parent
+ !minimal? (
+ dev-perl/PPI
+ )
+"
+DEPEND="${RDEPEND}
+ >=virtual/perl-ExtUtils-MakeMaker-6.360.0
+ test? (
+ dev-perl/Capture-Tiny
+ dev-perl/Test-Exception
+ dev-perl/Test-LongString
+ >=virtual/perl-Test-Simple-0.420.0
+ !minimal? (
+ app-editors/vim[perl]
+ )
+ )
+"