summaryrefslogtreecommitdiff
path: root/dev-perl/Perl-Tidy/Perl-Tidy-20170521.0.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-perl/Perl-Tidy/Perl-Tidy-20170521.0.0.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-perl/Perl-Tidy/Perl-Tidy-20170521.0.0.ebuild')
-rw-r--r--dev-perl/Perl-Tidy/Perl-Tidy-20170521.0.0.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-perl/Perl-Tidy/Perl-Tidy-20170521.0.0.ebuild b/dev-perl/Perl-Tidy/Perl-Tidy-20170521.0.0.ebuild
new file mode 100644
index 000000000000..c854b45911e3
--- /dev/null
+++ b/dev-perl/Perl-Tidy/Perl-Tidy-20170521.0.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=SHANCOCK
+DIST_VERSION=20170521
+DIST_EXAMPLES=( "examples/*" )
+inherit perl-module
+
+DESCRIPTION="Perl script indenter and beautifier"
+HOMEPAGE="http://perltidy.sourceforge.net/ ${HOMEPAGE}"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+"
+
+src_install() {
+ perl-module_src_install
+
+ # Compressing pod is bad because perldoc can't decompress
+ # bzip2 automatically, and `less` can't render perldoc
+ docompress -x /usr/share/doc/${PF}/stylekey.pod
+ docompress -x /usr/share/doc/${PF}/tutorial
+
+ docinto ''
+ dodoc docs/stylekey.pod
+
+ docinto tutorial
+ dodoc docs/tutorial.pod docs/testfile.pl
+}