summaryrefslogtreecommitdiff
path: root/dev-perl/PostScript-Simple
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-perl/PostScript-Simple
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-perl/PostScript-Simple')
-rw-r--r--dev-perl/PostScript-Simple/Manifest3
-rw-r--r--dev-perl/PostScript-Simple/PostScript-Simple-0.90.0.ebuild29
-rw-r--r--dev-perl/PostScript-Simple/metadata.xml13
3 files changed, 45 insertions, 0 deletions
diff --git a/dev-perl/PostScript-Simple/Manifest b/dev-perl/PostScript-Simple/Manifest
new file mode 100644
index 000000000000..6f7619a203a3
--- /dev/null
+++ b/dev-perl/PostScript-Simple/Manifest
@@ -0,0 +1,3 @@
+DIST PostScript-Simple-0.09.tar.gz 35450 BLAKE2B e642cf9d8b887fee458b2ac085a90ac6198b7e1ed1fd0349fa6b2abc597b16d32ec2b099e4e8db9e009a1341ec5015c24502099213996bae9840bcd3209fb589 SHA512 28026060f91e7bcc2722df7e7097667aa2baaa85b1c558e08558fbee3395b0326e0564142e7729068afd13bdf523da32073fd6dbe56317db3e554445b4a04b18
+EBUILD PostScript-Simple-0.90.0.ebuild 590 BLAKE2B 593373b7c9d5ef6ae4f36543e62d00b77fa432a423baf7f33f697a0d30f16eeca763b90581cf7590747a9c38c5f139b93e565965b601723121e86262bd799a17 SHA512 e583ab006564b9e76d9663506d4ae2ed42d7d7a00e2c7e64643fdb4d97e43b63897d2b72804d88ff65bf6efe6da8937a0ca5953e8c8e2a9fa750976e5362612c
+MISC metadata.xml 476 BLAKE2B 82a6ddb81ff8e8811e957d2f3b88a5d8e0a4af26dc050c73258e8459dd8443bc4e568123234850a8b4b51dde819498d16c39f8d0476beea913fb96fe0e0fb113 SHA512 737aa85b446ecc6ae1519dfe09b8ced51cb637e012dd398108bf7dd1ec76b3e82c147416e7e7f3b33ba65fd7bb7e2a64ddaea2770cfbcc8a40f832e6925887c5
diff --git a/dev-perl/PostScript-Simple/PostScript-Simple-0.90.0.ebuild b/dev-perl/PostScript-Simple/PostScript-Simple-0.90.0.ebuild
new file mode 100644
index 000000000000..79eac80b8906
--- /dev/null
+++ b/dev-perl/PostScript-Simple/PostScript-Simple-0.90.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=MCNEWTON
+DIST_VERSION=0.09
+inherit perl-module
+
+DESCRIPTION="Allows you to have a simple method of writing PostScript files from Perl"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 hppa ia64 ppc sparc x86"
+IUSE="test examples"
+
+RDEPEND=""
+DEPEND="
+ virtual/perl-ExtUtils-MakeMaker
+ test? ( >=virtual/perl-Test-Simple-0.180.0 )
+"
+
+src_install() {
+ perl-module_src_install
+ if use examples; then
+ docompress -x /usr/share/doc/${PF}/examples
+ dodoc -r examples
+ fi
+}
diff --git a/dev-perl/PostScript-Simple/metadata.xml b/dev-perl/PostScript-Simple/metadata.xml
new file mode 100644
index 000000000000..7e77e511ab0d
--- /dev/null
+++ b/dev-perl/PostScript-Simple/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>perl@gentoo.org</email>
+ <name>Gentoo Perl Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="cpan">PostScript-Simple</remote-id>
+ <remote-id type="cpan-module">PostScript::Simple</remote-id>
+ <remote-id type="cpan-module">PostScript::Simple::EPS</remote-id>
+ </upstream>
+</pkgmetadata>