summaryrefslogtreecommitdiff
path: root/dev-perl/Quota
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-perl/Quota
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-perl/Quota')
-rw-r--r--dev-perl/Quota/Manifest3
-rw-r--r--dev-perl/Quota/Quota-1.7.2-r1.ebuild44
-rw-r--r--dev-perl/Quota/metadata.xml20
3 files changed, 67 insertions, 0 deletions
diff --git a/dev-perl/Quota/Manifest b/dev-perl/Quota/Manifest
new file mode 100644
index 000000000000..46cb0fd2d330
--- /dev/null
+++ b/dev-perl/Quota/Manifest
@@ -0,0 +1,3 @@
+DIST Quota-1.7.2.tar.gz 50436 BLAKE2B 6a90e545fcb3739f4f10cbe5caed7ba5a3542c19a8f1b68baeefc12dab77ac27d125e3de083c1cf6d68c29fe126c8e4f2eaddaa1c55c1974de0e0451011f6c7c SHA512 55ea9fbf027676b0e6f7a6f97fd3e75749860ebefe0127791a0d8cd8a427676eb1f6bf1ddf1a3687666752430faef877eedd12ccce39b7b76466fc7bfc628433
+EBUILD Quota-1.7.2-r1.ebuild 1006 BLAKE2B 97c7c37da8e6a61bccbc0678fc2643456da6541f62a1c09e9a92352ce2a3901cc786c813f498dd4cd8be4e79b5999e0e629a6ef8098dcb36549d12ff136fcaf6 SHA512 73b45e6cd0820c8daf5c429e803a0af2276036afe0b4fd6c4af314c8b6cf34c99e3072680f48e3238ac31c027a2cf85375668476ad424b6e54100615efe38e83
+MISC metadata.xml 1007 BLAKE2B f0dec13ddc08a5db0c4853d291c223436686d8657f297538e5d577e867e8b1dd8114d2864e15a8e1e8cbab2e55f68aa117bbc90e0c29b4f40a66cabbddd2cd3d SHA512 14eb4b9bf426ea685c207d08d675d8ceb9fbed523907469e829c715609492144fc05285a817c1de88964dbdaee4dd53b2d5316ff72a2b433d5a47bd3693b5d61
diff --git a/dev-perl/Quota/Quota-1.7.2-r1.ebuild b/dev-perl/Quota/Quota-1.7.2-r1.ebuild
new file mode 100644
index 000000000000..bb9aaf148174
--- /dev/null
+++ b/dev-perl/Quota/Quota-1.7.2-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=TOMZO
+inherit perl-module toolchain-funcs flag-o-matic
+
+DESCRIPTION="Perl interface to file system quotas"
+
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="
+ sys-fs/quota[rpc]
+ net-libs/libtirpc
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+"
+
+# Tests need real FS access/root permissions and are interactive
+DIST_TEST=skip
+
+src_prepare() {
+ default
+ export mymake="INC=$($(tc-getPKG_CONFIG) --cflags libtirpc) OTHERLDFLAGS=$($(tc-getPKG_CONFIG) --libs libtirpc)"
+
+ # disable AFS completely for now, need somebody who can really test it
+ sed -i -e 's|-d "/afs"|0|' Makefile.PL || die "sed failed"
+}
+
+src_test() {
+ ebegin "Compile testing Quota ${PV}"
+ perl -Mblib="${S}" -M"Quota ${PV} ()" -e1
+ if ! eend $?; then
+ echo
+ eerror "One or more modules failed compile:";
+ eerror " Quota ${PV}"
+ die "Failing due to module compilation errors";
+ fi
+ perl-module_src_test
+}
diff --git a/dev-perl/Quota/metadata.xml b/dev-perl/Quota/metadata.xml
new file mode 100644
index 000000000000..357936dbeeaa
--- /dev/null
+++ b/dev-perl/Quota/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>c.affolter@purplehaze.ch</email>
+ <name>Christian Affolter</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>dev-zero@gentoo.org</email>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <longdescription>The Quota module provides access to file system quotas. The quotactl system call or ioctl is used to query or set quotas on the local host, or queries are submitted via RPC to a remote host. Mount tables can be parsed with getmntent and paths can be translated to device files (or whatever the actual quotactl implementations needs as argument) of the according file system.</longdescription>
+ <upstream>
+ <remote-id type="cpan">Quota</remote-id>
+ <remote-id type="cpan-module">Quota</remote-id>
+ </upstream>
+</pkgmetadata>