summaryrefslogtreecommitdiff
path: root/dev-perl/SOAP-Lite
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-01-08 21:45:04 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-01-08 21:45:04 +0000
commit65737cf14a7220bd9a487aa2af4ae0e79bd23e86 (patch)
tree625754b14ae80ac167d1b150c2314b647cd008e6 /dev-perl/SOAP-Lite
parent5001a6c7b6da2956f5b17c695b1e0059dc7b8de5 (diff)
gentoo resync : 08.01.2018
Diffstat (limited to 'dev-perl/SOAP-Lite')
-rw-r--r--dev-perl/SOAP-Lite/Manifest4
-rw-r--r--dev-perl/SOAP-Lite/SOAP-Lite-1.260.0.ebuild52
-rw-r--r--dev-perl/SOAP-Lite/metadata.xml32
3 files changed, 58 insertions, 30 deletions
diff --git a/dev-perl/SOAP-Lite/Manifest b/dev-perl/SOAP-Lite/Manifest
index ef11beed6cdb..5dffff2bf39c 100644
--- a/dev-perl/SOAP-Lite/Manifest
+++ b/dev-perl/SOAP-Lite/Manifest
@@ -1,3 +1,5 @@
DIST SOAP-Lite-1.19.tar.gz 271044 BLAKE2B 5bdf211c0ef37089ad20c129a877b7997fa9c02539524267900c72a289e396298d253bc3d1be6e3c370c4b58cbca055a7d4a5b7ece02e2b9587d6d6019a76829 SHA512 530deba9011075b65e8eae4c64cac62c374cd17823e1d23b8383af2bc28075aa1e68809eb8b09a98b44c29cbd7398e6d24ffc9808badc39453f6b9e87a2e1a1d
+DIST SOAP-Lite-1.26.tar.gz 272187 BLAKE2B ec4519c258b2822da74c41e20dc2c0ea3242a7d1936c2e8bf637f6cfa53fc721e4864f0ca0332986f5a1c912babe522c1b409d48dc0c433abd3f85c4aa207cb6 SHA512 b09e320cecbb4859f49dcb144a446af878219f6ba3d2f7999f8656f40989d3ead0707960f561d17a9f800706fcb53020327f9c85313f6dcca34f9699a4c74143
EBUILD SOAP-Lite-1.190.0.ebuild 1049 BLAKE2B eba3d4fd64e851c10248f189870891e0f3a37450c282ca9b66cd81904035625d9479365963a4169054b2a93539058be60583935243657ab8cc968623d97f3829 SHA512 f9434e61f6b50f504578c0da98776c202ed9112a5d672066b04c918525be20ad78a509aeaf2a4969e6025ff8b548753f64d1725dae13213e0a0196a7a3a5df0c
-MISC metadata.xml 6095 BLAKE2B 3901b5656c05398855dee8b80509f862a6d61d31e04b0f897d8b3332d42abad7a16ebcef4ea42e5e2e063de3235e19e556dd6ec15e98f0851c42746704f08725 SHA512 d6292dd744f83651e56ff407e231faacd80fc3c9b6521ba5e7108e0adf3d91dc036969848609237465eb78b16818be971580f0e4a4367b9f01dbe584790fe903
+EBUILD SOAP-Lite-1.260.0.ebuild 1132 BLAKE2B f2db17c0831876767e31611b337a64f5426a8e9ce4f6c7c68c474726c3968906d48bf972fb35448a36107db1f5b85c96dfd666335f4f3496a8db1cc18b8af839 SHA512 8f1f8f17f78c5052a42fe7c82b5aa32f1c8ec3c53e73833b02b5e3de666869c8eb9f356619287f8ca8d503890ee3baf4069f96c7b49dfd8bc1dcae3dc3b248b0
+MISC metadata.xml 4474 BLAKE2B ab605ed8948f1f6d511d6493acb0cf22290238b148be02a112964fcd7b44b63a8150ec366ca2b67c4f600c904f16600983deea47987a206a49c27a25cd90ae3c SHA512 8f12dfcd2e448904c05e1cd604ef0b4770764cf77a5fd585a249b9189b18b5d978232fcd8cacc7b8ff8d527bb78ef13e8973cf0aaf3b89c43f0e3f4e801d3ce6
diff --git a/dev-perl/SOAP-Lite/SOAP-Lite-1.260.0.ebuild b/dev-perl/SOAP-Lite/SOAP-Lite-1.260.0.ebuild
new file mode 100644
index 000000000000..bd48e266b0b5
--- /dev/null
+++ b/dev-perl/SOAP-Lite/SOAP-Lite-1.260.0.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=PHRED
+DIST_VERSION=1.26
+DIST_EXAMPLES=( "examples/*" )
+inherit perl-module eutils
+
+DESCRIPTION="Lightweight interface to the SOAP protocol both on client and server side"
+
+IUSE="ssl test xmpp"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+
+myconf="${myconf} --noprompt"
+
+RDEPEND="
+ dev-perl/Class-Inspector
+ >=dev-perl/IO-SessionData-1.30.0
+ dev-perl/libwww-perl
+ virtual/perl-MIME-Base64
+ virtual/perl-Scalar-List-Utils
+ dev-perl/Task-Weaken
+ dev-perl/URI
+ >=dev-perl/XML-Parser-2.230.0
+ dev-perl/MIME-tools
+ ssl? (
+ dev-perl/IO-Socket-SSL
+ dev-perl/LWP-Protocol-https
+ dev-perl/Crypt-SSLeay
+ )
+ xmpp? ( dev-perl/Net-Jabber )
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ virtual/perl-IO
+ virtual/perl-Test-Simple
+ dev-perl/Test-Warn
+ >=dev-perl/XML-Parser-Lite-0.715.0
+ )
+"
+PERL_RM_FILES=(
+ "t/author-pod-syntax.t"
+ "t/release-kwalitee.t"
+)
+src_test() {
+ has_version '>=www-apache/mod_perl-2' && export MOD_PERL_API_VERSION=2
+ perl-module_src_test
+}
diff --git a/dev-perl/SOAP-Lite/metadata.xml b/dev-perl/SOAP-Lite/metadata.xml
index 334ddc70dd93..9d47475e554d 100644
--- a/dev-perl/SOAP-Lite/metadata.xml
+++ b/dev-perl/SOAP-Lite/metadata.xml
@@ -8,9 +8,6 @@
<upstream>
<remote-id type="cpan">SOAP-Lite</remote-id>
<remote-id type="cpan-module">Apache::SOAP</remote-id>
- <remote-id type="cpan-module">Apache::XMLRPC::Lite</remote-id>
- <remote-id type="cpan-module">LWP::Protocol</remote-id>
- <remote-id type="cpan-module">My::PingPong</remote-id>
<remote-id type="cpan-module">SOAP</remote-id>
<remote-id type="cpan-module">SOAP::Client</remote-id>
<remote-id type="cpan-module">SOAP::Cloneable</remote-id>
@@ -64,36 +61,13 @@
<remote-id type="cpan-module">SOAP::Transport::MAILTO::Client</remote-id>
<remote-id type="cpan-module">SOAP::Transport::POP3</remote-id>
<remote-id type="cpan-module">SOAP::Transport::POP3::Server</remote-id>
+ <remote-id type="cpan-module">SOAP::Transport::TCP</remote-id>
+ <remote-id type="cpan-module">SOAP::Transport::TCP::Client</remote-id>
+ <remote-id type="cpan-module">SOAP::Transport::TCP::Server</remote-id>
<remote-id type="cpan-module">SOAP::Utils</remote-id>
<remote-id type="cpan-module">SOAP::XMLSchema1999::Serializer</remote-id>
<remote-id type="cpan-module">SOAP::XMLSchema2001::Serializer</remote-id>
<remote-id type="cpan-module">SOAP::XMLSchema::Serializer</remote-id>
<remote-id type="cpan-module">SOAP::XMLSchemaApacheSOAP::Deserializer</remote-id>
- <remote-id type="cpan-module">UDDI::Constants</remote-id>
- <remote-id type="cpan-module">UDDI::Data</remote-id>
- <remote-id type="cpan-module">UDDI::Deserializer</remote-id>
- <remote-id type="cpan-module">UDDI::Lite</remote-id>
- <remote-id type="cpan-module">UDDI::SOM</remote-id>
- <remote-id type="cpan-module">UDDI::Serializer</remote-id>
- <remote-id type="cpan-module">XML::Parser::Lite</remote-id>
- <remote-id type="cpan-module">XMLRPC</remote-id>
- <remote-id type="cpan-module">XMLRPC::Constants</remote-id>
- <remote-id type="cpan-module">XMLRPC::Data</remote-id>
- <remote-id type="cpan-module">XMLRPC::Deserializer</remote-id>
- <remote-id type="cpan-module">XMLRPC::Lite</remote-id>
- <remote-id type="cpan-module">XMLRPC::SOM</remote-id>
- <remote-id type="cpan-module">XMLRPC::Serializer</remote-id>
- <remote-id type="cpan-module">XMLRPC::Server</remote-id>
- <remote-id type="cpan-module">XMLRPC::Server::Parameters</remote-id>
- <remote-id type="cpan-module">XMLRPC::Test</remote-id>
- <remote-id type="cpan-module">XMLRPC::Test::Server</remote-id>
- <remote-id type="cpan-module">XMLRPC::Transport::HTTP</remote-id>
- <remote-id type="cpan-module">XMLRPC::Transport::HTTP::Apache</remote-id>
- <remote-id type="cpan-module">XMLRPC::Transport::HTTP::CGI</remote-id>
- <remote-id type="cpan-module">XMLRPC::Transport::HTTP::Daemon</remote-id>
- <remote-id type="cpan-module">XMLRPC::Transport::POP3</remote-id>
- <remote-id type="cpan-module">XMLRPC::Transport::POP3::Server</remote-id>
- <remote-id type="cpan-module">XMLRPC::Transport::TCP</remote-id>
- <remote-id type="cpan-module">XMLRPC::Transport::TCP::Server</remote-id>
</upstream>
</pkgmetadata>