summaryrefslogtreecommitdiff
path: root/dev-perl/SOAP-Lite
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-perl/SOAP-Lite
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-perl/SOAP-Lite')
-rw-r--r--dev-perl/SOAP-Lite/Manifest5
-rw-r--r--dev-perl/SOAP-Lite/SOAP-Lite-1.190.0.ebuild50
-rw-r--r--dev-perl/SOAP-Lite/SOAP-Lite-1.260.0.ebuild52
-rw-r--r--dev-perl/SOAP-Lite/metadata.xml73
4 files changed, 180 insertions, 0 deletions
diff --git a/dev-perl/SOAP-Lite/Manifest b/dev-perl/SOAP-Lite/Manifest
new file mode 100644
index 000000000000..5dffff2bf39c
--- /dev/null
+++ b/dev-perl/SOAP-Lite/Manifest
@@ -0,0 +1,5 @@
+DIST SOAP-Lite-1.19.tar.gz 271044 BLAKE2B 5bdf211c0ef37089ad20c129a877b7997fa9c02539524267900c72a289e396298d253bc3d1be6e3c370c4b58cbca055a7d4a5b7ece02e2b9587d6d6019a76829 SHA512 530deba9011075b65e8eae4c64cac62c374cd17823e1d23b8383af2bc28075aa1e68809eb8b09a98b44c29cbd7398e6d24ffc9808badc39453f6b9e87a2e1a1d
+DIST SOAP-Lite-1.26.tar.gz 272187 BLAKE2B ec4519c258b2822da74c41e20dc2c0ea3242a7d1936c2e8bf637f6cfa53fc721e4864f0ca0332986f5a1c912babe522c1b409d48dc0c433abd3f85c4aa207cb6 SHA512 b09e320cecbb4859f49dcb144a446af878219f6ba3d2f7999f8656f40989d3ead0707960f561d17a9f800706fcb53020327f9c85313f6dcca34f9699a4c74143
+EBUILD SOAP-Lite-1.190.0.ebuild 1049 BLAKE2B eba3d4fd64e851c10248f189870891e0f3a37450c282ca9b66cd81904035625d9479365963a4169054b2a93539058be60583935243657ab8cc968623d97f3829 SHA512 f9434e61f6b50f504578c0da98776c202ed9112a5d672066b04c918525be20ad78a509aeaf2a4969e6025ff8b548753f64d1725dae13213e0a0196a7a3a5df0c
+EBUILD SOAP-Lite-1.260.0.ebuild 1132 BLAKE2B f2db17c0831876767e31611b337a64f5426a8e9ce4f6c7c68c474726c3968906d48bf972fb35448a36107db1f5b85c96dfd666335f4f3496a8db1cc18b8af839 SHA512 8f1f8f17f78c5052a42fe7c82b5aa32f1c8ec3c53e73833b02b5e3de666869c8eb9f356619287f8ca8d503890ee3baf4069f96c7b49dfd8bc1dcae3dc3b248b0
+MISC metadata.xml 4474 BLAKE2B ab605ed8948f1f6d511d6493acb0cf22290238b148be02a112964fcd7b44b63a8150ec366ca2b67c4f600c904f16600983deea47987a206a49c27a25cd90ae3c SHA512 8f12dfcd2e448904c05e1cd604ef0b4770764cf77a5fd585a249b9189b18b5d978232fcd8cacc7b8ff8d527bb78ef13e8973cf0aaf3b89c43f0e3f4e801d3ce6
diff --git a/dev-perl/SOAP-Lite/SOAP-Lite-1.190.0.ebuild b/dev-perl/SOAP-Lite/SOAP-Lite-1.190.0.ebuild
new file mode 100644
index 000000000000..92c86852ca56
--- /dev/null
+++ b/dev-perl/SOAP-Lite/SOAP-Lite-1.190.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+MODULE_AUTHOR=PHRED
+MODULE_VERSION=1.19
+inherit perl-module eutils
+
+DESCRIPTION="Lightweight interface to the SOAP protocol both on client and server side"
+
+IUSE="ssl test xmpp"
+SLOT="0"
+KEYWORDS="amd64 ~arm ppc ppc64 x86 ~amd64-linux ~x86-linux"
+
+myconf="${myconf} --noprompt"
+
+RDEPEND="
+ dev-perl/Class-Inspector
+ >=dev-perl/IO-SessionData-1.30.0
+ dev-perl/libwww-perl
+ virtual/perl-MIME-Base64
+ virtual/perl-Scalar-List-Utils
+ dev-perl/Task-Weaken
+ dev-perl/URI
+ >=dev-perl/XML-Parser-2.230.0
+ dev-perl/MIME-tools
+ ssl? (
+ dev-perl/IO-Socket-SSL
+ dev-perl/LWP-Protocol-https
+ dev-perl/Crypt-SSLeay
+ )
+ xmpp? ( dev-perl/Net-Jabber )
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ virtual/perl-IO
+ virtual/perl-Test-Simple
+ dev-perl/Test-Warn
+ dev-perl/XML-Parser-Lite
+ )
+"
+
+SRC_TEST="do parallel"
+
+src_test() {
+ has_version '>=www-apache/mod_perl-2' && export MOD_PERL_API_VERSION=2
+ perl-module_src_test
+}
diff --git a/dev-perl/SOAP-Lite/SOAP-Lite-1.260.0.ebuild b/dev-perl/SOAP-Lite/SOAP-Lite-1.260.0.ebuild
new file mode 100644
index 000000000000..bd48e266b0b5
--- /dev/null
+++ b/dev-perl/SOAP-Lite/SOAP-Lite-1.260.0.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=PHRED
+DIST_VERSION=1.26
+DIST_EXAMPLES=( "examples/*" )
+inherit perl-module eutils
+
+DESCRIPTION="Lightweight interface to the SOAP protocol both on client and server side"
+
+IUSE="ssl test xmpp"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+
+myconf="${myconf} --noprompt"
+
+RDEPEND="
+ dev-perl/Class-Inspector
+ >=dev-perl/IO-SessionData-1.30.0
+ dev-perl/libwww-perl
+ virtual/perl-MIME-Base64
+ virtual/perl-Scalar-List-Utils
+ dev-perl/Task-Weaken
+ dev-perl/URI
+ >=dev-perl/XML-Parser-2.230.0
+ dev-perl/MIME-tools
+ ssl? (
+ dev-perl/IO-Socket-SSL
+ dev-perl/LWP-Protocol-https
+ dev-perl/Crypt-SSLeay
+ )
+ xmpp? ( dev-perl/Net-Jabber )
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ virtual/perl-IO
+ virtual/perl-Test-Simple
+ dev-perl/Test-Warn
+ >=dev-perl/XML-Parser-Lite-0.715.0
+ )
+"
+PERL_RM_FILES=(
+ "t/author-pod-syntax.t"
+ "t/release-kwalitee.t"
+)
+src_test() {
+ has_version '>=www-apache/mod_perl-2' && export MOD_PERL_API_VERSION=2
+ perl-module_src_test
+}
diff --git a/dev-perl/SOAP-Lite/metadata.xml b/dev-perl/SOAP-Lite/metadata.xml
new file mode 100644
index 000000000000..9d47475e554d
--- /dev/null
+++ b/dev-perl/SOAP-Lite/metadata.xml
@@ -0,0 +1,73 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>perl@gentoo.org</email>
+ <name>Gentoo Perl Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="cpan">SOAP-Lite</remote-id>
+ <remote-id type="cpan-module">Apache::SOAP</remote-id>
+ <remote-id type="cpan-module">SOAP</remote-id>
+ <remote-id type="cpan-module">SOAP::Client</remote-id>
+ <remote-id type="cpan-module">SOAP::Cloneable</remote-id>
+ <remote-id type="cpan-module">SOAP::Constants</remote-id>
+ <remote-id type="cpan-module">SOAP::Custom::XML::Data</remote-id>
+ <remote-id type="cpan-module">SOAP::Custom::XML::Deserializer</remote-id>
+ <remote-id type="cpan-module">SOAP::Data</remote-id>
+ <remote-id type="cpan-module">SOAP::Deserializer</remote-id>
+ <remote-id type="cpan-module">SOAP::Fault</remote-id>
+ <remote-id type="cpan-module">SOAP::Header</remote-id>
+ <remote-id type="cpan-module">SOAP::Lite</remote-id>
+ <remote-id type="cpan-module">SOAP::Lite::COM</remote-id>
+ <remote-id type="cpan-module">SOAP::Lite::Deserializer::XMLSchema1999</remote-id>
+ <remote-id type="cpan-module">SOAP::Lite::Deserializer::XMLSchema2001</remote-id>
+ <remote-id type="cpan-module">SOAP::Lite::Deserializer::XMLSchemaSOAP1_1</remote-id>
+ <remote-id type="cpan-module">SOAP::Lite::Deserializer::XMLSchemaSOAP1_2</remote-id>
+ <remote-id type="cpan-module">SOAP::Lite::Packager</remote-id>
+ <remote-id type="cpan-module">SOAP::Lite::Packager::DIME</remote-id>
+ <remote-id type="cpan-module">SOAP::Lite::Packager::MIME</remote-id>
+ <remote-id type="cpan-module">SOAP::Lite::Utils</remote-id>
+ <remote-id type="cpan-module">SOAP::Packager</remote-id>
+ <remote-id type="cpan-module">SOAP::Packager::DIME</remote-id>
+ <remote-id type="cpan-module">SOAP::Packager::MIME</remote-id>
+ <remote-id type="cpan-module">SOAP::Parser</remote-id>
+ <remote-id type="cpan-module">SOAP::SOM</remote-id>
+ <remote-id type="cpan-module">SOAP::Schema</remote-id>
+ <remote-id type="cpan-module">SOAP::Schema::Deserializer</remote-id>
+ <remote-id type="cpan-module">SOAP::Schema::WSDL</remote-id>
+ <remote-id type="cpan-module">SOAP::Serializer</remote-id>
+ <remote-id type="cpan-module">SOAP::Server</remote-id>
+ <remote-id type="cpan-module">SOAP::Server::Object</remote-id>
+ <remote-id type="cpan-module">SOAP::Server::Parameters</remote-id>
+ <remote-id type="cpan-module">SOAP::Test</remote-id>
+ <remote-id type="cpan-module">SOAP::Test::Server</remote-id>
+ <remote-id type="cpan-module">SOAP::Trace</remote-id>
+ <remote-id type="cpan-module">SOAP::Transport</remote-id>
+ <remote-id type="cpan-module">SOAP::Transport::HTTP</remote-id>
+ <remote-id type="cpan-module">SOAP::Transport::HTTP::Apache</remote-id>
+ <remote-id type="cpan-module">SOAP::Transport::HTTP::CGI</remote-id>
+ <remote-id type="cpan-module">SOAP::Transport::HTTP::Client</remote-id>
+ <remote-id type="cpan-module">SOAP::Transport::HTTP::Daemon</remote-id>
+ <remote-id type="cpan-module">SOAP::Transport::HTTP::FCGI</remote-id>
+ <remote-id type="cpan-module">SOAP::Transport::HTTP::Server</remote-id>
+ <remote-id type="cpan-module">SOAP::Transport::IO</remote-id>
+ <remote-id type="cpan-module">SOAP::Transport::IO::Server</remote-id>
+ <remote-id type="cpan-module">SOAP::Transport::LOCAL</remote-id>
+ <remote-id type="cpan-module">SOAP::Transport::LOCAL::Client</remote-id>
+ <remote-id type="cpan-module">SOAP::Transport::LOOPBACK</remote-id>
+ <remote-id type="cpan-module">SOAP::Transport::LOOPBACK::Client</remote-id>
+ <remote-id type="cpan-module">SOAP::Transport::MAILTO</remote-id>
+ <remote-id type="cpan-module">SOAP::Transport::MAILTO::Client</remote-id>
+ <remote-id type="cpan-module">SOAP::Transport::POP3</remote-id>
+ <remote-id type="cpan-module">SOAP::Transport::POP3::Server</remote-id>
+ <remote-id type="cpan-module">SOAP::Transport::TCP</remote-id>
+ <remote-id type="cpan-module">SOAP::Transport::TCP::Client</remote-id>
+ <remote-id type="cpan-module">SOAP::Transport::TCP::Server</remote-id>
+ <remote-id type="cpan-module">SOAP::Utils</remote-id>
+ <remote-id type="cpan-module">SOAP::XMLSchema1999::Serializer</remote-id>
+ <remote-id type="cpan-module">SOAP::XMLSchema2001::Serializer</remote-id>
+ <remote-id type="cpan-module">SOAP::XMLSchema::Serializer</remote-id>
+ <remote-id type="cpan-module">SOAP::XMLSchemaApacheSOAP::Deserializer</remote-id>
+ </upstream>
+</pkgmetadata>