summaryrefslogtreecommitdiff
path: root/dev-perl/Test-Compile/Test-Compile-3.0.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-12-22 14:08:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-12-22 14:08:05 +0000
commit93a93e9a3b53c1a73142a305ea1f8136846942ee (patch)
treeb9791a06ab3284e27b568412c59316c66240c682 /dev-perl/Test-Compile/Test-Compile-3.0.1.ebuild
parent2771f79232c273bc2a57d23bf335dd81ccf6af28 (diff)
gentoo resync : 22.12.2021
Diffstat (limited to 'dev-perl/Test-Compile/Test-Compile-3.0.1.ebuild')
-rw-r--r--dev-perl/Test-Compile/Test-Compile-3.0.1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-perl/Test-Compile/Test-Compile-3.0.1.ebuild b/dev-perl/Test-Compile/Test-Compile-3.0.1.ebuild
new file mode 100644
index 000000000000..2678d51cf437
--- /dev/null
+++ b/dev-perl/Test-Compile/Test-Compile-3.0.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 2020-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DIST_AUTHOR=EGILES
+DIST_VERSION=v${PV}
+inherit perl-module
+
+DESCRIPTION="Check whether Perl files compile correctly"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~sparc ~x86"
+
+RDEPEND="
+ >=virtual/perl-Exporter-5.680.0
+ >=virtual/perl-parent-0.225.0
+ virtual/perl-version
+"
+BDEPEND="${RDEPEND}
+ >=dev-perl/Module-Build-0.380.0
+ test? (
+ dev-perl/Test-Exception
+ dev-perl/Test-Warnings
+ virtual/perl-Test-Simple
+ )
+"
+
+PERL_RM_FILES=(
+ t/999-has-version.t
+ t/999-perlcritic.t
+ t/999-pod-coverage.t
+ t/999-pod.t
+ t/999-portability.t
+ t/999-synopsis.t
+ t/999-version.t
+)