summaryrefslogtreecommitdiff
path: root/dev-perl/Text-CSV_XS/Text-CSV_XS-1.550.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-07-08 12:25:04 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-07-08 12:25:04 +0100
commita5442e2318cb4df55867389654e322dbac82067e (patch)
tree6ee33490658219395df804dbba0ea77f8b0d8c3b /dev-perl/Text-CSV_XS/Text-CSV_XS-1.550.0.ebuild
parent5d8ffbc273ca664e15618d557ced3e02de1a884b (diff)
gentoo auto-resync : 08:07:2024 - 12:25:03
Diffstat (limited to 'dev-perl/Text-CSV_XS/Text-CSV_XS-1.550.0.ebuild')
-rw-r--r--dev-perl/Text-CSV_XS/Text-CSV_XS-1.550.0.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-perl/Text-CSV_XS/Text-CSV_XS-1.550.0.ebuild b/dev-perl/Text-CSV_XS/Text-CSV_XS-1.550.0.ebuild
new file mode 100644
index 000000000000..93ca7669400e
--- /dev/null
+++ b/dev-perl/Text-CSV_XS/Text-CSV_XS-1.550.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DIST_AUTHOR=HMBRAND
+DIST_A_EXT=tgz
+DIST_VERSION=1.55
+DIST_EXAMPLES=("examples/*")
+inherit perl-module
+
+DESCRIPTION="Comma-separated values manipulation routines"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
+
+RDEPEND="
+ >=virtual/perl-Encode-3.210.0
+ virtual/perl-IO
+ virtual/perl-XSLoader
+"
+BDEPEND="
+ ${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ virtual/perl-Test-Simple
+ )
+"
+
+PERL_RM_FILES=( "t/00_pod.t" "t/01_pod.t" )