summaryrefslogtreecommitdiff
path: root/dev-perl/X11-Protocol
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-perl/X11-Protocol
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-perl/X11-Protocol')
-rw-r--r--dev-perl/X11-Protocol/Manifest6
-rw-r--r--dev-perl/X11-Protocol/X11-Protocol-0.560.0-r1.ebuild19
-rw-r--r--dev-perl/X11-Protocol/X11-Protocol-0.560.0-r2.ebuild28
-rw-r--r--dev-perl/X11-Protocol/files/X11-Protocol-0.56-test-tap.patch28
-rw-r--r--dev-perl/X11-Protocol/files/X11-Protocol-0.56-test-timeout.patch38
-rw-r--r--dev-perl/X11-Protocol/metadata.xml28
6 files changed, 147 insertions, 0 deletions
diff --git a/dev-perl/X11-Protocol/Manifest b/dev-perl/X11-Protocol/Manifest
new file mode 100644
index 000000000000..e3c43c747a27
--- /dev/null
+++ b/dev-perl/X11-Protocol/Manifest
@@ -0,0 +1,6 @@
+AUX X11-Protocol-0.56-test-tap.patch 859 BLAKE2B f126f1516191c68557d12d0d68a13fc63a1385a715394e9291b3acb06e0dfccca9cda893965223f02c55f69f43413792c402abcafb7bc13a57c7b5869ed66563 SHA512 e48a388e73722bfecec01388c3b149a9e9507cc3d99c101ea0ffe6170925c157628600cbc43474945fe464069632da2890c494e3fb503e2d9aa6e27cbfa9b624
+AUX X11-Protocol-0.56-test-timeout.patch 875 BLAKE2B 4571b7ae0ad18c5545de085bb472c26021ff961e6e22f85310edb8bb6c34ac066a1de58e197daa5d5ccf561f305c6c318755ec3e4831e1a40d2bf90a34d9f6c2 SHA512 cc825c1190b594cbe787aa41fe1302e8b83d318a5ec6d42e802e630cf385193f161bce82f399d9e2f2eb96783afc5ce60c85d08238691d3063539c5686063207
+DIST X11-Protocol-0.56.tar.gz 101227 BLAKE2B 7c13e7f511a36c0f480f500577d4b9f2a5915fc1d071bb660a8d8d56ca0c2d5facc8122e3f9760751bbbe5f669a52e4c5cd6a375f209d7abb4f4281b227157d5 SHA512 1c1a6ed15ceff77e8be29ac32a0e72aa2d0a1e62b5e19af2e34055aa001ee281ab584d993ace82f46f00d4da2e7bd4c60e4e31876a43c6c64c3e216beb13fe5f
+EBUILD X11-Protocol-0.560.0-r1.ebuild 495 BLAKE2B 233cacf19901be6d1bf933eca440b2f3e30650431f559a936b4be482670ee2914ceb05f4d2fe859e62d102db88402dae5d05282e8d74e57dc49c28ec1a554cf4 SHA512 49602202d2eefd8e419f367b5a9dd1c33f274f5c30c45beee8cbb59fada544b1ea90abc8efbc34cb8932bd17cbae83bcadf6add3b36cd592c49d62291e4e6f5a
+EBUILD X11-Protocol-0.560.0-r2.ebuild 669 BLAKE2B f6740bb2e6d97e0dd018c474236473cfa66593f9966d8c9958addea5701c8d01d1e4abdc6fda4a4ca8ee75cc0ad937ce96c002d991fea69598e3979645394c50 SHA512 8412b6ff441252545fadb04d03a527f28b956156a637445c6f11375d6f360d6feb7f67585f352ca0648d88338d8fa4e79f458433b163aa752ee97e23fb531532
+MISC metadata.xml 1594 BLAKE2B 9de873c7cc1a7db3edf3a6ef6c1b7dd1843b0ffe0675ac9cd14c7c96cc92d838d800bb182c4dbf1fdb67560e1aa17dbbab536972f65b3c968bad86189a69140e SHA512 61e03d09767517801cfcc9af58a74ea67f092f6426108438b92afdbefd90de1945fc851b9b066f624f98b1f6cd4780e52cc50b7556b13bcf06fdfd0d6935f9ce
diff --git a/dev-perl/X11-Protocol/X11-Protocol-0.560.0-r1.ebuild b/dev-perl/X11-Protocol/X11-Protocol-0.560.0-r1.ebuild
new file mode 100644
index 000000000000..234c1a49e436
--- /dev/null
+++ b/dev-perl/X11-Protocol/X11-Protocol-0.560.0-r1.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+MODULE_AUTHOR=SMCCAM
+MODULE_VERSION=0.56
+inherit perl-module
+
+DESCRIPTION="Client-side interface to the X11 Protocol"
+
+LICENSE="${LICENSE} MIT"
+SLOT="0"
+KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~mips ppc ppc64 s390 sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~sparc-solaris ~x86-solaris"
+IUSE=""
+
+RDEPEND="x11-libs/libXrender
+ x11-libs/libXext"
+DEPEND="${RDEPEND}"
diff --git a/dev-perl/X11-Protocol/X11-Protocol-0.560.0-r2.ebuild b/dev-perl/X11-Protocol/X11-Protocol-0.560.0-r2.ebuild
new file mode 100644
index 000000000000..998cd12da987
--- /dev/null
+++ b/dev-perl/X11-Protocol/X11-Protocol-0.560.0-r2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=SMCCAM
+DIST_VERSION=0.56
+DIST_EXAMPLES=("eg/*")
+inherit perl-module virtualx
+
+DESCRIPTION="Client-side interface to the X11 Protocol"
+
+LICENSE="${LICENSE} MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~sparc-solaris ~x86-solaris"
+IUSE=""
+
+RDEPEND="x11-libs/libXrender
+ x11-libs/libXext"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-0.56-test-timeout.patch"
+ "${FILESDIR}/${PN}-0.56-test-tap.patch"
+)
+src_test() {
+ virtx perl-module_src_test
+}
diff --git a/dev-perl/X11-Protocol/files/X11-Protocol-0.56-test-tap.patch b/dev-perl/X11-Protocol/files/X11-Protocol-0.56-test-tap.patch
new file mode 100644
index 000000000000..83c07bebc37a
--- /dev/null
+++ b/dev-perl/X11-Protocol/files/X11-Protocol-0.56-test-tap.patch
@@ -0,0 +1,28 @@
+From 663aaa7eefbf9dcad54c8c7f4c463bf289a9b907 Mon Sep 17 00:00:00 2001
+From: Kent Fredric <kentnl@gentoo.org>
+Date: Wed, 28 Mar 2018 23:46:13 +1300
+Subject: Move to a TAP::Harness friendly test layout
+
+---
+ MANIFEST | 2 +-
+ test.pl => t/x11.t | 0
+ 2 files changed, 1 insertion(+), 1 deletion(-)
+ rename test.pl => t/x11.t (100%)
+
+diff --git a/MANIFEST b/MANIFEST
+index 24c14b7..8648607 100644
+--- a/MANIFEST
++++ b/MANIFEST
+@@ -33,4 +33,4 @@ eg/widgets2.pl X11-Motif version of widget example
+ eg/widgets3.pl Unfinished OO-interface widget example
+ eg/widgets.c C Xlib version of widget example
+ eg/wintree.pl Window hierarchy utility example
+-test.pl Short test of Protocol.pm et al.
++t/x11.t Short test of Protocol.pm et al.
+diff --git a/test.pl b/t/x11.t
+similarity index 100%
+rename from test.pl
+rename to t/x11.t
+--
+2.16.2
+
diff --git a/dev-perl/X11-Protocol/files/X11-Protocol-0.56-test-timeout.patch b/dev-perl/X11-Protocol/files/X11-Protocol-0.56-test-timeout.patch
new file mode 100644
index 000000000000..c20ae4d73b91
--- /dev/null
+++ b/dev-perl/X11-Protocol/files/X11-Protocol-0.56-test-timeout.patch
@@ -0,0 +1,38 @@
+From 00202116b49691de109c397f298c55960d2b9896 Mon Sep 17 00:00:00 2001
+From: Slaven Rezic <slaven@rezic.de>
+Date: Sat, 25 Nov 2017 09:57:00 +0100
+Subject: timeout tests on inactivity
+
+Bug: https://rt.cpan.org/Ticket/Display.html?id=123736
+---
+ test.pl | 12 +++++++++++-
+ 1 file changed, 11 insertions(+), 1 deletion(-)
+
+diff --git a/test.pl b/test.pl
+index 8436a47..209a6a6 100644
+--- a/test.pl
++++ b/test.pl
+@@ -91,9 +91,19 @@ $gc = getGC($win, $font);
+
+ $x->MapWindow($win);
+
++$SIG{ALRM} = sub { die "Timeout" };
++alarm(5);
+ while (1)
+ {
+- $x->handle_input until %e = $x->dequeue_event;
++ eval { $x->handle_input until %e = $x->dequeue_event; };
++ if ($@)
++ {
++ if ($@ =~ /Timeout/) {
++ print "ok 3\n";
++ last;
++ }
++ die $@;
++ }
+ if ($e{name} eq "Expose")
+ {
+ next unless $e{count} == 0;
+--
+2.16.2
+
diff --git a/dev-perl/X11-Protocol/metadata.xml b/dev-perl/X11-Protocol/metadata.xml
new file mode 100644
index 000000000000..484fc7c846c4
--- /dev/null
+++ b/dev-perl/X11-Protocol/metadata.xml
@@ -0,0 +1,28 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>perl@gentoo.org</email>
+ <name>Gentoo Perl Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="cpan">X11-Protocol</remote-id>
+ <remote-id type="cpan-module">X11::Auth</remote-id>
+ <remote-id type="cpan-module">X11::Keysyms</remote-id>
+ <remote-id type="cpan-module">X11::Protocol</remote-id>
+ <remote-id type="cpan-module">X11::Protocol::Connection</remote-id>
+ <remote-id type="cpan-module">X11::Protocol::Connection::FileHandle</remote-id>
+ <remote-id type="cpan-module">X11::Protocol::Connection::INETFH</remote-id>
+ <remote-id type="cpan-module">X11::Protocol::Connection::INETSocket</remote-id>
+ <remote-id type="cpan-module">X11::Protocol::Connection::Socket</remote-id>
+ <remote-id type="cpan-module">X11::Protocol::Connection::UNIXFH</remote-id>
+ <remote-id type="cpan-module">X11::Protocol::Connection::UNIXSocket</remote-id>
+ <remote-id type="cpan-module">X11::Protocol::Constants</remote-id>
+ <remote-id type="cpan-module">X11::Protocol::Ext::BIG_REQUESTS</remote-id>
+ <remote-id type="cpan-module">X11::Protocol::Ext::DPMS</remote-id>
+ <remote-id type="cpan-module">X11::Protocol::Ext::RENDER</remote-id>
+ <remote-id type="cpan-module">X11::Protocol::Ext::SHAPE</remote-id>
+ <remote-id type="cpan-module">X11::Protocol::Ext::XC_MISC</remote-id>
+ <remote-id type="cpan-module">X11::Protocol::Ext::XFree86_Misc</remote-id>
+ </upstream>
+</pkgmetadata>