summaryrefslogtreecommitdiff
path: root/dev-perl/tkispell/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-perl/tkispell/files
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-perl/tkispell/files')
-rw-r--r--dev-perl/tkispell/files/tkispell-0.18-aspell.patch46
-rw-r--r--dev-perl/tkispell/files/tkispell-0.180.0-aspell.patch31
2 files changed, 77 insertions, 0 deletions
diff --git a/dev-perl/tkispell/files/tkispell-0.18-aspell.patch b/dev-perl/tkispell/files/tkispell-0.18-aspell.patch
new file mode 100644
index 000000000000..14c080db3cf3
--- /dev/null
+++ b/dev-perl/tkispell/files/tkispell-0.18-aspell.patch
@@ -0,0 +1,46 @@
+From ed7ede66c01fbae6c5de0e6dc28d991a1f27016c Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Andreas=20K=2E=20H=C3=BCttel?= <dilfridge@gentoo.org>
+Date: Sat, 11 Oct 2014 21:48:27 +1300
+Subject: Patch to use aspell instead of ispell
+
+---
+ Makefile.PL | 8 ++++----
+ tkispell | 2 +-
+ 2 files changed, 5 insertions(+), 5 deletions(-)
+
+diff --git a/Makefile.PL b/Makefile.PL
+index 4cebdea..8a49493 100644
+--- a/Makefile.PL
++++ b/Makefile.PL
+@@ -1,11 +1,11 @@
+ use ExtUtils::MakeMaker;
+
+-my $ispell_bin = `which ispell`;
++my $ispell_bin = `which ispell-aspell`;
+ # The first match is for Solaris which. The second is for
+ # Linux which.
+-if (($ispell_bin =~ /no ispell/) || (length($ispell_bin) == 0)) {
+- print "Could not find locate ispell. Make sure that\n";
+- print "the ispell program is installed in a directory\n";
++if (($ispell_bin =~ /no ispell-aspell/) || (length($ispell_bin) == 0)) {
++ print "Could not find locate ispell-aspell. Make sure that\n";
++ print "the ispell-aspell program is installed in a directory\n";
+ print "named in the PATH environment variable.\n";
+ exit 1;
+ }
+diff --git a/tkispell b/tkispell
+index fbc6cc7..6bde051 100644
+--- a/tkispell
++++ b/tkispell
+@@ -14,7 +14,7 @@ my $lang = $ENV{LANG};
+ if ($lang =~ /^C$/ || ! defined ($lang)) {$lang = 'default'; }
+ my $hdict = $ENV{HOME}."/.ispell_$lang"; # Personal dictionary.
+
+-my $ispell_prog = `which ispell`;
++my $ispell_prog = `which ispell-aspell`;
+ chomp $ispell_prog;
+ my ($cw, $b1, @misspelledlist, @replacementlist, @addlist, $midx);
+ my $ifname = '';
+--
+2.16.2
+
diff --git a/dev-perl/tkispell/files/tkispell-0.180.0-aspell.patch b/dev-perl/tkispell/files/tkispell-0.180.0-aspell.patch
new file mode 100644
index 000000000000..1db7bd291eff
--- /dev/null
+++ b/dev-perl/tkispell/files/tkispell-0.180.0-aspell.patch
@@ -0,0 +1,31 @@
+diff -ruN tkispell-0.18.orig/Makefile.PL tkispell-0.18/Makefile.PL
+--- tkispell-0.18.orig/Makefile.PL 2004-02-28 20:38:46.000000000 +0100
++++ tkispell-0.18/Makefile.PL 2014-10-11 10:43:09.372002632 +0200
+@@ -1,11 +1,11 @@
+ use ExtUtils::MakeMaker;
+
+-my $ispell_bin = `which ispell`;
++my $ispell_bin = `which ispell-aspell`;
+ # The first match is for Solaris which. The second is for
+ # Linux which.
+-if (($ispell_bin =~ /no ispell/) || (length($ispell_bin) == 0)) {
+- print "Could not find locate ispell. Make sure that\n";
+- print "the ispell program is installed in a directory\n";
++if (($ispell_bin =~ /no ispell-aspell/) || (length($ispell_bin) == 0)) {
++ print "Could not find locate ispell-aspell. Make sure that\n";
++ print "the ispell-aspell program is installed in a directory\n";
+ print "named in the PATH environment variable.\n";
+ exit 1;
+ }
+diff -ruN tkispell-0.18.orig/tkispell tkispell-0.18/tkispell
+--- tkispell-0.18.orig/tkispell 2004-03-14 03:50:34.000000000 +0100
++++ tkispell-0.18/tkispell 2014-10-11 10:43:58.772005395 +0200
+@@ -14,7 +14,7 @@
+ if ($lang =~ /^C$/ || ! defined ($lang)) {$lang = 'default'; }
+ my $hdict = $ENV{HOME}."/.ispell_$lang"; # Personal dictionary.
+
+-my $ispell_prog = `which ispell`;
++my $ispell_prog = `which ispell-aspell`;
+ chomp $ispell_prog;
+ my ($cw, $b1, @misspelledlist, @replacementlist, @addlist, $midx);
+ my $ifname = '';