summaryrefslogtreecommitdiff
path: root/dev-php/PEAR-File_Find/PEAR-File_Find-1.3.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
commit1798c4aeca70ac8d0a243684d6a798fbc65735f8 (patch)
treee48e19cb6fa03de18e1c63e1a93371b7ebc4eb56 /dev-php/PEAR-File_Find/PEAR-File_Find-1.3.3.ebuild
parentd87262dd706fec50cd150aab3e93883b6337466d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-php/PEAR-File_Find/PEAR-File_Find-1.3.3.ebuild')
-rw-r--r--dev-php/PEAR-File_Find/PEAR-File_Find-1.3.3.ebuild45
1 files changed, 0 insertions, 45 deletions
diff --git a/dev-php/PEAR-File_Find/PEAR-File_Find-1.3.3.ebuild b/dev-php/PEAR-File_Find/PEAR-File_Find-1.3.3.ebuild
deleted file mode 100644
index a4addfe6d4e7..000000000000
--- a/dev-php/PEAR-File_Find/PEAR-File_Find-1.3.3.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-MY_PN="${PN/PEAR-/}"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="A class that facillitates the search of filesystems"
-HOMEPAGE="http://pear.php.net/package/${MY_PN}"
-SRC_URI="http://download.pear.php.net/package/${MY_P}.tgz"
-LICENSE="PHP-3.01"
-SLOT="0"
-KEYWORDS="alpha amd64 hppa ia64 ppc ppc64 sparc x86"
-IUSE="test"
-
-# Really only needs PEAR-Exception at runtime.
-RDEPEND="dev-lang/php:*
- dev-php/PEAR-PEAR"
-DEPEND="test? ( dev-php/PEAR-PEAR )"
-
-S="${WORKDIR}/${MY_P}"
-
-src_prepare() {
- eapply_user
-
- # Without this sed, the test suite will try (and fail) to mess
- # around in /tmp.
- sed -i "s~'/tmp'~'${T}'~" tests/setup.php \
- || die 'failed to fix temporary directory in tests/setup.php'
-}
-
-src_install() {
- insinto /usr/share/php
- doins -r File
-}
-
-src_test() {
- # Requires the "pear" executable from dev-php/PEAR-PEAR.
- pear run-tests tests || die
-
- # The command succeeds regardless of whether or not the test suite
- # passed, but this file is only written when there was a failure.
- [[ -f run-tests.log ]] && die "test suite failed"
-}