summaryrefslogtreecommitdiff
path: root/dev-php/PEAR-HTML_Template_Sigma
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-02-24 19:58:07 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-02-24 19:58:07 +0000
commit99abbc5e5a6ecd3fc981b45646fd8cb5d320377b (patch)
treeda76713365257a445f3ae3b95470917f59d46728 /dev-php/PEAR-HTML_Template_Sigma
parent4935506e9a5cbfabd37c64093eac5f36c2ff0017 (diff)
gentoo resync : 24.02.2018
Diffstat (limited to 'dev-php/PEAR-HTML_Template_Sigma')
-rw-r--r--dev-php/PEAR-HTML_Template_Sigma/Manifest3
-rw-r--r--dev-php/PEAR-HTML_Template_Sigma/PEAR-HTML_Template_Sigma-1.3.0-r1.ebuild20
-rw-r--r--dev-php/PEAR-HTML_Template_Sigma/PEAR-HTML_Template_Sigma-1.3.0.ebuild14
-rw-r--r--dev-php/PEAR-HTML_Template_Sigma/files/HTML_Template_Sigma-1.3.0-php7.patch42
4 files changed, 64 insertions, 15 deletions
diff --git a/dev-php/PEAR-HTML_Template_Sigma/Manifest b/dev-php/PEAR-HTML_Template_Sigma/Manifest
index c510c6b59948..8a5b3f2cfd4a 100644
--- a/dev-php/PEAR-HTML_Template_Sigma/Manifest
+++ b/dev-php/PEAR-HTML_Template_Sigma/Manifest
@@ -1,3 +1,4 @@
+AUX HTML_Template_Sigma-1.3.0-php7.patch 2155 BLAKE2B 1e46e49bf5bf54719635736f8c5f50c6c123c5777fbcf59c1fb5129f068d4947c0e0669b6df76de80b2cd54ec8674a85174f1acfa3a2601abd82eab6bb30d416 SHA512 ea9399d7b7de2361a11b2cc2e89d534b4289ecd656c9b5d99618d4faef9ad7b39e87884d5c720b62a8d55c58ce66b35ee014d010bef5a8ec5cc4b2884b894eda
DIST HTML_Template_Sigma-1.3.0.tgz 30185 BLAKE2B 62d91d803a088c45c662191cc4fe544d2ef694577a3250a5bc19bc7b41640fc695be95c075c8c3f53e3ebc03fa7d9d38135d607c408ff3d6cb0f1ad11855b740 SHA512 586068325a3320e2778131c1da98d6179d2385d2d73308b0ea1e8df3e0de23f869e03d74454752631998ef3411d8e8b37feab93c6c7b9f51ae4bedb48155e3ed
-EBUILD PEAR-HTML_Template_Sigma-1.3.0.ebuild 350 BLAKE2B 14c9dd32355a047e4cddd3d0b1654fda1d46f8475572df8b6495168bdbc8c4962bb15b645038dda1751849e96d2d0777f82a30d578486a22f9add97e5b5c7fc3 SHA512 a37351425597c3d9e45b8620223072d508915f86e38282997e20b971d13a5edaebe5be184a8ca9d4a903a48c1bd577ed7889569ee6a6eadd53682c62ac415a7f
+EBUILD PEAR-HTML_Template_Sigma-1.3.0-r1.ebuild 517 BLAKE2B 484399a6d26955aecd852d9f9c06094402f2a7f74d811f990491c5ed5afb68152b50500ff063fe3381017dcd9147d93a395ee9b429c32e8660d6e639d6ab0182 SHA512 eebf5229e8aedb4282f163617ae3f59e7a54006a512d678b219ca81fbeabb2b17748d20ce4b3f764b5529f6cd533828efc228d82ac5f4b7b8162e881f636b8cb
MISC metadata.xml 235 BLAKE2B 5b10304feea18aae1822be7d29bcce06c8715193b14a3dd2c4d79eb75e2767670352e2ca11e06b9a10ec04b63020a18254cd167e6d6be9072f4a200ca5d11ec4 SHA512 0b3e95bbf68eddf74289dad50f8828cffce2d904ff6f9bd5468177de979677cac11da84d1e0302c52b72085915b9d1b3496107172e5726520d51dad1981daf64
diff --git a/dev-php/PEAR-HTML_Template_Sigma/PEAR-HTML_Template_Sigma-1.3.0-r1.ebuild b/dev-php/PEAR-HTML_Template_Sigma/PEAR-HTML_Template_Sigma-1.3.0-r1.ebuild
new file mode 100644
index 000000000000..828f16ce507e
--- /dev/null
+++ b/dev-php/PEAR-HTML_Template_Sigma/PEAR-HTML_Template_Sigma-1.3.0-r1.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit php-pear-r2
+
+DESCRIPTION="An implementation of Integrated Templates API with template 'compilation' added"
+LICENSE="PHP-3.01"
+SLOT="0"
+KEYWORDS="alpha amd64 hppa ia64 ppc ppc64 sparc x86"
+IUSE="test"
+
+RDEPEND="dev-lang/php:*[ctype]"
+DEPEND="test? ( ${RDEPEND} dev-php/phpunit )"
+PATCHES=( "${FILESDIR}/HTML_Template_Sigma-1.3.0-php7.patch" )
+
+src_test() {
+ phpunit tests/AllTests.php || die
+}
diff --git a/dev-php/PEAR-HTML_Template_Sigma/PEAR-HTML_Template_Sigma-1.3.0.ebuild b/dev-php/PEAR-HTML_Template_Sigma/PEAR-HTML_Template_Sigma-1.3.0.ebuild
deleted file mode 100644
index dfde6e232ff2..000000000000
--- a/dev-php/PEAR-HTML_Template_Sigma/PEAR-HTML_Template_Sigma-1.3.0.ebuild
+++ /dev/null
@@ -1,14 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit php-pear-r1
-
-DESCRIPTION="An implementation of Integrated Templates API with template 'compilation' added"
-LICENSE="PHP-3.01"
-SLOT="0"
-KEYWORDS="alpha amd64 hppa ia64 ppc ppc64 sparc x86"
-IUSE=""
-
-DEPEND="dev-lang/php[ctype]"
diff --git a/dev-php/PEAR-HTML_Template_Sigma/files/HTML_Template_Sigma-1.3.0-php7.patch b/dev-php/PEAR-HTML_Template_Sigma/files/HTML_Template_Sigma-1.3.0-php7.patch
new file mode 100644
index 000000000000..ffb95e208467
--- /dev/null
+++ b/dev-php/PEAR-HTML_Template_Sigma/files/HTML_Template_Sigma-1.3.0-php7.patch
@@ -0,0 +1,42 @@
+diff -aurN a/HTML/Template/Sigma.php b/HTML/Template/Sigma.php
+--- a/HTML/Template/Sigma.php 2014-01-13 04:33:52.000000000 -0500
++++ b/HTML/Template/Sigma.php 2018-02-19 09:29:52.995013991 -0500
+@@ -384,6 +384,26 @@
+ *
+ * @see setRoot(), setCacheRoot()
+ */
++ function __construct($root = '', $cacheRoot = '')
++ {
++ // the class is inherited from PEAR to be able to use $this->setErrorHandling()
++ parent::__construct();
++ $this->variablesRegExp = '@' . $this->openingDelimiter . '(' . $this->variablenameRegExp . ')' .
++ '(:(' . $this->functionnameRegExp . '))?' . $this->closingDelimiter . '@sm';
++ $this->removeVariablesRegExp = '@' . $this->openingDelimiter . '\s*(' . $this->variablenameRegExp . ')\s*'
++ . $this->closingDelimiter . '@sm';
++ $this->blockRegExp = '@<!--\s+BEGIN\s+(' . $this->blocknameRegExp
++ . ')\s+-->(.*)<!--\s+END\s+\1\s+-->@sm';
++ $this->functionRegExp = '@' . $this->functionPrefix . '(' . $this->functionnameRegExp . ')\s*\(@sm';
++ $this->setRoot($root);
++ $this->setCacheRoot($cacheRoot);
++
++ $this->setCallbackFunction('h', array(&$this, '_htmlspecialchars'));
++ $this->setCallbackFunction('e', array(&$this, '_htmlentities'));
++ $this->setCallbackFunction('u', 'urlencode');
++ $this->setCallbackFunction('r', 'rawurlencode');
++ $this->setCallbackFunction('j', array(&$this, '_jsEscape'));
++ }
+ function HTML_Template_Sigma($root = '', $cacheRoot = '')
+ {
+ // the class is inherited from PEAR to be able to use $this->setErrorHandling()
+diff -aurN a/tests/AllTests.php b/tests/AllTests.php
+--- a/tests/AllTests.php 2014-01-13 04:33:52.000000000 -0500
++++ b/tests/AllTests.php 2018-02-19 09:37:14.071972780 -0500
+@@ -24,8 +24,6 @@
+ define('PHPUnit_MAIN_METHOD', 'HTML_Template_Sigma_AllTests::main');
+ }
+
+-require_once 'PHPUnit/Autoload.php';
+-
+ /**
+ * Class for file / directory manipulation from PEAR package
+ */