summaryrefslogtreecommitdiff
path: root/dev-php/PEAR-Log
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-06-21 17:50:24 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-06-21 17:50:24 +0100
commitfeb0daf81d888e9160f9f94502de09b66f2a63fd (patch)
treeb6e5c40ce2abef3da27ed50a023153f475e0ddef /dev-php/PEAR-Log
parent9452a6e87b6c2c70513bc47a2470bf9f1168920e (diff)
gentoo resync : 21.06.2020
Diffstat (limited to 'dev-php/PEAR-Log')
-rw-r--r--dev-php/PEAR-Log/Manifest2
-rw-r--r--dev-php/PEAR-Log/PEAR-Log-1.13.2.ebuild48
2 files changed, 50 insertions, 0 deletions
diff --git a/dev-php/PEAR-Log/Manifest b/dev-php/PEAR-Log/Manifest
index e996bc2efbbe..581d55671342 100644
--- a/dev-php/PEAR-Log/Manifest
+++ b/dev-php/PEAR-Log/Manifest
@@ -1,3 +1,5 @@
DIST Log-1.13.1.tgz 46764 BLAKE2B dc0f4605ed801818ddf070ec3beb6818af1630d99bec721cd3f487e709f87bd4a1628a05854c48fe9775aab546bdce4618061ef37674aa9921f536deccc6a080 SHA512 246510b7dbff4dc9f9cdd951d76baf2dd377e30ffde6d38cadac10091dcb92f8095406edb6d8a87ebe2330d514ce99f355f84ebfe57cd8a3f3babc316995148a
+DIST Log-1.13.2.tgz 46801 BLAKE2B 529677ed8a840742840a8ebeb5f5c7d4e8a8af257f9c3b1cb9ff990e42e760e0040f7df8d94794f40ec5654cf33e1909b7b48ca3f656d2a2bc0310c6705d6c24 SHA512 a4adaf7ee2af600a6c14ed398159c61a7df73b2c6be928f0ea6bbaf90d4b0e866e5a169953fa7819e293cd5cb29c6aca762ced79f3619dfbb38af1ea8731b1c4
EBUILD PEAR-Log-1.13.1.ebuild 1348 BLAKE2B 8ffba37aebb27becc35d76b635b25bdea8a084f9e6dfbdf33295ae4313150f73ad6b9741a0de2c9046d99441fe7df7aebc8b96867c41f2f88cb9d2dce14789fa SHA512 825574468c5848d094b18e6e9961c942556f4498cc0eaa7f6731909f730724eede1501e3dbe4da6dcbee6867ccb76e405c6636149f8acdf71eb7a843cad4989f
+EBUILD PEAR-Log-1.13.2.ebuild 1355 BLAKE2B 9b3c58f6b927d4231a010ca39eac6d374c855a175a4dae4f19f4a1e6cbf62eba674e589d97f5bcd41f21e96c39dc1e23b9050126247019d36bf6c1729a3d2844 SHA512 a1c01f4d37ef9217f8dcc7ffdb8dddc3d0530630a9cea89d6aace531461b45737d7a48819f90862b1293a1b385c24e0ca07114b24eb0a92f5e143daf78b59ca2
MISC metadata.xml 305 BLAKE2B 9ae588d4fa3e555b0362d0f9ba19dd3bfd459f1788fb047852f22cde3d2688e3807d4ad87247b9dd8759450af1c1ce55192b2e551a8337abd08fbc771f32cd36 SHA512 8540d045359dc2f4ed04bde79616f2ebe923a0d3a6e401788a37e3bfd973a9db33662f5c01326e0fe0198246dad290d8d3ec3d841394071c215f70a8ad4abf71
diff --git a/dev-php/PEAR-Log/PEAR-Log-1.13.2.ebuild b/dev-php/PEAR-Log/PEAR-Log-1.13.2.ebuild
new file mode 100644
index 000000000000..384c2311aa5c
--- /dev/null
+++ b/dev-php/PEAR-Log/PEAR-Log-1.13.2.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MY_PN="${PN/PEAR-/}"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="The Log framework provides an abstracted logging system"
+HOMEPAGE="https://pear.php.net/package/Log"
+SRC_URI="http://download.pear.php.net/package/${MY_P}.tgz"
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE="examples test"
+RESTRICT="!test? ( test )"
+
+# The DB, Mail, and MDB2 dependencies are technically optional, but
+# automagic. To avoid surprises, we require them unconditionally.
+RDEPEND="dev-lang/php:*
+ dev-php/PEAR-PEAR
+ dev-php/PEAR-DB
+ dev-php/PEAR-Mail
+ dev-php/PEAR-MDB2"
+DEPEND="test? ( ${RDEPEND} )"
+
+S="${WORKDIR}/${MY_P}"
+
+src_install() {
+ dodoc docs/guide.txt misc/log.sql
+ use examples && dodoc -r examples
+
+ # I don't like installing "Log.php" right at the top-level, but any
+ # packages depending on us will expect to find it there and not as
+ # e.g. Log/Log.php.
+ insinto "/usr/share/php/"
+ doins Log.php
+ doins -r Log
+}
+
+src_test() {
+ # Requires the "pear" executable from dev-php/PEAR-PEAR.
+ pear run-tests tests || die
+
+ # The command succeeds regardless of whether or not the test suite
+ # passed, but this file is only written when there was a failure.
+ [[ -f run-tests.log ]] && die "test suite failed"
+}