summaryrefslogtreecommitdiff
path: root/dev-php/PEAR-Net_SMTP/PEAR-Net_SMTP-1.8.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-11-03 08:36:22 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-11-03 08:36:22 +0000
commitf65628136faa35d0c4d3b5e7332275c7b35fcd96 (patch)
tree021998302365c5652e37824b6c26d4d969a62055 /dev-php/PEAR-Net_SMTP/PEAR-Net_SMTP-1.8.1.ebuild
parent70b82ae359a5538711e103b0e8dfb92654296644 (diff)
gentoo resync : 03.11.2018
Diffstat (limited to 'dev-php/PEAR-Net_SMTP/PEAR-Net_SMTP-1.8.1.ebuild')
-rw-r--r--dev-php/PEAR-Net_SMTP/PEAR-Net_SMTP-1.8.1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-php/PEAR-Net_SMTP/PEAR-Net_SMTP-1.8.1.ebuild b/dev-php/PEAR-Net_SMTP/PEAR-Net_SMTP-1.8.1.ebuild
new file mode 100644
index 000000000000..e73ba70c1876
--- /dev/null
+++ b/dev-php/PEAR-Net_SMTP/PEAR-Net_SMTP-1.8.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit php-pear-r2
+
+MY_PN="${PN/PEAR-/}"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="A PHP implementation of the SMTP protocol"
+HOMEPAGE="http://pear.php.net/package/Net_SMTP"
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="examples sasl"
+DEPEND=""
+RDEPEND="dev-lang/php:*
+ dev-php/PEAR-Net_Socket
+ dev-php/PEAR-PEAR
+ sasl? ( dev-php/PEAR-Auth_SASL )"
+
+S="${WORKDIR}/${MY_P}"
+
+src_install() {
+ DOCS=( docs/guide.txt )
+ use examples && HTML_DOCS=( examples )
+ php-pear-r2_src_install
+}