summaryrefslogtreecommitdiff
path: root/dev-php/PEAR-VersionControl_SVN
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-php/PEAR-VersionControl_SVN
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-php/PEAR-VersionControl_SVN')
-rw-r--r--dev-php/PEAR-VersionControl_SVN/Manifest5
-rw-r--r--dev-php/PEAR-VersionControl_SVN/PEAR-VersionControl_SVN-0.5.2-r1.ebuild20
-rw-r--r--dev-php/PEAR-VersionControl_SVN/PEAR-VersionControl_SVN-0.5.2_p20180314.ebuild28
-rw-r--r--dev-php/PEAR-VersionControl_SVN/metadata.xml8
4 files changed, 61 insertions, 0 deletions
diff --git a/dev-php/PEAR-VersionControl_SVN/Manifest b/dev-php/PEAR-VersionControl_SVN/Manifest
new file mode 100644
index 000000000000..db08d3916d08
--- /dev/null
+++ b/dev-php/PEAR-VersionControl_SVN/Manifest
@@ -0,0 +1,5 @@
+DIST PEAR-VersionControl_SVN-0.5.2_p20180314.tar.gz 36697 BLAKE2B 998e9c08d19284de2bd723fff07bc4c319ed65b12baad012f5f8e6b283060cd25cdefa5141e71f8368555d963e7ab1eec7b8e41d38cbd9a89dbd6977f72b5102 SHA512 aaba6fcd65d3906c9d98085b109d1357578be7557a9ac5b5997ae9a9896cb0970f3bf707246e5afc68dfbb8268a8fad36265b484220387b56e8de85e390db82a
+DIST VersionControl_SVN-0.5.2.tgz 31356 BLAKE2B d59971b0677d3e88b47f1fb249c6ba6971db7b868e390589705058fa0cc19a3b4e7a2da38db78b37a9fa7b8f9233297a4fb5376b1b225c8e93f41bbe65c99007 SHA512 09aaab0461a52fe87e5723472b9978c8f928a4741e11a69672ae1350ecdf90b287d951b8343b5fbfbc1d7cd449055cb249f229a1e943cdcd807e9b36e0a48b86
+EBUILD PEAR-VersionControl_SVN-0.5.2-r1.ebuild 586 BLAKE2B fe71070981e12a7151c32e16d4f4d08259dd4fbb79b4b70f43eb18a39763e4cd3de7c734cabf4759f6eda80de2f0711d62466607332b2a128c1077db84efd767 SHA512 12ce42b63818dc4bfd2960ee83c640767ca70fb782853aa1783e160699b793bec7d3d3f69a39e812d0a8dd0c3182b77fce0e9678b3c2061bcf896aea23eeb004
+EBUILD PEAR-VersionControl_SVN-0.5.2_p20180314.ebuild 938 BLAKE2B ff3f32f8a981a526a31251ee0d3a62c0d2d55fedfaa1ecf43a3963cee1fc0d64f3bddc554d8ebc5f9052b117997042d250c690c884eef3a2d16edf687177bc15 SHA512 5a2fd603d9f1e31d1e820575c870c55e98b5b6dc1bdb6119a20ced539c147e13b4ecb6ab669dd1585e9a33c71723fb8975b5926dffd50c671b212969206e7e2c
+MISC metadata.xml 235 BLAKE2B 5b10304feea18aae1822be7d29bcce06c8715193b14a3dd2c4d79eb75e2767670352e2ca11e06b9a10ec04b63020a18254cd167e6d6be9072f4a200ca5d11ec4 SHA512 0b3e95bbf68eddf74289dad50f8828cffce2d904ff6f9bd5468177de979677cac11da84d1e0302c52b72085915b9d1b3496107172e5726520d51dad1981daf64
diff --git a/dev-php/PEAR-VersionControl_SVN/PEAR-VersionControl_SVN-0.5.2-r1.ebuild b/dev-php/PEAR-VersionControl_SVN/PEAR-VersionControl_SVN-0.5.2-r1.ebuild
new file mode 100644
index 000000000000..7fea8919316e
--- /dev/null
+++ b/dev-php/PEAR-VersionControl_SVN/PEAR-VersionControl_SVN-0.5.2-r1.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit php-pear-r2
+
+DESCRIPTION="Simple OO wrapper interface for the Subversion command-line client"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+RDEPEND=""
+
+src_prepare() {
+ einfo "Patching SVN.php and SVN/Command.php to use proper paths by default"
+ sed -i -e 's:/usr/local:/usr:g' VersionControl/SVN.php || die "sed failed"
+ sed -i -e 's:/usr/local:/usr:g' VersionControl/SVN/Command.php || die "sed failed"
+ default
+}
diff --git a/dev-php/PEAR-VersionControl_SVN/PEAR-VersionControl_SVN-0.5.2_p20180314.ebuild b/dev-php/PEAR-VersionControl_SVN/PEAR-VersionControl_SVN-0.5.2_p20180314.ebuild
new file mode 100644
index 000000000000..e228a7700964
--- /dev/null
+++ b/dev-php/PEAR-VersionControl_SVN/PEAR-VersionControl_SVN-0.5.2_p20180314.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit php-pear-r2 vcs-snapshot
+
+DESCRIPTION="Simple OO wrapper interface for the Subversion command-line client"
+SRC_URI="https://github.com/pear/VersionControl_SVN/archive/6c9580df92f0cc77a6eb6fcc216c56913bf308e7.tar.gz -> ${P}.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="test"
+RDEPEND=""
+DEPEND="test? ( dev-vcs/subversion dev-php/phpunit )"
+S="${WORKDIR}/PEAR-${PHP_PEAR_PKG_NAME}-${PV}"
+
+src_prepare() {
+ einfo "Patching SVN.php and SVN/Command.php to use proper paths by default"
+ sed -i -e 's:/usr/local:/usr:g' VersionControl/SVN.php || die "sed failed"
+ sed -i -e 's:/usr/local:/usr:g' VersionControl/SVN/Command.php || die "sed failed"
+ sed -i 's/ +%d / %i /' tests/resetxml_19910.phpt || die
+ default
+}
+
+src_test() {
+ phpunit tests || die "Tests failed"
+}
diff --git a/dev-php/PEAR-VersionControl_SVN/metadata.xml b/dev-php/PEAR-VersionControl_SVN/metadata.xml
new file mode 100644
index 000000000000..aca42932b833
--- /dev/null
+++ b/dev-php/PEAR-VersionControl_SVN/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>php-bugs@gentoo.org</email>
+ <name>PHP</name>
+</maintainer>
+</pkgmetadata>