summaryrefslogtreecommitdiff
path: root/dev-php/awl/awl-0.59.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-php/awl/awl-0.59.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-php/awl/awl-0.59.ebuild')
-rw-r--r--dev-php/awl/awl-0.59.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-php/awl/awl-0.59.ebuild b/dev-php/awl/awl-0.59.ebuild
new file mode 100644
index 000000000000..3364d36a1b4d
--- /dev/null
+++ b/dev-php/awl/awl-0.59.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Andrew McMillan's Web Libraries"
+HOMEPAGE="https://gitlab.com/davical-project/awl"
+SRC_URI="https://www.davical.org/downloads/${PN}_${PV}.orig.tar.xz -> ${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DEPEND="test? ( dev-php/phpunit )"
+RDEPEND="dev-lang/php:*[pdo,postgres,xml]"
+
+S="${WORKDIR}"
+
+src_compile() {
+ :
+}
+
+src_test() {
+ phpunit tests/ || die "test suite failed"
+}
+
+src_install() {
+ einstalldocs
+ insinto /usr/share/php/${PN}
+ doins -r dba inc
+}