summaryrefslogtreecommitdiff
path: root/dev-php/doctrine/doctrine-2.6.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-php/doctrine/doctrine-2.6.1.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-php/doctrine/doctrine-2.6.1.ebuild')
-rw-r--r--dev-php/doctrine/doctrine-2.6.1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-php/doctrine/doctrine-2.6.1.ebuild b/dev-php/doctrine/doctrine-2.6.1.ebuild
new file mode 100644
index 000000000000..edd7e6575055
--- /dev/null
+++ b/dev-php/doctrine/doctrine-2.6.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MY_P="${PN}2-${PV}"
+DESCRIPTION="An object relational mapper for PHP"
+HOMEPAGE="https://www.doctrine-project.org/"
+SRC_URI="https://github.com/${PN}/${PN}2/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="2"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-lang/php-7.1:*[cli,pdo]"
+DEPEND=""
+
+S="${WORKDIR}/${MY_P}"
+
+src_install() {
+ insinto /usr/share/php
+ doins -r lib/Doctrine
+ insinto /usr/share/php/Doctrine
+ exeinto /usr/share/php/Doctrine
+ doins bin/doctrine.php
+ doexe bin/doctrine
+ dosym ../share/php/Doctrine/doctrine /usr/bin/doctrine
+}