summaryrefslogtreecommitdiff
path: root/dev-php/nikic-php-parser/nikic-php-parser-4.13.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
commit4cbcc855382a06088e2f016f62cafdbcb7e40665 (patch)
tree356496503d52354aa6d9f2d36126302fed5f3a73 /dev-php/nikic-php-parser/nikic-php-parser-4.13.2.ebuild
parentfcc5224904648a8e6eb528d7603154160a20022f (diff)
gentoo resync : 20.03.2022
Diffstat (limited to 'dev-php/nikic-php-parser/nikic-php-parser-4.13.2.ebuild')
-rw-r--r--dev-php/nikic-php-parser/nikic-php-parser-4.13.2.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-php/nikic-php-parser/nikic-php-parser-4.13.2.ebuild b/dev-php/nikic-php-parser/nikic-php-parser-4.13.2.ebuild
new file mode 100644
index 000000000000..17ac6a0df823
--- /dev/null
+++ b/dev-php/nikic-php-parser/nikic-php-parser-4.13.2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_PN="PHP-Parser"
+
+DESCRIPTION="PHP 5.2 to PHP 8.0 parser written in PHP"
+HOMEPAGE="https://github.com/nikic/PHP-Parser"
+SRC_URI="https://github.com/nikic/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE=""
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+RDEPEND="dev-php/fedora-autoloader
+ >=dev-lang/php-7.1:*[tokenizer(-)]"
+
+src_install() {
+ insinto /usr/share/php/nikic
+ doins -r lib/*
+ insinto /usr/share/php/nikic/PhpParser/
+ doins "${FILESDIR}/autoload.php"
+}