summaryrefslogtreecommitdiff
path: root/dev-php/onphp/onphp-1.0.11_pre20141124.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-php/onphp/onphp-1.0.11_pre20141124.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-php/onphp/onphp-1.0.11_pre20141124.ebuild')
-rw-r--r--dev-php/onphp/onphp-1.0.11_pre20141124.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-php/onphp/onphp-1.0.11_pre20141124.ebuild b/dev-php/onphp/onphp-1.0.11_pre20141124.ebuild
new file mode 100644
index 000000000000..7c375a214679
--- /dev/null
+++ b/dev-php/onphp/onphp-1.0.11_pre20141124.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit vcs-snapshot
+
+KEYWORDS="~amd64 ~x86"
+
+DESCRIPTION="onPHP is the LGPL'ed multi-purpose object-oriented PHP framework"
+HOMEPAGE="https://github.com/onPHP/onphp-framework/"
+SRC_URI="https://github.com/onPHP/onphp-framework/archive/706ddd5a2a33bd65a13c4e3ec8c46c5ce700133c.tar.gz -> ${P}.tar.gz
+ doc? ( http://onphp.org/download/${PN}-api-1.0.10.tar.bz2 )
+"
+LICENSE="LGPL-2"
+SLOT="0"
+IUSE="doc"
+
+DEPEND=""
+RDEPEND="dev-lang/php:*"
+
+src_install() {
+ rm doc/LICENSE || die
+ dodoc $(find doc -maxdepth 1 -type f -print)
+ if use doc ; then
+ local HTML_DOCS=( "${WORKDIR}/${PN}-api-1.0.10/" )
+ einstalldocs
+ fi
+ insinto "/usr/share/php/${PN}"
+ doins global.inc.php.tpl
+ doins -r core main meta
+}