summaryrefslogtreecommitdiff
path: root/dev-php/pecl-amqp/pecl-amqp-1.11.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
commitfcc5224904648a8e6eb528d7603154160a20022f (patch)
tree3bfce096b38a9cea8eed13fc70c1526c456e9abd /dev-php/pecl-amqp/pecl-amqp-1.11.0.ebuild
parent2fd57282f0262ca084e05b0f2c63fbada395d02b (diff)
gentoo resync : 02.02.2022
Diffstat (limited to 'dev-php/pecl-amqp/pecl-amqp-1.11.0.ebuild')
-rw-r--r--dev-php/pecl-amqp/pecl-amqp-1.11.0.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-php/pecl-amqp/pecl-amqp-1.11.0.ebuild b/dev-php/pecl-amqp/pecl-amqp-1.11.0.ebuild
new file mode 100644
index 000000000000..293de01fbd8b
--- /dev/null
+++ b/dev-php/pecl-amqp/pecl-amqp-1.11.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+USE_PHP="php7-3 php7-4 php8-0 php8-1"
+MY_P="${PN/pecl-/}-${PV/_rc/RC}"
+
+inherit php-ext-pecl-r3
+
+KEYWORDS="~amd64 ~x86"
+
+DESCRIPTION="PHP Bindings for AMQP 0-9-1 compatible brokers"
+LICENSE="PHP-3.01"
+SLOT="0"
+IUSE=""
+
+# Tests require running rabbitmq-server on localhost which requires epmd
+# which only accepts /var/run/epmd.pid as pidfile.
+RESTRICT="test"
+
+BDEPEND="virtual/pkgconfig"
+RDEPEND=">=net-libs/rabbitmq-c-0.7.1:=[ssl(-)]"
+DEPEND="${RDEPEND}"
+PHP_EXT_ECONF_ARGS=()