summaryrefslogtreecommitdiff
path: root/dev-php/pecl-eio/pecl-eio-3.1.0_rc1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-09-19 23:10:29 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-09-19 23:10:29 +0100
commit318828e81fe6707ce5a64e6a59a76d4c0ca709f8 (patch)
treecc4b7818f7960cb193ad2bf7f7defe71adb3ee47 /dev-php/pecl-eio/pecl-eio-3.1.0_rc1.ebuild
parent590c04803f88a968b4a750c0f420eb314e1fe968 (diff)
gentoo auto-resync : 19:09:2023 - 23:10:29
Diffstat (limited to 'dev-php/pecl-eio/pecl-eio-3.1.0_rc1.ebuild')
-rw-r--r--dev-php/pecl-eio/pecl-eio-3.1.0_rc1.ebuild11
1 files changed, 5 insertions, 6 deletions
diff --git a/dev-php/pecl-eio/pecl-eio-3.1.0_rc1.ebuild b/dev-php/pecl-eio/pecl-eio-3.1.0_rc1.ebuild
index 47a57328a455..09c39fede5e8 100644
--- a/dev-php/pecl-eio/pecl-eio-3.1.0_rc1.ebuild
+++ b/dev-php/pecl-eio/pecl-eio-3.1.0_rc1.ebuild
@@ -2,6 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
+
MY_PN="${PN/pecl-}"
MY_PV="${PV/_rc/RC}"
MY_P="${MY_PN}-${MY_PV}"
@@ -15,16 +16,14 @@ DOCS=( README.md )
USE_PHP="php8-0 php8-1"
inherit php-ext-pecl-r3
-KEYWORDS="~amd64 ~x86"
-LICENSE="PHP-3.01"
-
DESCRIPTION="PHP wrapper for libeio library"
-LICENSE="PHP-3"
+S="${PHP_EXT_S}"
+
+LICENSE="PHP-3.01"
SLOT="0"
+KEYWORDS="~amd64 ~x86"
IUSE="debug"
-S="${PHP_EXT_S}"
-
src_configure() {
local PHP_EXT_ECONF_ARGS=("--with-eio" "$(use_enable debug eio-debug)" )
php-ext-source-r3_src_configure